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Startup

1. Startup

1.1 Command Line Startup Options

See also 2.1.3 Command Line Installation Options.

When starting NIS-Elements from the command line (or when editing the desktop shortcut properties), you may
append some switches with parameters to the main command and thereby modify the startup behavior.

Note

Some switches do not have parameters.

Example 1.1. Command line switches syntax

“ NIS-Elements executable” switch#1 parameter#1 switch#2 parameter#2 etc.

For example, to run NIS-Elements and open the starting_image.jp2 at straight away, run.:

"c:\Program Files\NIS-Elements D\nis d.exe" -f "C:\Images\starting image.jp2"
Startup Switches

-? Displays a help screen with the description of switches (basically this page).
-c “Command” The application runs the specified macro Command.

-cam “Camera Name” The specified Camera will be used. When using this option you must also specify the Grabber
Name and the HW Unit Name. To find the camera name, search the application log file for “Camera Name”. It is
also possible to use only a part of the Camera Name, but the part of the name must be unique among all the
available cameras.

-cw “Command Wait” The application runs the specified macro command and waits until it is completed
-f “Filename” The application tries to open the image pointed to by the Filename parameter.

-g “Grabber Name” The image grabber (driver) of the specified Grabber Name will be used and no camera-selection
window will show at startup. Set the parameter value to “last” and the most recently used grabber/camera will be
loaded. As the grabber name, you must use internal name of the grabber, not the one you see in the startup dialog
window.

Either use one of the following names or search the application log file for the phrase “Grabber Name” (see 1.2
Fixed Grabber Startup).

-gn No grabber (camera) driver will be loaded. Image acquisition will not be possible.

-h “HW Unit Name” The specified HW Unit will be used. When using this option you must also specify the Grabber
Name. Two HW Units (e.g. two DS-U2 cameras) can be run by one grabber/driver. The available HW Units are listed
in the Acquire > Select [Camera Name] window. Set the parameter value to “select” and the selection box will be

shown. When using this option you must also use the -g switch. To find the HW Unit Name, please search through
the application log file for “HW Unit Name”.

-i “Config Name” A user can specify the configuration to be used by NIS-Elements. The default configuration is
saved in the “C:\ProgramData\Laboratory Imaging\Platform” folder. If you want to create a custom configuration,
usethe-iswitch,e.g.:nis ar.exe -i "My Configuration".The configuration of thisinstance will be saved
tothe "C:\ProgramData\Laboratory Imaging\My Configuration" folder.

This is useful when using two cameras on one microscope for example. You can create a separate program shortcut
which uses the -i switch to load a different configuration.



-1 “Language” The application will run in the specified language (if available). Use three-letter language codes ac-
cording to the ISO 639 [http://en.wikipedia.org/wiki/List_of_ISO_639-2_codes] standard.

-m “Macro File” The application will execute the macro file (*.mac) pointed to by the Macro File parameter.

-mw “Macro File” The application will execute the macro file (*.mac) pointed to by the Macro File parameter and
wait until it is completed.

-p “Command” [“Param”] The application window will be placed according to the Command. Possible values are:
left, right, top, bottom The window is placed on the corresponding monitor screen.

minimize The software window is minimized to the task bar on startup.
monitor N The window is placed on the Nth monitor.

rectangle (x0,y0,x1,y1) The window is placed in the specified rectangle (in workspace coordinates). The co-
ordinates must be in parenthesis without any spaces.

-passive The application will not connect to any device on startup (NIS-Elements will start with blank Device Manager).
Camera selection is not affected by this option.

-q A new instance of the application will run. By default, only one instance of NIS-Elements is allowed to run.

-s “Settings File” The application will use the specified Settings File to load and save its settings. The settings file
can be created from MS Windows Start menu by the NIS Settings Utility.

-var, -vbr, -vd, -vf For testing purposes, you can switch the application to run as if you have a different version
(AR/BR/D/Freeware) installed. However, you have to have the corresponding licence written in your key (Even if
you normally run NIS-AR, the -vd switch will not work to run NIS-D unless you have also the NIS-D licence).

Note

Mind that the set of functions you will get once the software is run depends on the setup file used for install-
ation (for example, some functions of NIS-D are not included in the NIS-AR setup so these will not appear in
the software run by: nis ar.exe -vd

1.2 Fixed Grabber Startup

Each time NIS-Elements is run or the grabber / camera / HW unit is changed, four parameter values are written to
the application log file (C:\ProgramData\Laboratory Imaging\Platform\Logfiles).:

* Grabber Name

* HW Unit Name

* HW Unit Connection String

e Camera Name

Let's say we want to set the last used configuration for every NIS-Elements start:

1. Lookup the parameters in the most recent log file. E.g.:
Grabber Name CLxGrabberDriverSim

HW Unit Name SimGrabber
HW Unit Connection String (empty)

Camera Name Sim_Camera_Color


http://en.wikipedia.org/wiki/List_of_ISO_639-2_codes
http://en.wikipedia.org/wiki/List_of_ISO_639-2_codes

Startup

. Modify the shortcut, E.g.:

"c:\Program Files\NIS-Elements\nis d.exe" -g CLxGrabberDriverSim -h SimGrabber
-cam Sim Camera Color

. Double-click the shortcut. NIS-Elements will start without asking for grabber selection






Installation and Settings

2. Installation and Settings

2.1 Installation and Updates

2.1.1 The Installation DVD-ROM Content

* NIS-Elements software setup file

* Drivers and utilities for the HASP Key
* Drivers for selected cameras

* User's Guide in the PDF file format

* Sample image database

* Sample ND2 image sequences

2.1.2 NIS-Elements Installation Steps

Caution

You have to possess the administrator rights to your computer to be able to install NIS-Elements successfully.
Quick Guide
* Insert the installation DVD in the DVD-ROM drive. A window automatically appears.
* Install the selected NIS-Elements software version, additional modules and device drivers.
* Plug the provided HASP key into the USB port of your PC.

¢ Run NIS-Elements.



Step by Step

1) When the installation DVD is inserted, a selection window appears automatically.

Imaging Scfware

Browse DVD

Select the software package to be installed. Select the one you have got the licence for and which is properly
coded in your HASP key. The installation wizard welcome-window appears. Click Next to continue.

2) Install Local Options

Figure 2.2. Local Options installation

[ Local Option

Destination Folder

C:\Program FileshMIS-Elements

Select whether to install Local Option or not. Define the folder where NIS-Elements should be installed. We
recommend to use the predefined directory. If you want to change the directory anyway, press the Browse
button and select a new one. Otherwise click Next.

Note

The Local Option installation provides some advanced features which did not pass the quality assurance
procedure yet. We recommend to wait until they are released officially.



Installation and Settings

3)
b anufacturers Carmneraz
[Mikon |l Nikon D5-U3
Andor | Nikon DS-L3
Photometics ] Nikan DS-U2/L2 USE
Qlmaging ] Mikan DS-U2/L2-Ril
Imaging Source | Mikon DS-U1
| Mikon DAC-FS
[ Mikon D5-L1

Now, select the cameras which will be used with NIS-Elements.

Note

When a camera is installed, CPU Power Management C-State is automatically disabled to secure stable
camera operation. Please restart your computer after changing the C-State settings. C-state is automat-
ically restored to its original condition after uninstalling NIS-Elements.

4)

Select the modules pou want ta ingtall, and deselect the modules pou do not want to install
=} D atabase

L] APl (Advanced Interpreter)

| Live Compare

| EDF [Extended Depth of Focus)
W Auto Measure

] Metalo Grain Size

] Metalo Cast lron

1 Industrial GUI

[ Japanese Help

| Chinese Help

If your licence contains some additional modules besides the NIS-Elements core software, please select them
in this window.

Note

Any module selected will be installed along with NIS-Elements automatically. However, you might not be
licensed to use it. The module will run after you get the corresponding code registered in your HASP key.



5)

6)

b anufacturers

[T [ Manual Microscaope
Nikon Ni-E

Friar

Sutter
Marzhauzer, Lang
Ludl, 451

EXFO0, CoolLed
Yincent Associates
Phyzik Instrumente
Others

Devices

»

[ ] Mikon Ni-U

| Mikan Ci

[ Mikon Shutter [NI-5H-COM)

| Mikan Ti

] Mikoon 905, 80, DIH, D-FL-E

] Mikon TE2000

] Mikon LY Series

] Mikon RFA [Remote Focus Aszist)
] Mikon LUSU and A0M

| Mikaon LY Mozepiece Controller

m

Select the devices which will be used with NIS-Elements. Finish the installation by clicking the Install button.

Note

NIS-Elements may not be connected to devices after installation depending on the PC status at installation.
If so, execute the Modify installation command of the Windows Start menu (see the next step) to perform
Repair that corrects the previously installed status.

Warning

For Windows7 users: Some devices do not work correctly after recovery from Sleep mode. Please turn
off the Windows 7 Sleep Mode to prevent possible problems:

O 00 N W N R

. Click Hardware and Sound

. Run the Start > Control Panel command on the main Windows toolbar.

. Make sure the control panel is displayed in the Category mode (View by in the top-right corner).

. In the Power Options section, click Change when the computer sleeps
. Set the Put the computer to sleep option to Never

. Confirm the settings by the Save changes button and close the Control Panel window.

MIS-Elements iz configuring your new software installation.

Inztalling

C:\Program Files\MIS-Elements\wE_anr_imagefaormat_jp2. dil




Installation and Settings

The setup creates a new program group in the Start menu containing the following items: NIS-Elements applic-
ation shortcut, the HASP key information shortcut, the Modify Installation shortcut (for adding hardware drivers,
modules, etc.), the Uninstall procedure, and the Send Info Tool. A shortcut to NIS-Elements is created on the
desktop too. These changes affect all user profiles of your local Windows operating system.

Figure 2.7. Start menu

MNIS-Elerments

¥ HASP Info

W HASP Update

BN Modify installation
E&) s Settings Utility
NIS-Elements AR
@ Uninstall

Note

Clicking the Uninstall command deletes all installed files from disk, and removes the NIS-Elements program
group from the Start menu as well as it removes the desktop icon.

2.1.3 Command Line Installation Options

See 1.1 Command Line Startup Options for details about how to use command line switches. The following switches
are to be used with the NIS-Elements installation file to modify behavior of the installation wizard.

-all This parameter unhides options in the setup which are hidden by default. It concerns mainly drivers of devices
which were formerly supported but are no longer available.

-new If this command line parameter is appended, the setup checks if any other setup has already been installed.
If so, the setup restarts and runs in an independent mode. The update mode is disabled. This enables to install
two or more builds together on one operating system.

-xp This parameter enables the user to install NIS-Elements on Windows XP even though this operating system is
NOT supported officially.

2.1.4 Additional Module/Device Installation

You may need to install a device or an additional module after the NIS-Elements main system installation.
* Go to [Start menu > Programs > NIS-Elements] program group.

* Select the Modify Installation command.

¢ Follow the installation wizard instructions. Select the check-boxes by the items you would like to add.

¢ Finish the installation.



2.1.5 Sample Database Installation

If you chose to install the Sample Database, a new subdirectory “Databases” is created inside the NIS-Elements
installation directory (e.g. C:\Program files\NIS-Elements \Databases\...). The “Sample_Database.mdb” file is
copied to there along with database images (stored in subdirectories). An administrator username/password to
access this database is set to:

¢ Username: “sa”

¢ Password: “sa”

2.1.6 Software Copy Protection

NIS-Elements is delivered with a hardware key (also called HL = hardware licence or HASP).

Figure 2.8. Hardware key

The key contains information about the software licence and allows users to run the corresponding software. A
warning message is displayed when user starts NIS-Elements with an incorrect hardware key. Please do not connect
the USB hardware key until after the software installation is finished. The utility called HASPinfo is installed to the
installation directory. It enables the user to view information about the software licence and is accessible via the
Help > HASP Info menu command. See also 2.5 Hardware licences.

2.1.7 Device Updates

The main goal of the Device Updates setup is to add new devices/cameras or to fix problems that are localized in
the drivers only and do not affect any other NIS-Elements functionality.

Device Update setup requires installation of the corresponding NIS-Elements version. The setup contains only .dll
files supporting a new device or some corrections and upgrades of already existing drivers. This update form keeps
NIS-Elements stable and the update file size small.

Device Update numbering is consecutive and appropriate to its NIS-Elements version until a new full setup of NIS-
Elements is released (Major version, Service Pack or HotFix) - then the numbering starts from the beginning.

Device Updates are cumulative and contain all the changes from the previous updates. Also full NIS-Elements
setups (Major versions, Service Packs and HotFixes) will contain all the changes from the previously released Device
Updates.
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2.1.8 Fixes

Fixes represent driver changes which serve for testing purposes or for correcting problems occurring only under
special conditions. Fixes are packed into a zip file containing modified driver files. Fixes are usually user requested,
therefore they are not considered as Device Update candidates.

2.1.9 Installing the Database Module on 64-bit Systems

The NIS-Elements installation file contains 64bit MDB drivers which improve the speed of the database module on
64bit systems. However, 32bit version of MS Office 2010 cannot be used along with these 64bit drivers. You can
install these drivers, if:

¢ you run 64bit version of MS Office 2010
¢ you use other version of MS Office such as Office 2013

¢ you do not use MS Office at all

Find the drivers in the NIS-Elements folder, typically: “C:\Program Files\NIS-Elements\Drivers\Database_MDB\”

2.2 Additional Modules Available in NIS-Elements D

2.2.1 Acquisition and Analysis Modules

EDF Module (Extended Depth of Focus) The EDF module allows you to combine an existing Z-stack of images into
one focused image by picking the focused regions from each frame and the pieces together.
High Dynamic Range This module brings the functionality of capturing and creating HDR images within NIS-Elements.

INTADV (Interactive Advanced Macro - API) This module dramatically extends the macro programing capabilities
of NIS-Elements. It contains a set of user-interactive macro functions and the ability to import functions from external
DLLs.

LCOMP (Live Comparisons) This module provides several comparison modes which can help to identify and visu-
alize differences or similarities between two images.

MEAS (Automatic Measurement) This module extends the measurement abilities of NIS-Elements by adding
number of automatic processing features. Particularly, it enables users to threshold the image and process and
measure the binary layer. See also 8.3 Automated Measurement.

2.2.2 Industrial Modules

Concrete (requires: Local Option)
This module is for automated and semi-automated measurement of air void characteristics of hardened concrete.

Filters Particle Analysis (requires: 64bit NIS-Elements) This industrial module is aimed at analysis of filters according
to the ISO 16232 standard.
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Industrial GUI After the Industrial GUI module is installed, the View > Simple Control command is added to the
application. The command activates a simple layout intended to be used in industry imaging applications.

See 3.7 Simplified User Interface

Layer Thickness This module adds the Applications > Layer Thickness Measurement > Measure Layers command
to the main menu. The module can perform different types of layer thickness measurement.

Measurement Sequencer With this module, you can:
* Create custom measurement sequences.
¢ Install predefined measurement sequences suitable to measure welds of different shapes.

¢ Install predefined measurement sequences suitable for hardness measurement (Vickers, Brinell, Knoop)

Metalo - Cast Iron Analysis After the module installation, the Applications > Metallography > Cast Iron command
appears in the main menu. Run this command to display the cast iron measurement layout.

Metalo - Grain Size Analysis Adds the Applications > Metallography > Grain Size command to the main menu. The
command displays a layout dedicated to grain size measurement.

2.2.3 Device Modules

Digital Mirror Device (requires: Local Option) DMD support. E.g.: Nikon Ti-Lapp, Andor Mosaic 3, Mightex Polychrome
400.

Dual Camera Support Support for dual camera drivers (two mono cameras behaving as a single dual-channel
camera). Specific camera models are supported.

Monochromator (requires: Local Option) Thirdparty monochromator support. E.g.: Till Photonics Polychrome V.
Revolution DSD (requires: Local Option) Andor Revolution DSD confocal support.

SFC (requires: Local Option) Swept field confocal support.

Slide Loader (requires: Local Option) This module enables NIS-Elements connect and control a slide loader.
Splitter DV Dual View and Quad View support.

Stage This module enables to connect and control motorized XY stages. All non-Nikon stages require this module.
Stage Incubator This module enables to connect and control gas and temperature-controlling chambers.
Structured Light (requires: Local Option) Support of structured-light-based devices (OptiGrid, ViCo).

Sutter Third party filter-wheels support.

TTL/Analog 10 This module enables NIS-Elements to send and receive TTL and analog signals via a DAQ board.
Wavelength Switcher This module enables NIS-Elements connect and control wavelength switchers.

Well Plate Loader This module enables NIS-Elements connect and control a well plate loader.

X-CITE Third party illumination device support.

Z Drive This module enables connect and control motorized Z drives.

See also 4.1.6 Connecting a Device to NIS-Elements .
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2.2.4 Other

64bit NIS-Elements Some functions and applications run only under the 64bit version of NIS-Elements. Unlike with
32bit applications, the size of memory available to a single application is not restricted on 64bit.

DBASE (Database) If the database module was installed, the system can create and control image databases. A
database can help you to efficiently organize your image archives and manage additional information related to
the images.

Local Option When Local Option is installed (see Step 2), NIS-Elements will provide some advanced features which
did not pass the quality assurance procedure yet. We recommend to wait until they are released officially.

MS Excel NIS-Elements supports export of results straight to an MS Excel sheet (see 8.1.7 Exporting Results). MS
Excel is not part of the NIS-Elements and must be purchased and installed separately.

2.3 User Rights

User management is very useful when a single workstation is shared by number of users. Some user accounts may
have administrator rights to NIS-Elements while other's privileges are quite restricted. A per-person system may be
established or user accounts may be shared. The following principles are utilized within NIS-Elements:

MS Windows accounts support NIS-Elements can assign privileges to MS Windows accounts. Whoever is logged
in the operating system and runs NIS-Elements obtains a default set of privileges. System administrator can then
further restrict or extend the user's rights.

NIS-Elements password protection It may be not comfortable enough to log the current user off from MS Windows
when a user change is required in NIS-Elements. For such case a completely independent list of user accounts,
which is not connected with MS Windows users, can be created. Then just restart of NIS-Elements is needed to
switch the user.

Private vs. Shared storage Every user-created item (setting) important in the work-flow can be protected from un-
wanted change in two levels. First, the creator of the item (optical configuration, layout, objective, etc.) can save it
as private. Unless its status is changed to shared, no other user will even see this item within the lists throughout
the application. The second level of protection concerning all shared items is provided by assigning users to Groups
and Privileges groups.

Groups Every user is a member of a group. The group enumerates shared items (Hardware Configurations, Objectives,
Layouts, etc.) which will be visible for its members. NIS-Elements administrators can create any number of groups
and select the items to be visible.

Privileges There are basic groups of privileges which allows users or restrict them to perform certain actions. This
concerns for example modifying macros, reports, selecting cameras, etc. There are four levels of privileges by default,
but further can be created by an administrator:

¢ Admin
¢ Common
* Guest

¢ Default
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2.3.1 NIS-Elements authentication

If you have chosen “ NIS-Elements (Password protected)” user authentication method, a login dialog window appears
at every start-up of NIS-Elements. Enter a user name and a password for existing user account. If the option Allow
Create New User on Startup is enabled, you can create a new user account without needing an administrator. This
account is assigned to the Default group of users and Default group of privileges automatically.

2.3.2 Creating a Shared Layout

Please read the following example on user management. Step by step, we describe the creation of a shared layout
which can not be modified by members of the Common and Guest groups.

1)

2)

3)

4)

5)

6)

7)

Run the View > Layout > Layout Manager command. Set at least one of the defined layouts as Shared. (see
3.1.3 Arranging User Interface)

In the left column of the window, select User Rights.

Make sure you are logged as a user with the Privileges to Modify user rights. If not, use the |Login As| button
to log in under a different account which has the privilege.

Set layout visibility

Select the Groups tab. Here you can see at least one group of items called Default. Either select one a group
or create a new one by the New button and choose Layout within the list of items. All layouts set as shared
will be listed on the right side within the Accessible items field. Make sure the check boxes next to the layouts
which you allow to be used by the group are selected.

Disable layout modification

Select the Privileges tab. Select the group of privileges which should have not the permission to modify the
selected shared layouts. In the Privileges field on the right, make sure you de-select the Modify Shared Layouts
option.

Apply the new policies

Select the Users tab. In the list of users, select the ones which you would like to apply the policy to (users can
be selected one by one or by multi-selection with the Shift | or Ctrl |key pressed). Then, assign the appro-
priate Group and Privileges by selecting them from a pull-down menu on the right side of the window.

Confirm the changes by the |Apply| button.

2.3.3 Closing Another Instance of NIS-Elements

Only one instance of NIS-Elements can be running on one computer. If a second user starts NIS-Elements when
another instance of the program is already running, the following dialog appears.
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Figure 2.9. Another instance running

Another Instance is Running : @

Another instance is currently running under

a different user.
If you want to terminate the instance of another
user anyway, dick Force to Close,

Force to Close

The user can press the Force to Close button to close the running instance. This option is only available if there is
no acquisition experiment in progress.

2.3.4 User Rights Options

User Authentication The Windows authentication utilizes Windows accounts to automatically log in to NIS-Elements.

The NIS-Elements (Password protected) authentication utilizes application user accounts and passwords at the
start-up of NIS-Elements. Check the Allow Create New User on Startup option to enable creating of a new user in
the Login dialog window.

Current user Displays currently logged in user.

Log As Opens the Login As dialog which enables you to login as a different user e.g. an administrator with more
user rights for the purpose of changing User rights settings.

Figure 2.10. Login As
Login As L @

Login As is valid temporarily and only for the User
Manager settings. An application restart is reguired
for changes to take effect.

Log on to: FIRMA

User name: l Karolina.Macuchova E]]

Password: ’ e ]

Select the user name you want to log-in as from the drop-down menu. Enter a valid password and press OK|. The
new user identity is available only while the User manager is opened.

Statistics Edit path and file name of a database file for saving statistics.

Export/Import user rights These buttons enable anyone to save/load complete settings of user accounts and their
privileges to/from an external XML file. Standard Open and Save As windows appear. Having the data exported
may be useful when copying the settings to other computers.
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2.3.5 Users Tab Options

New Enables to create new NIS-Elements user account. You have to posses the privilege Modify User Rights.

Figure 2.11. Creating new user
Mew User Iﬁ

User name: [ guest ]

Group: [hall B]

Privileges: [Guest B]

Password: l FEEEEE l

Confirm password:’ P—— l

[ Enforce user to change his password at start-up

[ gete |[ cose |

Enter a new user name, assign him to one of the existing Groups and group of Privileges and set the password.
Check the Enforce user to change his password at start-up option to make the user change his password at his
first login into the NIS-Elements.

User name and password properties

Length of the user name and password is limited to 50 characters. You can use any combination of characters,
symbols or numbers (except the Windows ones: ", :, *, 2, "\, /, <, >, |").

Remove Removes selected user account. You can select multiple accounts and delete them at once.

Copy To Choose a user from the pull down menu whose group and group of privileges will be changed according
to settings of a selected user.

Duplicate You can easily create a new user by duplicating the existing. This preserves all account settings under
a different name. If you have selected to duplicate more then one user, enter a name prefix, which is added in front
of the original name for all selected duplicated accounts. User which was created as a duplicate has an empty
password and is forced to change his password at next application startup.

User Accounts List This table displays all existing user accounts. You can sort them according to any of four columns.
The first column displays type of the account. The second one shows user names. The third one displays assigned
group of users. The fourth one displays assigned group of privileges. Select one or more users whose settings needs
modification.

Set password To change password of a selected NIS-Elements user account, press the Set password button. You
have to posses the Privilege Modify User Rights. Otherwise you can change only password of the current user. Fol-
lowing window appears:
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Figure 2.12. Reset of password

Change Password A @

User name: [ guest ]

Mew password: [ Je— ]

Confirm new password: [ R R ]

| chenge || cand |

Name of the user is displayed. Enter and confirm new password. When done, press the Change button.

Enforce user to change his password at start-up Check this option to make the user change his password at his
first login into the NIS-Elements.

Enumerate All Windows Users This button starts copying MS Windows accounts to NIS-Elements. The accounts
are assigned to user groups (admin, common, guest) according to their Windows permission settings.

2.3.6 Groups Tab Options

Figure 2.13. Groups tab

Currentuser: Michal. Zezula

| Users | Groups |Privileges |

+ New 3 Remove [ CopyTo = [ Duplicate Chedc Al [] Uncheck Al
Default Accessible items
B Lab_1 [+] AZ Plan Apo 1x
Optical Configurations 1 Plan Apo 100x Gil Ph3 DM
Objectives [ Plan Apo 10x

[=1 Plan Apo 40x Ph2 DM

Cameras L
[[] SR. Apo TIRF AC 100xH

Devices
Layouts
Macros
Reports
Lab_2
Guest

New Enables to create new group of users. You have to posses the privilege Modify User Rights. Enter a name of
new group.

Remove Removes selected groups. You can select multiple groups and delete them at once.
Copy To Choose a group from the pull down menu which settings will be changed according to selected group.

Duplicate You can easily create a new group of users by duplicating the existing. This preserves all group settings
under a different name.
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List of Groups All defined groups are listed in this window. Each group contains subsets. If you click on a subset,
its items appear in the Accessible items list.

Accessible items This list shows items of a selected subset. Every item has its own check box. If the check box is
checked, all users assigned to the corresponding group will see the item. Otherwise they will not see the item.

Optical Configuration Displays all shared optical configurations.
Objectives Displays all shared objectives.

Cameras Displays all installed cameras. From the pull down menu below select a camera which is used as
default for users without the privilege Select Camera.

Devices Displays all installed devices.

Layouts Displays all shared layouts.

Macros Displays all shared macro commands. Check a macro to make the content of it visible to this Group.
Reports Displays all shared reports and report templates.

Sequencer Definitions Displays all shared Measurement Sequencer definitions.

2.3.7 Privileges Tab Options

Figure 2.14. Privileges tab

Users |Groups Privileges
+ New 3¢ Remove [ CopyTo v [ Duplicate [ Chedk all ["] Uncheck all

" Groups of Privileges | " Privileges

Guest ] Modify user rights

Common ] Modify shared objectives
Admin ] Modify shared optical configurations
Default ] Modify shared layouts

[ Modify devices

[ Select camera

[] Modify shared macros
[] Modify shared reports
] Modify camera light path

New Enables to create new group of privileges. You have to posses the privilege Modify User Rights. Enter a name
of new group.

Remove Removes selected groups. You can select multiple groups and delete them at once.
Copy To Choose a group from the pull down menu which settings will be changed according to selected group.

Duplicate You can easily create a new group of privileges by duplicating the existing. This preserves all group settings
under a different name. If you have selected to duplicate more then one group of privileges, enter a name prefix,
which is added in front of the original name for all selected duplicated accounts.

Groups of Privileges A list of all groups of privileges is displayed.

Privileges A list of privileges is displayed. Every item has its own check box. If the check box is checked, it grants
all users assigned to the corresponding group relevant privilege to access, change, modify, etc.
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Note

Users that do not have the privilege “Modify Shared Optical Configuration” can temporarily change the
brightness settings (e.g. exposure time, gain, etc.) in a shared optical configuration and use such adjusted
optical configuration for example in Multichannel acquisition. But all such modifications will not be stored and
they will disappear when the application is restarted.

2.4 NIS-Elements Preferences

2.4.1 Adjusting Program Preferences

1) Run the Edit > Options 'I:l' command. The Options dialog window appears.
2) Select a tab which contains requested options. Options are sorted into several groups:
General Options concerning basic image operations. See 2.4.2 General.
Appearance Options concerning the graphical user interface. See 3.6 Appearance Options.
Open Next Options concerning the File > Open/Save Next > Open Next menu command.
Save Next Options for the File > Open/Save Next > Save Next B command.
Macro Configures key shortcuts to macros and sets macros to run automatically on startup See 10.6 Macro
Preferences.
Measurement See 8.1.4 Measurement Options for more information.
Data export See 8.1.7.2 Data Export Options for more information.
User rights See 2.3 User Rights for more information.
Layout Manager See 3.2.1 Layout Manager for more information.
3) Make any changes you need in preferences and use the following buttons to manage them:
Defaults for this Page Restores default settings of the currently displayed options tab.
OK Confirms and saves changes made to the preferences. The dialog window is closed afterwards.
Cancel Cancels all changes made to the preferences. The dialog window is closed afterwards.
Apply Applies changes made in preferences but keeps the Options dialog window open. You can apply changes
individually on each tab.
Help Displays the relevant help page.
2.4.2 General

Documents and History
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Use fix path for images The defined directory is always used when using the File > Open @ or File > Save
As command.

Allow only one opened document If checked, only one document at a time can be opened.

Limit number of opened documents When this options is checked, the user is limited to a single opened image
at one time.

Capture always creates a new document If checked, every acquisition creates a new image.

Use last LUTs on image open When a new image is opened, this option turns the look up tables automatically
on, and copies the settings from the current or the last opened image. Some image formats (JP2, ND2) can
contain the LUTs settings. If such image is opened, the saved LUTs are loaded instead of the most recently
used.

Use AutoLUTs on image open for images without LUTs information This option keeps the AutoLUTs feature
of the File > Open @ window always ON, and it applies AutoLUTs to the image after opening. This option is
ignored if LUTs settings are saved in the image, or if the Use last LUTs on image open option is applied.

Show mapping dialog in organizer after drag and drop Displays the Mapping window every time an image is
inserted to a database table. It enables you to check/modify mapping of the image info values to the database
table fields.

Open new ND views to new window Displays each newly generated ND view in a separate window.

Enable authentication Authentication verifies each image frame and detects changes in image data made

after acquisition. Modifications are indicated in the Image Properties dialog. See File > Image Properties.
Note

Authentication works with images acquired by the Capture button, the ND Acquisition dialog(s) or using
the JOBS module.

Show image info window on save Displays the File > Image Properties window every time an image is saved
via the Save As command.

Detect sequence on image open When you select to open an image that is a part of image sequence such
as 001.JP2, 002.JP2..., it is recognized automatically and you are offered to convert it to an ND2 file.

Show binary layers' contours Check this item to display contours of binary layers.
Use zero based time scale for ND documents Select this option to ensure that the first frame of a time sequence
will always start at 0.0s.

State of saturation indicator after start Select what to do with the saturation indicator settings ( |/~ ) after
NIS-Elements is restarted. Turn it ON, OFF, or remember the last setting.

Rotation, Flips and Shifts
Apply to overlaid binary layer If checked, in overlay mode both binary and color images are rotated, shifted
and flipped.

Optical Configuration

Save changes to optical configuration automatically Make changes to the current optical configuration
without warning? If selected, some setting changes are written to the optical configuration immediately and
the exclamation mark would not appear by the OC name. Select the settings to be changed without warning:

Exposure Only Camera exposure time only.

All Camera Settings All camera settings such as exposure, gain, resolution, etc.
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All Brightness Settings All Camera Settings plus selected settings of illumination-related devices such
as laser power, light power, etc.

Select corresponding optical configuration when filter or nosepiece changed Enabled if “Unselect” in the
option below is chosen.

Allows NIS-Elements to automatically change the optical configuration based on the filter or nosepiece selected
on the microscope.

When Optical Configuration setting changed

Keep Selected The Opt. configuration name is marked by the “*” sign and the change is offered to be
saved.

Unselect Every change of Optical configuration setting results in its deselecting and switching to user
settings.

Save all changes All changes regarding the Opt. configuration settings are updated automatically according
to the current state.

Temp NIS-Elements uses the Temp directory for storing temporary data when there is not enough RAM available.
You can redirect the system to use a directory on another hard disk, which may speed up the whole system.

Defaults for this Page Restores the default setting for General Options.

2.5 Hardware licences

2.5.1 What is a hardware licence?
Together with the NIS-Elements software package you received a hardware USB key - so called hardware licence

(HL) or HASP. This key contains information about your software licences. If the USB key is not inserted into the
computer USB port or if the key does not contain the appropriate licence NIS-Elements cannot be executed.

Figure 2.15. Hardware USB key

Note
Formerly the USB key was called “HASP key” often abbreviated to “HASP”.
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2.5.2 How do | find out the content of my USB key?

To verify the contents of the licence recorded on your USB key, service tool called HASP Info is installed together
with NIS-Elements.

1. Insert the USB key into your PC.
2. Go to the Start menu of your operation system and search for the installed NIS-Elements folder.

3. Click on HASP Info inside this folder. Window containing information about your key (modules which can be ex-
ecuted using this key) is shown. See also 2.2 Additional Modules Available in NIS-Elements D.

Note

Displayed information can be saved into a text file (*.txt) using the |Save info| button. Sending this text file
(e.g. to the technical support) is the easiest way of conveying the full information about your USB key. This
can be useful for verifying whether a specific function is available with your current licence.

2.5.3 Is there an update for my software?
New updates of NIS-Elements are released to serve as a tool for:

* expanding the software functionality

* adding the support of new devices (cameras, microscopes, etc.)

* bug fixes

You can easily find out whether an update is ready for your NIS-Elements version:

* If the computer running NIS-Elements is connected to the Internet, execute Help > Check Version Update from
the program main menu. A web page with information about your USB key is automatically loaded inside your
browser.

* Frequently the laboratory computes are not connected to the Internet. In such case write down your licence
number (USB key), find a computer having Internet connection, go to this web page: http://www.nis-elements.cz/ver-
sion and fill in the form using your licence number.

Version List of released program versions compatible with the USB key.
Release date Release date of the particular version.
Available for free Is the software update available for free? If so, “Yes” is shown in the column.

Available after purchasing For updates not available for your original licence, “Software Upgrade Agreement” (SUA)
has to be ordered.

2.5.4 What is SUA?

SUA - “Software Upgrade Agreement” is a time limited agreement enabling the owner of the NIS-Elements licence
to update the software during the next 12 months for free. The business model works as follows:

» After buying the licence to NIS-Elements it needs to be activated. Once activated the activation date is recorded
into the manufacturer's database.
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* From this activation date you get a 13 months period during which all updates (even updates to new software
versions) are available for free.

* After the expiry of the 13 month period from the activation date, all new updates are available only after buying
a SUA. 1x SUA = free updates for the next 12 months.
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User Interface

3. User Interface

3.1 Advanced Layout

Figure 3.1. NIS-Elements Advanced Layout
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Context menu over the Advanced tab enables to load original settings of the selected predefined layout (Load Default),
lock the selected layout so that its components cannot be moved or closed (Lock Layout), Save Current Layout As
a new layout or open the Layout Manager (3.2 Modifying Layouts).

3.1.1 Main Window Components

3.1.1.1 Main Menu

All NIS-Elements functions are accessible from the main menu at the top of the screen. Menu commands are
grouped according to their purpose.

3.1.1.2 Toolbars

There is a default set of toolbars, each toolbar containing number of buttons. There is also one fully customizable
toolbar - the main left toolbar - to which any button can be added. Every button or whole toolbar can be hidden by
the user. Please see 3.1.3 Arranging User Interface for further details.
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3.1.1.3 Status Bar

The status bar at the bottom of the screen displays the following information:

Figure 3.2. The application status bar

Full Screen ¥, Dacked Controls* /|- Color [Contrast(0,0,95,0,7); [Plan Apo 10x (0.00 n [X¥=[0.000, 0.000]mm, Z=499.96pm
1 2 3 4 5

1. This part of the status bar displays available layouts.

Note

The layout Tabs may be hidden when the Show Layout Tabs option in the 3.1.3 Arranging User Interface
window is deselected.

2. This status bar section displays the type of the currently selected camera.

3. Here you can get information about the most recently performed command. The FPS / Exposure / Focus info is
shown in case of live image. The black bar indicates the focus rate. Longer black bar represents more of the
image in focus.

4. This section show the name of the current objective.

5. Current coordinates of XY (Z) stage are shown in this part of the status bar.

3.1.1.4 Docking Panes

Docking panes are square spaces inside the application window, where you can place (dock) any of the control
panels. There is one docking pane available at the Right, Bottom, and Left side of the application screen.

To Display a Docking Pane

1. Go to the View > Docking Panes sub-menu and select the pane you would like to display.

Docking Panes O Left Cirl+Alt+Hum4
[0 Right Ctrl+Alt+Mum6
Analysis Controls } ||| Bottom Crl+Alt-+Hum2

-

Acquisition Controls

Note

The Docking Panes sub-menu can be also displayed by right-clicking into the empty application screen.
2. The docking pane appears, either empty or with some window(s) docked inside.
3. Repeat this procedure to display more docking panes.

Handling Control Panels

Various control panels can be displayed docked within the docking panes or they can be floating. See the following
picture:
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Figure 3.4. The Docked Control Panel Caption
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To handle the control panels (CPs), you can:

Open recently closed CP Locate the €B) button on the main left toolbar. When you click it, the list of recently
closed CPs appears. Pick one to display it again.

Add CP to a docking pane Right click inside a docking pane (3) to display the context menu. Select the control
panel to be displayed. If the window is already opened somewhere else (in another docking pane or floating), it
closes and moves to the new destination.

Close CP Click the cross button (2) in the right top corner of the tab.

Drag CP Drag any CP by the tab and drop it somewhere. If you drop it by the edge of a docking pane, it will create
another column of this pane. If you drop it over the caption of another CP, it will be docked in the same pane as a
new tab. If dropped somewhere else, the CP will be floating.

A color frame appears when you place the mouse cursor dragging a CP over the edge of a docking pane or a caption
of another CP. It indicates that if you drop it, its placement will be handled automatically.

Minimize the docking pane Click the arrows in the top left corner. The pane minimizes to a stripe by the edge of
the screen. It can be restored to its original position by double clicking this stripe or by clicking the arrows again.

Close the docking pane Click the cross button (4) in the docking pane caption. Or you can right click the pane and
unselect the Docking View option.

Dock/undock CP To dock (and undock) a CP, double click its tab.

Display CP Another way to display a CP is to go to the View menu and select the desired control panel. After that,
the CP appears on the screen - floating or docked. Positions of the windows are being saved by the system so that
each control panel appears in the same position as it was before it being hidden. The controls are sorted to several
groups.

Acqguisition Controls 4

Analysis Controls 4

Visualization Controls @ Controls

Macro Controls 4 |__ Histogram Cirl+Alt+H
4 LUTs Cirl+Alt+H.

Shrink/Expand dockers Having more docking panes opened, a situation where there is not enough room for the
control panels can occur. In such case, as you can see in our example, the Shrink bottom (green color) or Expand
bottom (red color) commands shall be used.
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1. Right click the pane you would like to shrink/expand. A context menu appears.

2. Select p.e. the Expand /Shrink right command. When one of the panes shrinks, the neighboring pane expands
to the emptied corner and vice-versa.

3.1.2 Image Window

Tools affecting the appearance of the current image are gathered within the image window toolbars (the top image
toolbar and the right image toolbar). There are the following buttons by default:

LY Enable LUTs (L) Applies LUTs to the image. See 6.5 LUTs - Non-destructive Image Enhancement.
1?2 Keep Auto Scale LUTs Applies the AutoScale command to the image continuously.

N Auto Scale Performs automatic setting of LUTs.

X Reset LUTs Discards the LUTs settings.

E Show LUTs window Opens the window with LUTs.

M Pixel Saturation Indication (Ctrl+Shift+S) Turns on/off pixel saturation indication without setting on/off LUTs.
Select the highlighting color from the nearby pull-down menu for Oversaturated pixels and/or Undersaturated pixels.
See 6.2.3 Channel Coloring.

[@ Open Attachment Opens a file previously attached and saved with the ND2 file. To attach any file to an image,
right-click inside the image, select Add Attachment and choose a file to be attached. Maximum size of the attached

file is 64 MB. Context menu over the image also enables to Open Attachment... (same functionality as the @
button), Save Attachment As... (saves the attached file separately) or Remove Attachment (attachment is removed
from the ND2 file).

Switch to Main View, [l Show Slices View, [0 Show Volume View, 52 Show Tiled View, []* Show Maximum
D ==

Intensity Projection, [l Show Maximum Intensity Projection When working with the ND images, these functions
become available.

For more information see 6.3.2 ND Views.

Enable Dynamic Threshold Activates the dynamic threshold in the image.

<§> Mouse XY Requires a motorized stage. If turned on, the mouse cursor on a live image changes and you can
control the XY stage by dragging the live image.

W cCreate Focused Image Creates an EDF focused image.
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WY Create EDF Focused Document Creates a new simple focused image from an ND file.

Jf,;‘ Show EDF Z-profile Opens the EDF Z-profile panel with the Z-profile graph of the image. See View > Analysis
Controls > EDF Z-Profile [z .

) Show EDF Z-map Creates a new image displaying the EDF Z-map. Opens the Z-map setting window, where you
can choose the Z-map method. Press OK and the new focused image is created. See Applications > EDF > Show
Z-Map Image.

Show EDF 3D Surface View Opens the 3D surface view of the image. See Applications > EDF > Show Surface
View & .

bd Show EDF Anaglyph Enables/disables Anaglyph 3D view. New options appear in the toolbar - you can define
the position of the first frame (Lowest/Highest), Style (the color combination used for anaglyph image), Effect
(Descend into the Screen / Rise from the Screen) and Z-zoom (define the percentage).

% Refresh ND View Refreshes the ND view.

Fit to screen Adjusts zoom to view the whole image within the NIS-Elements screen.

Best Fit Adjusts zoom to fit the image window in one direction and fill the available area with the image.
1:1 1:1 Zoom Adjust zoom so that one pixel of the image matches one pixel of monitor.

@ Zoom In Increases magnification of the image.

(=) Zoom Out Decreases maghnification of the image.

D Show Probe This button activates the probe. The probe affects histograms, auto exposure and auto white balance
functions.

HH show Grid Displays the grid for indicative measurements.

',Tm' Show Scale Displays the image scale.

I_, Show Frame Displays and applies the measurement frame. (requires: MEAS (Automatic Measurement))
@ Turn ROI On/Off Displays the Measurement Region Of Interest. (requires: MEAS (Automatic Measurement))

% Show Profile Displays the Measure > Intensity Profile % control panel. It allows you to specify a linear section
in the image of which the pixel intensities graph will be created.

ﬂ; View LUT Intensity Displays the scale of intensities used inside the image. It works on monochromatic images
or a single image channel.

A Show Annotations (A) Displays the vector layer which typically consists of annotation objects (text labels, arrows)
and measurement objects.

m View Binary Displays the binary layer of the image. (requires: MEAS (Automatic Measurement))
ﬂ View Color Displays the color layer of the image.

E View Overlay Displays the color layer and the binary layer in overlay. (requires: MEAS (Automatic Measurement))

Tip

Right click the icons to invoke a context menu where properties of each tool can be modified.
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Channel Tabs

Figure 3.7. Channel tabs of an RGB image

RGE % M Red /M Green ) B Elue

Channel tabs at the bottom left corner of the image window enable switching between image channels. You can
also edit their properties using commands available via a context-menu. See also 6.2 Image Layers.

Status Bar

The status bar at the bottom of the image window displays the following information:

Figure 3.8. Status bar of the image window

[0,34pmjpx [RGB 8bit: 1232 x 972 pixels (653, 454] RGE: (107, 135, 141)
1 2 3

1. The first field of the image window status bar Image displays the calibration. See also 8.1.1 Calibration, 8.1.1.3
Units.

2. Image bit depth (8bit, 12bit, 16bit, etc.) followed by Image size. You can change the displayed units from the
context menu.

3. Pixel coordinates of the mouse cursor along with channel intensities, Binary layer value (O or 1) and the Color
mode (RGB, Monochromatic, etc.).

3.1.3 Arranging User Interface

Having a well organized application layout can help you make the work with NIS-Elements very effective. There are
the following options on customizing the appearance of NIS-Elements:

Custom window placement All control panels (Camera Settings, Measurement, Histogram, LUTs, etc.) can be ar-
ranged inside or outside of the main application window.

Compact window or multiple windows The control panels as well as toolbars can be floating or docked on sides
of the application screen.

Multiple monitor support The NIS-Elements window can be stretched to occupy two monitors. When you switch
from different application, NIS-Elements will be activated on both monitors.

Customized toolbars Toolbar buttons may be added and removed from toolbars. See 3.3 Modifying Toolbars.

Maximizing the Image Area You can hide some of the GUI elements which are displayed by default:

* The channel tabs and the layout tabs may be hidden to save some screen-space. Display the 3.6 Appearance
Options window and de-select the Show Channel Tabs and the Show Layout Tabs options.

* Image controls and the image status bar may be hidden. Use the Common for all images, auto hide bottom
toolbar option of the 3.6 Appearance Options window.

* When an image is displayed in great magnification, scroll bars automatically appear by the sides of the image
window. You can hide them by de-selecting the Show Scrollbars context menu option.
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3.2 Modifying Layouts

A layout in the context of NIS-Elements is a set of options describing the arrangement of control panels, tool bars
and menu items.

To Create a New Layout

. Select the Advanced layout.
. Right click the tab and select Save Current Layout As.
. Write the new layout name and confirm it by | OK|.

. A new layout is created.

o A~ W N P

. Modify the layout so that it suits your concept of work. You can add or remove control panels, tool bar buttons
etc.

6. Right-click the tab of the new layout and select Save from the context menu.

3.2.1 Layout Manager

Run View > Layout > Layout Manager to display the Layout Manager. The list of currently available layouts is placed
on the left side of the layout manager. Each layout may contain information about controls, toolbars, menu, and
commands to be performed when switching between layouts.

Figure 3.9. List of Layouts

D% 3] & 9] €| B/

| Description | Storage
= Global Layout Private hd
- |Controls
-[«]Toalbars
-] Menu
- | Commands
BE[+]rCompact Private E
-[w] Controls
-[«]Toalbars
-] Menu
- | Commands
E[#]Advanced Private E
-[«]Controls
- |Toolbars
[ |Menu

- | Commands

Modifying the Layout Settings

1. Select items within the Global Layout list which you want to be shared by all layouts.
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2. The check marks on the left of the layout names indicate the layout visibility. Select the ones you want to display
in the application status bar.

3. If an item within some particular layout is not selected, it means you do not want to customize it and the global
settings - if selected within the Global Layout - will be used. If the item is not selected within the Global Layout
either, the settings of the most recently active layout will be used.

4. Set whether the layout is Private or Shared. If set Private, it will not be visible for other users. See 2.3 User Rights.

5. Customize each item according to your needs (see below).

Note

When upgrading to NIS-Elements version 5.30, only the modified layouts from the older version are loaded
into the new Layout Manager.

Making a Layout Default for All Users

1. Create the layout you would like to propagate to all NIS-Elements users.

2. Right-click the command name and select the Propagate this layout to command (you can choose either to All
Users, or to a specific Group).

3. Restart NIS-Elements.

Note

No apparent change will be visible in the Layout Manager after propagating the layout. However, after the
software is restarted, the layout will be present.

Caution

Users who have the privilege to Modify shared layouts can remove the layout via a context-menu, but this
action will also affect all users!

Layout Manager Tools

Propagate this layout to all users This context-menu command makes the layout default to all users of the software.
Whenever the software is started the layout will be activated.

D Create Layout Adds a new layout to the list of layouts.
3 Remove Layout Deletes the selected layout. The first two layouts cannot be deleted.
= set Layout as Active Makes the selected layout active.

[ Load Default Loads original settings of the selected pre-defined layout (Full Screen, Docked Controls, Measure-
ment) so that it looks just like after the program installation.

O Lock Layout Select a layout component and click this button to lock these elements so that they cannot be
moved or closed. To unlock these components, click the button again or right-click the locked layout tab at the
bottom and click Unlock Layout.

-EEE Apply to All Changes made on the currently edited layout are applied to all other layouts using this button.
Global layout is not affected however changes made on the global layout are applied to other layouts.
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@ Import Layouts Enables to load a previously saved set of layouts from an XML file. When you try to import a
layout with already existing name, you will be prompted to choose whether: the imported layout replaces the existing
colliding layout, or is not imported, or is imported and renamed.

E Export Layouts The settings of layouts can be saved to an external XML file. Use this Export button. In the
windows that appears, define the destination file name and check which layouts will be included in the exported
xml file.

3.3 Modifying Toolbars

Hiding Toolbar Buttons

[] Large Buttons
Toolbar: {Main Left Top Teolbar B

[+ PointingTool Show Toolbar
Magrifier [] Use Default

i
AnnotateAndMeasure Default
* ModifyBinary
= :

. Display Layout Manager by the View > Layout > Layout Manager command.
. Select the Toolbars item within the list of layouts. The right-side part of the window changes.
. Choose one of the toolbars which you would like to modify from the Toolbar pull-down menu.

. If selected, de-select the Use Default option on the right.

a A~ W N P

. Any button of the toolbar may be hidden by de-selecting it. No buttons can be added to any of the toolbars except
the Main Left Toolbar.

()

. The whole toolbar can be hidden by de-selecting the Show Toolbar check box.

7. There are two sizes of buttons available. Select the Large Buttons option to use the larger one. This setting is
shared by all toolbars.
Adding Buttons to the Left Toolbar

Custom user buttons can be added to the main left toolbar. You can define your own buttons which run single
macro functions or execute macros. Select the Main Left Toolbar from the pull-down menu.
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[] Large Buttons

- Button Properties
MName: [ Conftrast

 Toolbar: {Main Left Toolbar B
oin wy
&' CaptureMChauto A Show Toolbar
Separator [ Use Default
%Copylmage Default
EPasteImage
ki [ Remove |
ﬁ RunMacro
Separator E
|'.:PTnnlbar5e1J.||:n .
*, Command0 D
v

Tooltip: [

Enabled bitmap: \

Disabled bitmap: %

_Contrast(); ‘ E]

Command:

Let's say that we very often use the Image > Contrast O command. It is useful to add a shortcut button to the
toolbar.

1. Press the Add button, and choose Command from the pull-down menu:
2. A new command - CommandO - is added to the list.

3. Now, assign a macro command: Open the pull-down menu on the right side of the Command edit box and click
Command List.

4. Alist of commands appears. Choose Contrast ().

5. Confirm the selection by |OK|.

Note
It is possible to assign a sequence of commands to a single button by repeating this procedure.

If you are not satisfied with the default icon, you can change it by pressing the |Change...| button. A window for se-
lecting the icon appears. You can select the image from the NIS-Elements icon set or load some other from any file
containing icons (ico, dll). You can define another icon for the command in a disabled state, too.

It is handy to define a tool-tip (a text that appears when the mouse cursor is placed over the icon) for your command.
Simply write the text into the Tooltip box. You can change the position of the command in the toolbar using the arrow
buttons. The |Default| button discards your changes and inserts the default set of commands to the toolbar.
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3.4 Modifying Menus

The Main Menu and some of the Context Menus within the application window may be modified. ltems of the context
menus can be hidden by de-selecting them similarly to the toolbars. The main menu can be modified as follows:

Modifying the Main Menu

1. Display Layout Manager by the View > Layout > Layout Manager command.

2. Select the Main Menu in the topmost pull-down menu.

~Menu: —[Main Menu 517

- File [] Use Default
- Edit

- Calibration
B
- ROL

[ Binary
[ &Measure [_]

- Reference

3. Any item may be added to the main menu - a Separator, a Menu Command, a sub-menu (Menu Popup), and
even a new menu (Main Menu Popup) - by the Add button.

4. Select the existing menu item under which you would like to place the new item.
5. Click the Add button and select the item to be added from the pull-down menu.

6. Edit the Item Properties.

~Item Properties

Text: | Fie |
Hotkey: | [*] | add... | |Remove |
Enabled bitmap:

Disabled bitmap:

Command: - E

Text This is the text which appears in the pull-down menu. You may add “&” before any letter - such letter
will be considered a keyboard shortcut when browsing the menu.

Hot key One or more hot key shortcuts may be assigned to the command. Just press the Add button and
press the key combination. Press Remove to remove the selected hot key.

Enabled/Disabled bitmap, Command These fields serve for assigning a bitmap image and a macro function
to the menu command. It works the same way as when modifying the Main Left Toolbar (described above).
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Note

The Default button discards all changes and loads the main menu original configuration. The Remove button
deletes the selected item. The arrow buttons move the selected item up/down. The Use Default check box,
when selected, applies the default settings to the menu.

3.5 Running a Macro Upon Layout Change
A macro command or a macro can be run upon layout change.

1. Display the layout manager by the View > Layout > Layout Manager command.
2. Select the layout by displaying of which the macro function will run and select the Commands check box.

3. The following box appears on the right side:

Zommand before Layout changing
[ Runfacrof"C: A MacrosiLavoubZhange0l . mac"); IE]

[ Command after Lavout changing:

l |8

4. Select the timing. The “before” option will run the command when you click on the layout tab, but before actually
changing the layout. The “after” option runs the command right after the layout is changed.

5. When the field is enabled, type the command or insert it via the pull-down menu.

3.6 Appearance Options

General appearance adjustments can be made in the Options window. Run the Edit > Options £+ command and
switch to the Appearance tab.

Background Background of the main screen may use default tiles or custom color.

Color scheme There are the following color schemes predefined within the application: Light scheme, Dark scheme,
Black scheme.

Language Select the language to be used in GUI. The language pack is a part of the Local Option feature set.

Prompts on Image Save dialog Actual words used on buttons of the window which appears if an image has been
modified and is about to be closed.

The Z value displayed in status bar Having two Z devices, select whether to display Z1, Z2 or both on the main
status bar.

Close ND Acquisition window after Run The View > Acquisition Controls > Capture Timelapse window will be closed
automatically upon acquisition start.

Image window toolbars You can decide whether the top and side image toolbar is integrated into the main toolbar
(Common for all Images) or whether each image has its own set of toolbars (Visible for each image). The most
space-saving option is to use shared toolbars and hide the image status bar and the ND2 control bar (6.3.1.1
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Control Bar) automatically (Common for all images, auto hide bottom toolbar). It will show up only when the mouse
cursor rolls over the bottom part of the image.

In the Right Toolbar section you can select the appearance of buttons having more sub-options. See 3.1.2 Image
Window .

Common for all images, auto hide bottom toolbar This option hides the image status bar and the ND2 control bar
(6.3.1.1 Control Bar) automatically. It is displayed only when the mouse cursor rolls over the bottom part of the
image picture.

Show channel tabs Show channel names and colors in the image window status bar.

Show Layout tabs Show layout tabs in the main status bar.

Show Task Bar If unselected, the Windows taskbar will be hidden.

Default vertical docker on the right/left side Select the preferred side for the default vertical docking pane.
Keep text size while zooming When selected, text annotations will not be zoomed with the image. See View >
Analysis Controls > Annotations and Measurements y .

Allow zoom factors lower than best fit When selected, the image can be resized to be smaller than displayed using
the View > Zoom Q. > Fit to Screen command.

Lock camera maghnification If you are used to switch between two camera modes (resolutions), this option ensures
that the scene observed does not change its size or position.

Keep picture window aspect If checked, the image window respects the image size while zooming.

Initial Zoom You can select the zoom factor of the newly opened images. The options are Best Fit, 200, 100, 50,
25%.

Initial zoom 100% for Live and Capture Whenever a new Live or Captured window is opened, the zoom will be
automatically set to 100%.

Default Volume View Rendering Engine Switch between the Old/New engine used in the Volume Viewer.

3.7 Simplified User Interface

After the Industrial GUI module is installed, a simple layout intended to be used in industry imaging applications is
added to the application. Switch to the layout by the | ¥ Simple| button in the top right corner. Return to the main
layout by the same button (which is changed to | ¥ NIS-D)).

Note

This button corresponds to the View > Simple Control menu choice.

A Nikon-manufactured digital camera (DS-U1,/U2/U3, DXM1200C, 1QM) must be connected to NIS-Elements
in order to display the View > Simple Control command.

3.7.1 Behavior

* The “Live” and “Captured” images can be switched between the main image area and the preview window on
the right.

* The number of control panels available within the docking panes is reduced.
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* The main toolbar is reduced, some buttons are added. See 3.7.2 Toolbar Buttons.

3.7.2 Toolbar Buttons

The following toolbar buttons are added to the layout:

Q Print This button sends the current image (the large one) to the default printer. Invoke the nearby pull-down

menu to set printing properties. See File > Print Q .

|£|‘-| |_'-1] Change View This button swaps the Live and the Captured images between the main image window and
the preview window in the right-side docking pane.

HH show Graticule This button has been moved here from the right image toolbar of the main view and provides
the same functionality. See 3.1.1 Main Window Components.

b Show Scale This button has been moved here from the right image toolbar of the main view and provides the
same functionality. See 3.1.1 Main Window Components.

3.7.3 Camera Control Panel

The & Live button displays live image in the picture window. The second button either captures a single image
after clicking the # Capture or captures a single image and saves it to the Auto Capture Folder automatically after
clicking @ Auto Capture (check the Auto Capture (Auto Save) option in the Save control panel).

‘ V Live ‘
‘ o Capture ‘

[ Select Camera. .. ]

3.7.4 Save Control Panel

This control panel enables the user to specify image saving options. Most of the settings only applies when the
Auto Capture (Auto Save) option is checked.
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= |

Directory:
[ C:\DATAmages ] E
[ Make Subdirectories Automatically

[ $DD-$MMM-§TYYY (03-May-2017) -

Prefix: Mext Files Digits:

[s=a I 1[4 5
File Format: Compression:
’Tagged Image Format (*.tf;*. E]] [Nnne E]]

Ex: c:\data\images\seqlO0 1. tif

D Auto Capture

{Auto Save) D Burn Annotations

Directory Press the ... button and select the Auto Capture Folder where images captured by the i@ Auto Capture
button will be saved.

Make Subdirectories Automatically The images can be sorted to subdirectories automatically based on the time
of acquisition. Select this option and use place-holders from the drop-down menu to specify the right format (click

? to display the place-holder legend). E.g.: “SYYYY$MM$DD” would create a new subdirectory for each day named
like this: “20150103".

Prefix, Next File, Digits Type the prefix and numbering style intended for the files being saved automatically. The
Next File field 1/ informs you and enables you to change the number which will be used for the next automatically
saved image.

File Format, Compression Select the file format to save the images in. Some formats enable you to set the Com-
pression parameter. It is recommended to use either “none” or “lossless” in order to preserve good image quality.

Ex. The path and file name of the next image to be saved is displayed here.

Auto Capture (Auto Save) Check this option and a new image will be created and saved to the Auto Capture Folder
each time you press the Auto Capture button.

Burn Annotations This option determines whether the annotations created by the tools of the Annotations and
Measurements window will be included in the saved file.

Warning

The separate annotation layer will be merged with the image data.

3.7.5 Preview Control Panel

The Live or Captured image is displayed within this window. Use the |£F Change View button of the main toolbar
to select which one.
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Cameras & Devices

4. Cameras & Devices

4.1 Basic Workflows

4.1.1 Startup Hardware Configuration Selection

If you are running NIS-Elements for the first time, you will be asked to select a microscope and define the first
hardware configuration. Click |Select Microscope|to open the New Setup window. Select the microscope connected
to your computer and click |Create Setup|. The Device Manager window opens. Use this manager to add all cameras
and devices connected to the microscope, then create hardware configurations and light paths. Please see 4.2
Visual Device Manager .

You will be asked to select a hardware configuration every time you launch NIS-Elements. Only the cameras and
devices present in the selected configuration are connected. You can switch to another hardware configuration

later in Devices > Device Manager ﬁ by switching the tabs or using the Devices > Select HW Configuration
command. If you need to create a new hardware configuration without loading an existing one, please select Offline
Analysis during the startup of NIS-Elements and then create a new configuration in the Devices > Device Manager

}_3 (see 4.2 Visual Device Manager ).

4.1.2 Dual, Triple, Quad Camera Modes

Some camera models may be used in a dual, triple or quad mode. The software combines their grayscale images
into one multi-channel image.

1 Run the Devices > Device Manager ﬁ command.

2. Add the Dualcamera device and two or more cameras to the configuration. Arrange them to match the physical
setup.

3. Right-click a camera and select the Make Dual Camera with command. A dashed line will connect the two selected
cameras.

4. Repeat the previous step for all of your cameras. For a triple camera setup use two Dualcamera devices connected
in a row, for a quad setup use three.

4.1.3 Using a Multiview Device

A Multiview device (dual, triple or quad) enables you to divide the camera chip into halves/thirds/quarters and
observe the chip parts in an overlay as a multichannel image.

1 Run the Devices > Device Manager 1 command

2. Add your mutli-view device to the configuration by the |Devices| 4 button. If you cannot find your multi view
brand in the list, use the generic MultiView device.

3. Arrange the configuration to match the physical setup.
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4. Right-click the multi view device and select Configure Multiview and select whether it is a Dual View, Triple View
or Quad View.

5. Click |OK|.

Note

* Bypassing the multi view feature is done by switching to the light path with the “MV(Out)” postfix.

¢ To run a multi view mode on a dual camera, connect two “Multiview” devices to one “Dualcamera” device,
display a context menu over a camera and select Make Dual Camera with.

4.1.4 Optical Configurations

4.1.4.1 Introduction to Optical Configurations

Typically, a laboratory computer image analysis system consists of a computer, a camera, and a microscope equipped
with certain accessories (objectives, filters, shutters, illumination, rotary changers, etc). Most of the mentioned
microscopic hardware can be motorized and therefore can be controlled via NIS-Elements. In addition, it is possible
to integrate single settings of all these devices into one compact set called Optical Configuration. It is recommended
to create several optical configurations containing particular devices settings. Then a single click can completely
change the current hardware configuration.

4.1.4.2 Creating New Optical Configuration

1) Please checkthatallthe devices (microscopes, cameras, etc.) which you want to associate with the new optical
configuration are properly attached to the system and working.

2) Choose the Calibration > New Optical Configuration lj". command. In the window which appears, adjust the
settings of the devices to match the intended state which will be saved to the optical configuration.

3) Type the name of the new optical configuration to the Name field. Use a short descriptive name, the name is
used on the button in the main toolbar when you select the Show on toolbar option.

4) In the left column, select which device settings to associate with the Optical configuration. Only the devices
related to the currently selected light path are listed here.

Camera setting A list of the current camera properties appears on the right. It is being updated dynamically.

Use Stored ROI If you want to include the camera ROI settings, select this option. Status of the camera
ROI (ON/OFF) and its size will be set when switching to this configuration.

Channel setup These settings determine how channels of newly captured images will be named and what
color will be assigned to them. The available properties depends on the current camera setup (color/mono).
In the mono camera mode, you can either assign the name, the emission length and color to the channel
Manually, or leave this task to NIS-Elements (the Automatically option). In such case, information of the light
path (emission wavelength) will be used to determine the channel name and color.
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Microscope setting If there is more than one shutter available and you would like to associate a shutter with
the optical configuration, select which one is the Active Shutter from the pull-down menu. Select which parts
of the microscope shall be included in the configuration by checking them in the Used devices dialog box.

Note

Active shutters remember their aperture setting and display it in the Microscope setting section.

Objective An objective mounted to a motorized nosepiece can be included in the configuration. Select the
objective from the pull-down menu. Objectives which are currently assigned to any position of the nosepiece
are listed. See 4.1.5 Objectives.

Note

The objective must be assigned to a nosepiece position via the microscope control pad or the nosepiece
control panel beforehand.

5) If some of the device settings still need to be adjusted, click the |[Camera & Devices Controls| button and select
the appropriate control panel from the pull-down menu. Adjust the settings within the control panel, the optical
configuration will be updated automatically.

6) Click Finish to save the new optical configuration and to close the window.

7) You can create more optical configurations by repeating the procedure. The optical configurations are saved
to registry immediately. A backup of optical configurations can be made by running the Calibration > Optical

Configurations | command and clicking the Export button.

4.1.4.3 Managing Optical Configurations

To display the optical configurations manager window, run the Calibration > Optical Configurations l command.
You can make the following actions from the window:

* Create, duplicate, rename, delete, copy settings and switch between optical configurations.
* Modify optical configuration properties.

¢ Import and export optical configurations to/from an XML file.

4.1.4.4 Operations with Optical Configurations

Once created, the configuration appears in the list and can be shared with other users by changing the Private
option to Shared (see 2.3 User Rights). The following operations can be performed on the selected configuration:

* It can be deleted by pressing the Remove button. A confirmation dialog box appears.

* Its name can be changed by the Rename button. A button with the configuration name appears in the toolbar
(if the Show on toolbar option is selected).

* The configuration settings may be transferred to another optical configuration by the |Copy to| button. Press the
button and select the optical configuration to be overwritten with the current one.

* A copy of the configuration can be made via the Duplicate button.
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* The configuration can be applied to by the Set As Active button.

* The settings of all optical configurations can be exported to an external XML file using the Export button.

* The previously exported optical configurations settings can be loaded from the XML file via the Import button.
¢ The list of optical configurations can be ordered manually using the arrow-up and arrow-down buttons.

* Each configuration can be arbitrarily modified within the right-side portion of the window.

The optical configuration buttons are available in the main toolbar when Show on toolbar option was selected
during the setting process.

4.1.4.5 Using Auto Exposure while Switching between Optical Configurations

You can use one optical configuration when working with live image and switch to another optical configuration
just for the image acquisition, very often, this is performed automatically. However, if the optical configuration used
for acquisition has the Auto Exposure camera mode turned on, it may produce over-saturated or under-saturated
images.

Since the Auto Exposure algorithm estimates the optimal exposure time by analyzing several last frames, it is not
able to make the estimation correctly if the change of optical configurations would cause significant change in image
brightness. To prevent this, we recommend to use Manual Exposure mode in the optical configuration used for
capturing.

4.1.5 Objectives

If you want to perform measurements on captured images it is wise to calibrate all objectives used to capture images.
Whenever an image is captured through a calibrated objective, the image inherits its calibration.

4.1.5.1 Managing Objectives

Run the Calibration > Objectives command. The Objectives window appears:

Objecti
Name MNosepiece | Storage | calibration e
Uncalibrated Uncalibrated
SR Apo TIRF AC 100xH PES [=] shared [=] 0.00006 mm/px @ 1280x1024, Zoom 1x, Relay lens 1x B
e AZ Plan Apo 1x - Shared [~] 0.006 mm/px @ 1280x1024, Zoom 1x, Relay lens 1x B
wPlan Apo 10x [ [~] Shared [~] 0.0006 mm/px @ 1280x1024, Zoom 1x, Relaylens 1x B
e Plan Apo 40x Ph2 DM [=] shared [=] 0.0002 mm/px @ 1280x1024, Zoom 1x, Relaylens 1x B
—Plan Apo 100x Ol Ph3 DM [=] Shared [=] 0.00006 mm/px @ 1230x1024, Zoom 1x, Relay lens 1x B
e Plan 50x O - [=] shared [=] 0.0001 mm/px @ 1280x1024, Zoom 1x, Relaylens ix B
e Plan Apo VC 80x WIDIC N2 0 —— [=] shared [=] 0.0001 mm/px @ 1280x1024, Zoom 1x, Relaylens 1x B | | pecalibrate.
Plan Apo 20x Ph2 DM Pos. 2 [=] Shared (=] 0.0003 mm/px @ 1280x1024, Zoom 1x, Relay lens 1x B
e Flan 40x Ph2 DL Pos. 3 [=] Shared [=] 0.0002 mm/px @ 1280x1024, Zoom 1x, Relaylens ix B
Pz Fluor 40x Ol DICHNZ g Pos. 4 [=] shared [+] 0.0002 mm/px @ 1280x1024, Zoom 1x, Relaylens 1x B
Pl Apo IR 50x WIDIC N2 g Pos. 5 [x] shared [+] 0.0001 mm/px @ 1280x1024, Zoom 1x, Relay lens 1x B
= Plan Fluor 100x Gl DICH  Pos. & [=] shared [=] 0.00006 mm/px @ 1280x1024, Zoom 1x, Relay lens 1x B
Current Unit
Main properties Physical properti Hep
Name: Plan Apo 10x Work. Dist.:  [3gon  |pm AF Range:
Abbreviation: 10x Z-5tep (AF): E] pm  Numerical Aperture
Calibration: 0.0006 Z-Step (Slices): um Refractive Index:
Product Code: [ Scale properties... ] [ Reset to defaults ]
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A list of used objectives can be created within the Objectives window. For each objective, the objective name, pos-

ition in the changer, storage status and the calibration are displayed. A Calculator E icon next to the calibration
value indicates that the calibration has been calculated from objective properties. If the calculator icon is missing,
the calibration has been performed manually. Use the buttons on the right side to manage the objectives:

Insert Click the button and select one of the objectives from the database (ordered by magnification). Custom ob-
jectives can be added to the database via an INI file.

New Press this button to create a custom objective. The new objective will be added to the list. Then, define the
Main properties and the Physical properties of the objective.

Duplicate If zoom is used, the objective calibration must be re-calculated accordingly. Use this button to make a
copy of the objective and define the zoom factor in the window which opens.

Remove This button deletes the selected objective.
Recalibrate Starts the calibration of the selected objective. See 4.1.5.3 Objective Calibration.
Export Enables you to export the complete list of objectives to an XML file. The standard Save As window appears.

Import This button enables you to import a complete list of objectives from an external XML file previously created
by the Export button.

Current Unit This button invokes a pull-down menu where units for the whole application can be selected.

Help Displays a help page to the Calibration > Objectives command.

Edit the properties of the selected objective in the bottom part of the window. Press the Close button to finish this
window.

4.1.5.2 Assigning Objectives to Nosepiece Positions

1 Display the microscope control pad - View > Acquisition Controls > Microscope Control Pad E

2. Click the setup E button in the nosepiece section.
3. A window appears which enables you to select one of the available objectives to the corresponding position.

4. Each objective has its specifications displayed in the table. These specifications are not editable.

4.1.5.3 Objective Calibration

After you press the Recalibrate button in the Objectives window or when creating a new custom objective, the fol-
lowing window appears:

Select method for calibrating objective 'Achromat 40x’

() Manually, drawing a line of known length

(®) Automatically, using stage
a;
BT

-t .
i 4 points
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Select one of the calibration methods:

* The Manual calibration lets you draw a distance into a picture and assign real length to it. The live image starts
automatically and a window appears. Proceed to: 4.1.5.4 Manual Calibration

* |f a motorized XY stage is available, the Auto and 4 points buttons appear. Proceed to: 4.1.5.5 Objective Calibration
Using XY stage.

Press |OK|to continue.

Superresolution Calibration

This type of calibration is available after successful manual or automatic calibration. It triples the camera's resolution
and uses fine stage movements to improve the resulting objective calibration. Click the |Run SR Calibration| button
and wait till the objective is calibrated.

4.1.5.4 Manual Calibration

Manual calibration requires the user to specify a distance in the image. It can be either a measurable distance or
the size of one pixel. The following procedure can be used for different purposes:

¢ Calibrating of an image (see 8.1.1 Calibration)
* (Re)calibrating of an objective (see 4.1.5.3 Objective Calibration)

* (Re)calibrating of a microscope zoom

1) The following window appears:

Draw line of known length.

Zoom on Click

2)

a) If you know the size of one pixel, click the |Pixel size...| button.

Enter real size of 1 pixel; | 0,001

o | [ coce |

Enter the value and finish the calibration by the |OK| button.

b) If you do not know the pixel size, you will need to specify distance in the image. For this purpose, use an
image of a calibration slide or a ruler captured with your current system configuration.
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3) The distance is defined by placing lines to the image. If you are sure the calibration pattern is perpendicular
to image edges, it is recommended to select either vertical l—| or horizontal :I: lines. Otherwise, select the
parallel lines %y .

4) Click into the image to place the first line and then the second line to specify the distance:

| ,I You can modify the line position while holding the primary mouse button. After you release the button
no further changes can be made. Place the second line in the intended position by another click.

"y Draw the first line by clicking twice inside the image. The line can be moved and adjusted arbitrary by

mouse. When satisfied, finish the first line by right-click. The second line can be placed by another click to the
image, this time only to adjust the distance from the first line. The process is completed by right-click.

Zoom on Click zooms the image after the mouse button is clicked so that the position of the point can be set
precisely.

5) Then the following dialog box appears:

Enter real size of line:

6) Enter the distance between the two lines and select correct units.

7) Click |OK|to finish the calibration.

4.1.5.5 Objective Calibration Using XY stage

This procedure requires a motorized stage. Select one of the following methods:

Auto The Auto method is fully automatic. Calibration is performed on a part of the live image marked by red square
that is shown before the calibration is launched. You can also choose the channel to be used by auto-calibration.
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Figure 4.6. Auto-calibration window

O Live -Fast — 0O
B Hl | L | 100% - Please select the channels that will be used by autocalibration:
LIl NX B~ -] - st B8 @ ) Al Channels
J - (%) Single Channel [ 400 nm E]]
D () Selected Channels:
-
400 nm
@ - Please make sure that there is a reasonable structure in
the center of the red rectangle.
Hm
...... - OK ] ’ Cancel
-
e
- 4
A -

', A1) M_400 nm /@ 450 nm M 500 nm }, Custorn

8,06 pmjpx [3x12bit: 256 x 256 pixels I

NIS-Elements moves the motorized stage, acquires two images, and calculates the calibration from the shift of the
images. The auto-calibration performs an estimation of the real relay lens zoom factor. If the estimation does not
match the value specified in the Device Manager window, a warning appears.

Figure 4.7. Example of the warning message

The Relay Lens is set up in the Camera Light Path setting to 1.30,but the correct value should be 1,00
l % on your microscope. Please fill in the correct value in Camera Light Path setting.

D you want to continue anyway?

It is recommended to cancel the auto calibration (click \Nz), check the real zoom factor of your relay lens and set
correct relay lens settings in the Device Manager.

Note

The success of this method depends on the texture of the specimen, its contrast, illumination, etc. If the
combination of these factors is unsuitable, the auto calibration may fail. If it fails, try the following:

* Move the stage to another area of the specimen to get a better texture.
* Improve contrast by setting LUTs.
e Check focus, re-focus if needed.

* Turn on the shading correction (see 5.3 Shading Correction).

48



Cameras & Devices

4 points If you select the 4 points method, the system draws four points on the screen (subsequently) and asks
user to move one significant part of the specimen to each position. After all four steps are completed, the calibration
is calculated from the moves of the stage.

4.1.5.6 Monitor Calibration

A real zoom factor can be displayed within the image window. In order for the value to be accurate, both the image
calibration and the monitor calibration must be accurate. To calibrate the monitor:

1. Display a context menu over a calibrated image and select the Show Physical Zoom command. The computed
value appears in the top left corner of the image. If the current image is not calibrated, the box will show N/A.

2. Right-click the box with the zoom value and select Monitor Calibration, the following window appears.

Figure 4.8. Monitor Calibration Dialog

Menitor Calibration *

Monitor: HP Z27 IPS Display (0002) (primary)
(@) Automatic monitor calibration: Width: 537.0  mm Height: 336.0 mm

(") Custom monitor calibration: :] E

| concel |

Caution

The dialog displays calibration of the monitor on which it is displayed. If you have multiple monitors, move
the dialog between them.

3. Check the Width and Height values and whether they match the real size of your monitor.
Tip
The detected monitor type is displayed in the window. If the information about the model is precise, it is

likely that the automatic calibration is correct, otherwise, we recommend to switch to Custom monitor cal-
ibration.

4. If you are not sure whether the detected calibration is correct, select Custom monitor calibration. Take a ruler
or a measuring tape and measure width and height of your monitor. Enter these values and confirm the calibration
by the | OK| button.

4.1.6 Connecting a Device to NIS-Elements

Before you get to work with NIS-Elements, all hardware accessories should be connected properly to the system.
In most cases, the following basic procedure is sufficient to connect a device successfully:

1. Install NIS-Elements, and select the appropriate device(s) during the installation.

2. Connect the device to the PC and switch the device ON.
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8.
9.

* Run NIS-Elements, and run the Devices > Device Manager ﬁ command to open the Device Manager window.
. Select a microscope or create a new one.

. Click the Add button next to the Devices caption to add the device to NIS-Elements.

. Select the device from the list of installed devices and click |Add Device|.

. Click on the device in the scheme and drag it to the highlighted hotspot so that the connection matches your

physical microscope setup.
Create a hardware configuration with light paths suitable for the experiment.

Close the Device Manager.

If a peripheral device is connected to NIS-Elements, some extra commands and features become available. This
concerns typically motorized XY stages and Z drives, but also other devices.

Note

MULTIZOOM AZ100M, ECLIPSE LV series, ECLIPSE MA200, or ECLIPSE L200N/300N microscopes can not
be connected from NIS-Elements while the setup tool of each microscope is active. To connect any of these
microscopes to NIS-Elements, exit the setup tool and then run NIS-Elements.

Renaming of devices

Either logical or physical device can be renamed by the user. Just right-click the device name and select the
Rename... command from the context menu. The user-defined names can be handy in two cases:

* You are using two logical devices having matching names, but you need to uniquely identify them (e.g. from
macro).

¢ You are used to call a device with another name and would like to rename it in order not to be confused by
the predefined name any more.

4.1.7 What are “Logical Devices”?

NIS-Elements handles hardware accessories using the concept of logical devices. There are features of different
hardware devices which equal and therefore can be controlled equally. Such features are called “logical devices”.
A typical logical device is Stage XY. Different microscopes can be equipped with different XY motorized stages, al-
though - regarding the user interface - they behave equally. One physical device (a piece of hardware) can contain
one or more logical devices the list of which appear in the Device Manager after the connection is established.

Available Logical Devices

Analyzer The analyzer is a polarizing filter placed in the optical path between the specimen and the lamp. The lo-
gical device offers two states: ON (inserted) and OFF (extracted).

Aperture This logical device is used for controlling apertures in the light path. It is used in complex microscopes
rather than as a standalone device. Two parameters can be typically set for aperture devices, the state (on/off)
and aperture size.

Condenser A condenser is a two-lens combination located next to the illumination source in the optical path. Its
purpose is to collect light and direct it to the specimen being examined. The corresponding logical device relates
to a changer of different condensers.
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Filter This logical device controls filter changer movements. There can be several filter changers connected to NIS-
Elements at a time. Each filter changer needs to be set up - filter types shall be assigned to positions of the changer:

1. Display the filter changer control panel (Devices > Filters and Shutters or Devices > Microscope Control Pad
@)

2. Click the settings button E , a window appears.

3. Select one of the available positions which the filter will be assigned to.

4. Click the |...| button, a list of available filters appears.

5. Select the filter name from the list and confirm it by | OK|.

6. The filters can be moved within the already defined positions using the Up/Down arrow buttons.

Note

When browsing the list of filters, details about the currently selected filter are displayed on the right side of
the window.

Illuminator This logical device is used for controlling the specimen illumination remotely. There is no standard
dialog box for the illuminator control. Each device handles this logical device via a user interface specially designed
for it - typically containing one button for switching it on/off and a slider for regulating intensity.

Light Path Some microscopes have more than one port where it is possible to attach a light source or a camera.
This logical device can switch the illumination between these ports.

Microscope This logical device is used to group standalone logical devices used in certain microscopes. To control

the logical devices of a microscope from one control panel, select the Devices > Microscope Control Pad E
command.

Nosepiece This logical device serves for controlling microscope objective changers. There can be three nosepiece
types attached to a microscope:

* Manual - it can not be controlled via the software.
* Intelligent - the current nosepiece position is read by the application, but can not be controlled.

* Motorized - such nosepieces can be fully controlled via the Microscope Control Pad or the Nosepiece control
panel.
See 4.1.5.2 Assigning Objectives to Nosepiece Positions.

ND Filter A neutral-density filter is a light absorbing filter whose absorption spectrum is moderately flat. It is used
to reduce the illumination intensity within the optical path. The logical device offers two states: ON (inserted) and
OFF (extracted).

PFS Perfect Focus System - this logical device corresponds to the PFS physical device available with Nikon TE2000/TI
microscopes.

Shutter This logical device can control shutters installed in your system. This device is handled via the Devices >
Filters and Shutters control panel or straight from the microscope control pad. You can select the type and rename
the shutter by running a contextual menu command either within the Filters and Shutters control panel, Device
Manager window, or in the main toolbar.

Note

There was a restricted number of shutters which could be connected to the system in previous releases of
NIS-Elements and they were identified by Type (DIA, EPI, Aux1, etc...). The current version supports identification
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of shutters by custom Names, but the Type attribute can be still found in some windows (or used in some
macro functions). This is to ensure backward compatibility.
Zoom This logical device is used for controlling the zoom factor. Run the Devices > Zoom Configuration w‘T command
to adjust the zoom settings.

Stage XY Stage XY enables the movement of specimen within X and Y axes. The system offers user to control stage
movements.

Stage Z The Z Drive device enables movement throughout the Z axis direction.

4.1.8 XY Stages and Z Drives Tips

Please read the following tips for using motorized XY Stages and Z Drives.

Motorized Stage Initialization

A motorized stage being initialized could strike the objective. Before initializing the stage, make sure that the ob-
jective is away from the stage. If a motorized Z drive is available, use the Devices > Objective Clearance command
to prevent collision.

Setting Software Limits to Stage Movement

Some microscopes enable you to reduce the range of movement of the motorized stage by setting limits within the
configuration window.

1) Display the configuration dialog window (within the Devices > Device Manager ﬁ window).

2) Move the stage to the position where the limit shall be set.
3) Click the appropriate button.

4) Set all the limits by repeating this procedure.

Caution

This procedure can not be used if you already set some limits and would like to broaden them at the
same time. NIS-Elements will not allow you to move the stage to any out-of-limits position. What you need
to do is to reset the limits within the configuration window beforehand.

Using two independent Z Drive devices

Workstations can be equipped with two independent Z drive systems, one coarse (slow) and the other fine (fast).
Typically, the first one is used for specimen manipulation in Z axis, when changing objectives, etc., the second one
is used for auto-focusing. The following text explains how NIS-Elements handle the two Z drives.

Absolute Z The current positions of both Z drives (Z1, Z2) and the absolute Z position (sum of Z1 and Z2) are dis-
played in the main status bar. If there is not enough space to display all these values, only the absolute Z value is
displayed (Z1 and Z2 still appear in a tool-tip). The absolute Z value appears in the Z Series Setup.

Active Z

The concept of Active Z enables user to select the preferred Z drive:

* The active Z drive is used when performing auto-focus.
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* The Devices > Enable Mouse Joystick Z in Live command applies to the active Z.
You can select the Active Z device in the Devices > Mouse Joystick and Auto Focus Z menu.

Regular Z drive + Piezo Z drive

If you have a regular Z drive and a Piezo Z drive installed, some functionality is added:
* The Move Piezo Z to button is added to the Z Series Setup window when Piezo Z is selected.

* The Devices > Keeps Z position and centers Piezo Z and the Devices > Move Piezo Z to Home Position commands
appear in the Devices menu

The button and the Devices > Keeps Z position and centers Piezo Z command provide corresponding functionality.

They move the Piezo Z device to its home position, and compensate this shift by moving the second Z drive in order

to maintain the absolute Z position.

4.1.9 Camera Settings

A digital camera mounted to a microscope port records images of the observed scene on a light-sensitive sensor,
and transfers them to a computer. NIS-Elements supports various cameras differing from each other in resolution,
frame-rate, sensor type, etc. Despite these differences, controlling different cameras is similar. The following features

are included in the View > Acquisition Controls > [Camera name] Settings "G window depending on a particular
camera type.

Note

The complete list of cameras and devices supported by NIS-Elements is available in a separate document.

Reference of Common Camera Settings

1 frame for Fast Timelapse The camera head is equipped with 4 GB of memory available for fast capturing. Use
this button to run acquisition with maximum available frame rate. However, the size of image sequence is limited
to 4 GB.

Note

The actual frame rate depends on other settings (readout mode, sensor mode) and is limited by the read-out
speed of the camera sCMOS chip. Maximum frame rate can be achieved with the combination of Rolling
shutter and Overlap sensor mode.

AE Compensation In automatic exposure modes, the compensation affects how optimum exposure settings (Ex-
posure time and Gain) are calculated. The Compensation value is expressed in Exposure Values (EV). Setting the
compensation to + 1.0 EV makes the image twice brighter (e.g. doubles the Exposure time or Gain).

AE Lock This option makes the automatic exposure mode to lock the current exposure settings (Exposure time and
Gain).

Analog Gain Controls the Gain (Sensitivity) of the camera and strength of the camera analog signal before it is di-
gitized. This setting affects image brightness.

Auto White Balance This button performs an automatic white balancing. It calculates the right values and then
adjusts the red, green, and blue image components in order to get a neutral white color. The Auto White gives the
best results on color neutral (gray) scenes.

Averaging Averaging is a commonly used technique of decreasing noise in the image. In this method 2, 4, 8 or 16
consecutive frames are averaged together.
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Binning The binning mode provides considerably enhanced camera chip sensitivity by integrating more elements
(pixels) together. E.g.: binning 4x4 integrates the signal from the area of 4x4 chip elements to one pixel of the res-
ulting image. Smaller resolutions and faster frame rates are achieved using the binning modes.

Capture Bit Depth Channel Select per-channel bit depth used for capturing.

Clear Cycles This option enables you to decide, how many times the CCD chip should be cleared (reset). The set
Clear Mode determines how often it is performed.

Clear Mode Sets how often the CCD chip will be reset. Please, see the camera user manual for further details.
These options are available:

¢ Automatic

* Never

* Pre-exposure

* Pre-sequence

¢ Post-sequence

* Pre and Post-sequence

* Pre-Exposure and Post-Sequence

Contrast Affects dynamics of how the luminosity is rendered. There are several modes for different illumination
(contrast) scene situation.

Conversion Gain This is a hardware pre-amplifier gain.
Cooling The Qil/Ril camera heads are equipped with a cooling system that enables to cool down the CCD chip by
-5° or-10° of the current room temperature.

Warning

When cooling by -10 °, there might be a risk of water condensing inside the camera head (depending on hu-
midity inside the room).

Desired Temperature Sets the target temperature of the CCD chip.

Detector Mode

Only in 12bit mode
Timed A common mode for capturing images.
Strobe If the camera controller is equipped with DS-RC switch, this mode needs to be selected to use the
switch for capturing images.

Dynamic Range Dynamic range of a camera sensor is defined by the largest possible signal that it can generate
divided by the smallest possible signal. Higher bit dynamic ranges bring wider ranges of grayscale levels from each
camera pixel.

EM Gain Multiplier EM gain allows weak signals to be multiplied before any readout noise is added by the output
amplifier, hence rendering the read noise negligible. There is a complex relationship (approximated to an exponential)
between the value set and the actual level of multiplication. Typically, optimal signal-to-noise ratio and dynamic
range is achieved between x1 to x300 EM Gain. When the setting exceeds the value of 300, the field gets highlighted
red in order to notify you.

Exposure, Exposure Mode Exposure mode determines how the Exposure time is calculated. Usually, the user can
select between the automatic and the manual mode:
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Auto Exposure Automatically calculates the exposure time in order to achieve optimal brightness of the scene.
Image quality is the priority, therefore longer exposure times are preferred.

Note

Depending on particular light conditions, the result of auto exposure may not be optimal for image acquis-
ition.

Warning

Under- over-saturation may occur when switching between optical configurations. Please see 4.1.4.5
Using Auto Exposure while Switching between Optical Configurations.

Note

Available exposure time range depends on the selected Format and Readout Speed.
Manual Exposure The user selects both Exposure time and Gain manually.

Continuous AE When selected, the automatic exposure time is calculated continuously. If brightness of the
scene changes, the exposure time is adjusted so that the live image is not over- or under- saturated.

Exposure Time Exposure time is the time of charge accumulation in a camera chip between two adjacent frames.
Prolonging the exposure time increases brightness of the image as well as its quality (there will be less noise).

Fast (Focus), Quality (Capture) The software enables to create two resolution presets - Fast used for live image
and Quality used for capturing. The formats then differ in image size, and consequently in frame rate (number of
frames per second - fps). The higher the resolution is, the lower frame rate can be achieved. Available resolutions
depend on the camera type.

Note

When switching between the formats while observing the live image, the size of the image on the screen is
maintained - the zoom setting is changed instead. Only in some special cases, the behavior changes and the
image size is changed instead of the zoom setting which is maintained.

FOV Size FOV of a camera which has the sensor larger than the image from the microscope port (imaging circle)
needs to be reduced. Otherwise, images captured with a too-large FOV Size would contain visible vignetting (will
be darker at the periphery).

Figure 4.9. Correct setting of FOV Size

Sensor Full area —

Microscope imagining circle ==

Correct FOV Size —
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16 mm Suits most conventional microscopes
22 mm Suits the Nikon Ti2-E microscope equipped with two filter-turrets.

25 mm Suits the Nikon Ti2-E microscope equipped with a single filter-turret.

Gain Controls the camera sensitivity. Increasing the gain increases brightness of the image, but decreases quality
(the more random noise, the more streaky noise and color unevenness), and increases the frame rate indirectly by
enabling shorter exposure times.

Gamma The gamma correction maps the intensity of live signal exponentially to the gamma parameter. For gamma
< 1, dark portions of the image are enhanced whereas for gamma > 1, image parts of higher intensities are enhanced.

High Quality Capture When this option is checked, images are not processed by the camera control unit, but are
sent to the computer in a RAW format. The computer then processes the images into the RGB format. This mode
produces images with less noise and better color fidelity. Of course, transfer of the RAW data is slower than the
normal mode which causes a lower maximal frame-rate.

Hue Hue shifts image colors across the rainbow.

Internal Shutter This option sets behavior of the camera internal shutter.

Opened Internal shutter is opened upon NIS-Elements and stays opened through the whole session. Only with
one exception: if the Readout Mode is set to Normal 80kHz at 16bit, the shutter stays closed and opens only
for exposures.

Closed Internal shutter is closed upon NIS-Elements startup and gets opened only for exposures.

Automatic Shutter is closed when the NIS-Elements is running. It opens only for acquisition.

Isolated Crop Mode This option turns on the Isolated Crop Mode described within the Andor documentation. In
this special mode, the size of chip is reduced and very high frame-rates can be achieved.

Keep Overlapped If checked. The Clear Mode and Sensor Mode boxes are set to Automatic and become disabled.
This mode produces maximal frame rate and decreases the list of exposure times (in the camera settings window).
Only the times of 1 frame and longer become available.

Limit Max. FPS to Insert maximum frame rate (frames per second) you would like to use, this will prolong the total
duration of the time-sequence in exchange for the reduced frame rate. This option may be useful especially when
using the 1 frame for Fast Timelapse button with a small region of interest. Then the frame rate could get unreas-
onably high.

Note

The Limit MAX FPS is possible only when camera is in Normal mode (not overlapped), the maximum fps in
normal mode is shown next to the edit box.

Live Acceleration If the exposure time is too long, Live Acceleration helps you to make it shorter. The system
automatically shortens the exposure time (so the frame rate rises), and the loss of intensity is compensated by in-
creasing the gain (software multiplication). This procedure is not used upon Capture.

Maintain Temperature on Camera Shutdown If this option is checked, the camera maintains its temperature until
the computer workstation shut down. The temperature will be maintained for example during NIS-Elements restart
or when another camera is selected.

Max gain Maximal camera gain.

Maximum Exposure This is a safeguard of the time of the Auto Exposure. For quick exposure, it is convenient not
to set this value too high.

Metering Mode If this option is available, auto exposure can be calculated with an emphasis on overexposed peaks
(Peak) or average pixel intensity (Average).
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Mode Defines how the Auto Exposure is performed. Average is suitable for bright field and Peak is better used for
dark field.

Multiplier Controls on-chip multiplication gain. There is complex relationship (approximated to an exponential)
between the multiplier value and the level of multiplication - in other words, the value 2 does not mean the signal
is multiplied two times.

Noise Reduction If activated, it reduces noise generated by higher gain. NR works on interframe basis so you may
notice some shadows on moving objects.

Offset Sets the brightness of the image. It is a constant additive (positive or negative) changing all pixel values of
the image. With negative offset value the dark image areas become pure black. Considering fluorescence microscopy,
an appropriate offset setting can create continuous black background and thus help to enhance (together with
gain or illumination enhancement) the contrast.

Overillumination Tolerance Sets how many pixels should be white after the Auto exposure is performed. Use lower
values (0.01%) for very bright (shining) objects (fluorescence). For common bright field, even 1% may be a good
value.

Readout Mode Within this option you can select a combination of these parameters - readout speed and bit depth.
The settings influences frame rate and image quality. Higher frequencies increase frame rate, lower frequencies
offer better image quality.

Readout Rate Select the readout speed 100 or 280 MHz. If speed is not crucial, leave 100 MHz.

Readout Speed The speed of digitization - influences frame rate and image quality. Higher frequencies increase
frame rate, lower frequencies provide better image quality.

Resolution

Note

If the resolution of 4076x3116 is used for capture and the scale is burnt to the image, the scale position is
different from the Live image. This is a consequence. To keep the scale at the same position as in the Live
image, use other resolutions for capture.

Note

The High Quality Capture mode is also supported. If the Quality is 16bit or the resolution of pixel shift mode
is selected, you cannot uncheck the High Quality Capture check box.

ROI Select this option to activate the camera ROl defined via the ROI Size drop-down menu. When active, the current
ROl size is displayed in brackets. If a binning is applied, this size which is the size of the ROI on the camera chip
does not match the size of the resulting image. Also, if you define the ROl with the binning turned on, the pixel size
displayed in the definition dialog does not match the value then displayed in the brackets because it includes the
binning factor.

The user can choose a ROl size from the list or define a custom ROl via|Define ROI|. The ROI can also be saved/loaded
to/from a . camroi file (Save ROI/Load ROI).

Saturation The amount of saturation determines how colors are rendered. More saturation produces richer colors.
Less saturation makes the colors gray.

Save Settings, Remove Settings, Load Settings Save the current camera settings by clicking Commands > Save
Settings > New Settings... and give it a name. Load the saved settings by selecting its name in the Commands >
Load Settings list. To remove a setting, click on it inside the Commands > Remove Settings list.

Scene Mode, Preset There are several camera settings presets optimized for a specific usage. You can reset the
settings using the Reset button.

Neutral Neutral preset.

57



Industrial microscopy:
W (Water/IC) Wafer IC-Chip.

M (Metal) Metal or ceramic.
C Circuit boards.
FPD Flat panel displays.
Bioscience/Biological microscopy:
DF/FL, F Dark-field fluorescence.
DIC/PH DIC or phase contrast.
LED-Bright Field, B LED illuminated bright field.
HAL-Bright Field Halogen illuminated bright field.
HAL-HE, H Halogen illuminated Hematoxylin and eosin stain.

HAL-ELA, E Halogen illuminated enzyme labeled antibody method.
Asbestos Asbestos.

Sensor Mode This option sets the method of reading the CCD chip.
Automatic This option makes the system to choose the best mode.

Normal A standard mode where the exposure phase is followed by the readout phase. Please, see the camera
user manual for further details.

Alternate Normal Please, see the camera user manual for further details.

Overlap This mode enables the camera to achieve higher frame rates by reducing the exposure+readout time
(the readout is performed simultaneously with the exposure of the next frame). Please, see the camera user
manual for further details.

Frame Transfer This mode enables the camera to achieve higher frame rates by reducing the exposure+readout
time (the readout is performed simultaneously with the exposure of the next frame). Please, see the camera
user manual for further details.

Separate Channel Settings Having a color camera, influence of the settings described above on each color
channel can be adjusted. In such case, three edit boxes with the default values set to 1.0 are displayed below the
feature setting. These values determine the influence of the feature on each color channel.

Sharpness Some camera settings provide the sharpness control which affects how sharp edges in the image appear.
Too much sharpness leads to over-saturated edges.

Speed up Triggered Acquisition + Different Exposures Connect the Arm and the Ext. Trig connectors of the camera
and enable this option. When you run triggered acquisition with the Use different exposures option enabled, it will
speed up the performance (the camera will not have to wait for software triggers but will be controlled by the Arm
triggering signal).

Spurious Noise Filter This option reduces spurious noise. Try whether it has desirable influence on image quality.

Target Maximum Intensity Restricts the maximum of image intensity after the auto exposure was applied. The
value represents a percentage of the whole camera dynamic range.

Trigger Mode Sets the exposure method.

Internal The exposure time and the beginning of each frame acquisition is controlled by the NIS-Elements AR
settings.

Strobe In this mode, the beginning of each frame exposure is being controlled by external signal.
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Bulb The exposure time and frames timing are controlled by external signal connected to the camera.

Triggered by master camera Having a dual camera system (or a special triggering device connected to the
camera), you can use this mode. If the cameras Interval setting is set to No delay within an experiment or if
the Live mode is run, the slave camera will be triggered only once so that both cameras will run simultaneously
while single frames will not be synchronized. If the settings are different, the trigger will be engaged once and
all the subsequent frames will be controlled by the NIS-Elements AR settings as in the Internal mode.

Use Current ROI The currently defined region of interest, set by the Define ROl command, can be switched on/off
by checking this item.

Using Probe The probe D enables you to determine a small image area that serves as the data source area for
LUTs, histogram etc. It also affects the AWB (auto white balance) and the AE (Auto Exposure) features of the cam-
eras which support it. When the probe functionality is not supported, the AWB and AE algorithms are computed
from the whole image.

Vertical Pixel Shift
Shift Speed Please, see the camera user manual for further details

Vertical Clock Voltage Amplitude Please, see the camera user manual for further details

White Balance There are Red, Green and Blue Gain properties that control how colors are rendered. It is used to
eliminate a color cast from white areas.

4.1.10 Controlling lllumination Devices

The substance of an illumination device is the light source. The light emission is produced mainly by a laser, diode
or a light bulb. NIS-Elements does not distinguish between wavelength modules of these light sources and all are
controlled in a similar manner. Basically you select which wavelength(s) you want to use for illumination and set

its light intensity. The selected wavelength modules are turned off until you activate the O shutter button usually
placed in the bottom left corner of the control panel.

4.2 Visual Device Manager

Key Features

* The full microscope configuration is displayed visually and controlled by the user using a mouse.

Simplified work with multi-device hardware configurations. Double-clicking on a device in the scheme opens its
control pad.

Multiple hardware configurations (multiple independent microscope setups) can be set and running at the same
time.

Light path concept - optical paths are colored to match the defined wavelengths. The system computes the correct
emission wavelength. Each light path can switch between the camera and the ocular. Switching between a single
and a dual camera is safe.

Simplified definition of Optical Configurations - only devices enabled in the current configuration are visible
within the OC Panel (View > Acquisition Controls > OC Panel = ).
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Hierarchy of Configurations

* Hardware setup - sets which microscope is used for the ongoing hardware configuration.
* Hardware Configuration - determines which devices are used together, other devices can be turned off.

* Light Path - groups devices (from the hardware configuration) used in one observation mode (EPI, DIA, TIRF,
confocal, etc.).

» Optical Configuration - specifies the settings of each device in a light path. Each optical configuration is associated
with one light path.

Modes

Hardware Configuration By default, “Acquisition” hardware configuration is created. The user then adds the con-

nected Cameras and Devices using the == buttons. Lightpath combinations are automatically calculated in the
Lightpath Selection table. The user usually does not need all the devices connected so any camera/device can be
turned off creating a new device combination. This new “hardware configuration” can be saved by clicking on the

=+ Create New Hardware Configuration button and a new tab with a given name is created. The user can switch
to a different configuration using the tab and clicking |Activate|, using the Devices > Select HW Configuration...
command or on NIS-Elements startup. Devices which are disabled for the selected configuration are not loaded
and can be switched off to make the startup faster.

To display the system overview with each start of NIS-Elements, check Show Startup System Overview in Edit >
Options > Visual Device Manager.

Light Path The table inside each hardware configuration contains “Light Paths” which represent all available light
paths (light tracks between the cameras and illumination devices present in the current configuration). Simply
stated a light path tells which devices are used at the same time. Click on the name of a light path to highlight it
in the image. Check Edit to select which light paths will be shown in the current hardware configuration.

Different light paths are usually saved under different hardware configurations to make the microscope operation
most powerful and efficient.

Note

Hardware buttons of the Nikon Ti2-E microscope can be set to switch to a predefined light path. In the 4.2
Visual Device Manager select |Configure...|in the context menu over the microscope, switch to the |Program-
mable Buttons|tab, choose a button and click on its drop-down arrow, click Select Lightpath and set a light
path from the list.

60



Cameras & Devices

Figure 4.10. Device Manager Overview
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Device Manager window

1.

2.

Hardware Setup tabs - select which microscope is used. More setups are added by the == button.

Hardware Configuration tabs - select a hardware configuration. More configurations are added by the =+ button.

. Lightpath Selection table - displays all available light paths for the current hardware configuration and selects

the active light path. Use |Edit| to select which light paths will be hidden/shown and change their order using

the ‘f + arrows. To add/remove the light path with all devices, click 'l:I- Settings... and check/uncheck All
Devices.

. Microscope/Cameras/Devices list - shows all connected microscopes, cameras and devices. To add more, use

the == button.

. Microscope scheme - shows a visual microscope scheme of the current setup. The system can be configured

directly from this scheme using mouse dragging and context menus.

. Device Manager Settings - |[Export...| exports the whole device manager setup (hardware configurations, light

paths, optical configurations, etc.) into a .bin file whereas |Import Setups...| can be used to load the previously
exported setup. |Help| opens this help page.

4.2.1 Connecting Cameras

To correctly setup a camera using the Visual Device Manager (see 4.2 Visual Device Manager ), follow these steps:

1)

Start NIS-Elements.
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2) Select a microscope - click on |Select Microscope| and select your microscope from the list. A new hardware
configuration of the microscope is loaded.

3) In the left panel, click on Cameras = .

4) Select your camera from the list and click |Add Cameral.
5) Make sure the camera (rectangle with the camera symbol and the camera name) is visually mounted to the
proper port to match your physical setup. If not, drag and drop it to the correct place. Available positions are

highlighted yellow.

Note

Non-standard camera mounts can be replaced by “Coupler Universal” (found in Devices) which enables
the user to connect any camera to any port. The system automatically detects non-standard camera
connections. In such cases the system automatically prompts the user to Add Coupler. “Coupler Universal
Switcher” enables to connect two devices to a single port.

6) Reveal the context menu over the camera to:

» disable the camera in the current hardware configuration,

* remove the camera from the configuration,

change the camera to a different one,

select the camera mode,

rename the camera,

* make a connection with a different camera,
e open the camera light path settings.

¢ hide the camera,

* set the camera rules for active lightpath, or

open its configuration dialog (Configure...).

4.2.2 Connecting Devices

Connecting a device is similar to connecting a camera.

1) In the left panel, click on Devices =+ .

2) Select a device from the list and click |Add Device|.

3) Make sure the device is visually mounted to the proper port to match your physical setup. If not, drag and drop
it to the correct place. Available positions are highlighted yellow.
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Non-standard device mounts can be replaced by “Coupler Universal” (found in Devices) which enables
the user to connect any device to any port. The system automatically detects non-standard device con-
nections. In such cases the system automatically prompts the user to Add Coupler. “Coupler Universal

Switcher” enables to connect two devices to a single port.

4) Reveal the context menu over the device to:

disconnect the device,

disable the device in the current hardware configuration,

remove the device from the configuration,

* show the connection dialog,

rename and change any parameters of the device, or

 set the device rules for active lightpath, or

open its configuration dialog (Configure...).

4.2.3 Lightpath Scheme

Figure 4.11. Lightpath Scheme pad
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This control pad invoked by the Devices > Show Lightpath Scheme ;f command shows the current microscope
configuration with visible light paths which indicate the physical tracks of the excited and emitted light in real colors
matching the defined wavelengths (Real Color - Additive/Spectrum), or in Pseudo Colors. Dashed paths indicate

that the light does not pass through. A warning symbol ( & ) points out what prevents light from passing through.
The warning symbol next to a light path name indicates that device(s) in the particular light path are not set correctly.
Such light paths are not saved. Thanks to this indication the user can quickly detect possible errors and setting
mistakes (e.g. wrong filter cube assignment) and fix them directly in the pad.

Microscope buttons, shutters, lights, etc. can be controlled directly by clicking on them in the scheme. Double-
clicking on a device opens its control pad. Devices not participating in the current light path are outlined in gray
and can still be controlled.

Note

Stimulation light paths are not shown in the Light Path Scheme. If you need to use the stimulation light path
for acquisition and not only for stimulation, enable the acquisition light path under the |Edit| button in the 4.2

Visual Device Manager . If this light path is missing, make it visible by clicking the e Settings... button and
checking it.

Context menu over a device

Activate Lightpath with this device Finds and activates a light path being the most similar to the currently selected
light path and containing the device being clicked at the same time.

Rules for Active Lightpath Specifies further rules for the clicked device in the current light path:

Set State/Position via OC - controls the device state/position/settings using Optical Configurations when the current
light path is selected.

Keep Previous State/Position - does not change the device state/position/settings when the current light path is
selected.

Active Device - uses the device as an active device in the current light path and sets all other similar type devices
to their default behaviour.

Position - always keeps the device in the position selected from the drop-down menu when the current light path
is selected.

Configure... Opens the configuration dialog of the clicked device.

o Lightpath Scheme Settings Enables to change the color of the light paths (Lightpath Colors), turn on the table
with listed light paths (Show Lightpath List on Pad), display labels on each device of the microscope ((Show Labels
on Pad|) and turn on/off the warning message when light path changes and non-motorized devices positions do
not match.

@ Fit to Screen Adjusts the zoom so that the microscope scheme fits into the Lightpath Scheme pad. The scheme
can be zoomed in/out using the mouse wheel.

ﬁ Device Manager... Opens the Visual Device Manager (see 4.2 Visual Device Manager ).
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4.3 Legacy Cameras and Devices

Cameras and devices called “legacy” are no longer officially supported but should work with the current version of
NIS-Elements. Drivers for these accessories are still available within the program setup, but are not tested any
more.
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Image Acquisition

5. Image Acquisition

5.1 Introduction to Image Acquisition

Having NIS-Elements installed and all hardware accessories set up, you can start capturing images. Let's begin
with the simplest case.

How to capture a single image

1) Turn the connected camera and other devices ON and start NIS-Elements.

2) Run Acquire > Camera Settings "8 to display the Camera Settings control panel.

3) Switch camera to the Live - Fast mode (Acquire > Live - Fast)

4) Adjust resolution of the Live - Fast mode to get a continuous Live image. It is recommended to set a low resol-
ution in order to achieve high frame rates. This is good when searching the specimen or when focusing
manually.

5) Adjust Exposure time to get a nice image of the scene.

6) Focus on the scene.

7) Optionally, turn on the camera ROI. The Define ROI button appears on the toolbar if the camera ROI function
is supported by your camera. See also 5.2 Camera ROI.

8) Capture the image by running the Acquire > Capture command

9) Anew image is opened automatically and named “Captured”.

Tools for Handling the Live Image

(3 Live - Quality, Ctrl |+ il If a high frame rate is not crucial or if you would like to view the live image exactly
as it will be captured, run the Acquire > Live - Quality command. It displays the live image in the Quality (Capture)
resolution. This resolution is used whenever an image is captured.

@ capture, Ctrl|+ ;| When pressed, the camera exposure runs till the end of the current frame, and the next
frame is captured and displayed on the screen (it is the first frame with the complete exposure after you have
pressed the Capture button).

If you are using the Live - Fast mode and click Acquire > Capture, NIS-Elements will automatically switch to the
quality mode to capture the image. When the image is captured, it is opened on the screen in a new image window.

O Freeze, - The Freeze button interrupts the camera exposure, and displays the very last complete frame.
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5.2 Camera ROI

You can specify a camera ROl on a live image by checking ROl in your camera pad. Please see 4.1.9 Camera Settings
for more information about camera settings.

Flash 4.0 Pad =

Format For Live D
Format For Capture
[ Auto Exposure ] [ 9.8ms E]]

ROI (512%1024)

18mm (1952 x 1352)
1imm (1192 x 1192)

| commance i

512 x 512

[ Settings

256 x 256
128 x 128

Define ROL...
Save ROL..
Load ROL...

ROI Select this option to activate the camera ROI defined via the ROl Size drop-down menu. When active, the current
ROl size is displayed in brackets. If a binning is applied, this size which is the size of the ROl on the camera chip
does not match the size of the resulting image. Also, if you define the ROI with the binning turned on, the pixel size
displayed in the definition dialog does not match the value then displayed in the brackets because it includes the
binning factor.

The user can choose a ROI size from the list or define a custom ROI via | Define ROI|. The ROI can also be saved/loaded
to/from a . camroi file (Save ROI/Load ROI).

5.3 Shading Correction

Shading correction is a method which can correct illumination inhomogeneities of the captured images. How does
this work? First of all, a “shading image” must be obtained. It is an image which represents illumination intensities

within the field of view.
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Figure 5.2. Example of a shading image showing inhomogeneous illumination

As you can see in the image above, the illumination intensity is 100% in the center but gets darker near the edges.
This can be corrected by applying the shading correction which will equalize intensities of the resulting image based
on the captured “shading image”.

Figure 5.3. Image before and after applying the shading correction
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5.3.1 Simple Shading Correction

1) Runthe Acquire > Shading Correction Panel command to display the panel.
2) Select the Simple mode in which one correction image is used for all optical configurations.

3) Click the % Capture| button, a dialog appears.

4) Find an empty clean part of the glass and move slightly out of focus.
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5)

6)

7

8)

Select image modality (background brightness) in the dialog.

Capture multiple images (10 is reasonable) by pressing the |Next >>| button. It is optimal if you move the stage
between the acquisitions. Images will be merged together to form the final correction image. The Background
Variability parameter is taken into account..

Click the |Finish| button to save the correction image.

Start using the correction by clicking the D Apply Shading Correction to All Acquisitions| button.

5.3.2 Shading Correction per Optical Configuration

1)
2)

3)

4)

5)

Run the Acquire > Shading Correction Panel command to display the panel.
Select the per Optical Configuration mode in which one correction image is used for each optical configuration.

Click the |...| button in the Capture Shading Image section of the dialog and select the optical configuration for
which you want to capture the correction image.

Click the % Capture|button and proceed in the same way described above (5.3.1 Simple Shading Correction)

Start using the correction by clicking the D Apply Shading Correction to All Acquisitions| button.

5.3.3 Removing Dust from Camera Chip Using Shading Correction

If you have dust or dirt on the camera chip, the Shading Correction panel can be used to compensate it.

1)
2)
3)

4)

5)
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Run the Acquire > Shading Correction Panel command to display the panel.
Find an empty clean part of the glass and defocus the image
Run the Acquire > Capture command to capture the image. Make sure the captured image stays active.

Select the camera or optical configuration for which the correction image will be used In the Shading Correction
panel.

Click the |Use Current Image as Shading Image| button at the bottom.



Image Acquisition

5.3.4 Shading Correction Panel

Figure 5.4. Shading Correction panel
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D Apply Shading Correction to All Acquisitions This button turns the shading correction on/off on the current
image (Simple) or on the current optical configuration (per Optical Configuration).

Simple shading correction is applied globally. If multiple cameras are used, select the one used for capturing
the shading image in the Camera drop-down menu.

per Optical Configuration applies the shading correction to the currently selected optical configuration. Use
the |...| button to select an optical configuration and use % Capture| to capture the shading image.

7 Help Opens this help page.
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% Capture Opens the Capture Shading Image dialog. The information box gives advice on how to properly capture
a shading image. Follow the instruction and click |Next >>|to capture the image. Repeat the capture multiple times
(10 times optimally) to capture an accurate shading image, then click |Finish|.

Capture Correction Image >

Correction
(®) Light Background (Erightfield)
(") Black Background (Fluorescence)
() Average Background (DIC, PhC)

Background Variability: mg

Find an empty dean part of the glass carrier, move
slightly out of focus.

Use the 'Next' button to acguire one or more images.
Press the ‘Finish' button to leave the dialog.

You are about to capture the first image.

Mext == ” Einish “ Cancel

Correction Select the type of background to be corrected. It is important for the algorithm to know whether
the background is bright, dark, or neutral.

Background Variability This value determines the level of detail of the correction algorithm (smoothness of
the curve). Homogeneous shading such as in our example above has low variability, so the default value (10)
should work fine. Higher values are suitable for more variable shading images. The range is from 5 to 50.

Preview The drop-down contains a list of captured correction images. In the Simple mode, the correction image
has the name of the camera (there can be two items if you have two cameras). In the per Optical configuration
mode, each correction image carries the name of the optical configuration used during acquisition. Once you select
a correction image, its preview appears in the Shading Image tab. You can:

° Open it to the main window by the [7 button.

° Delete it from the list by the X button.

¢ Examine its intensity profile at the bottom of the panel. Below the preview area there is a set of buttons for
changing the rotation of the profile line providing data to the intensity graph below. The profile line can be moved
manually using the mouse.

» Test the correction algorithm on the current image by switching to the Test On Current Image tab and clicking

the | = Test| button. The profile graph changes accordingly.

%‘ This button deletes all shading correction images for both modes.

Use Current Image as Shading Image If the user has a previously saved shading image, it can be loaded into this
dialog and used as a shading image.

Apply Shading Correction to Current Image Applies the currently selected shading image to the currently opened
image.

72



Image Acquisition

5.4 About ND Acquisition

5.4.1 Introduction to ND Acquisition

NIS-Elements being a multi-purpose imaging system can be used as a handy tool to study objects, live organisms,
processes, etc. The universal ND2 (N-dimensional) file format is what makes this possible. One ND2 file can contain
multiple images organized according to what type of acquisition they came from. There are the following acquisition
types:

Note

Each acquisition type gives a name to the corresponding dimension of the resulting ND2 file. For example,
we can speak about two-dimensional TZ ND2 file, which means the file contains the Time-lapse dimension
and the Z-series dimension.

Time-lapse - T A sequence of images can be captured over a period of time and create a time-lapse image. See
5.5 Time-lapse Acquisition.

Multi-point - XY Images from different coordinates of the XY stage can be acquired. See 5.6 Multi-point Acquisition.

Z-series - Z Several techniques utilize Z-stacks of images. Such Z-stack can be for example converted to a 3D
model of the specimen. See 5.7 Z-series Acquisition.

* Single-dimensional documents can be created automatically (using motorized accessories) or manually using
commands from the Acquire menu.

5.4.2 Common ND Experiment Options

The following options can be applied to all types of ND experiments:

Experiment You can enter a custom name of the experiment. Also name of the phase is editable.
Path Browse to a folder where your ND2 images will be stored.
Filename Specifies the name of the file to be saved.

Custom Metadata Check this option to add custom metadata to the image(s) being captured. Select the metadata
set from the drop-down menu and the metadata items present in the set are automatically listed below.

For information about creating and editing custom metadata please see 5.4.2.1 Custom Metadata.

Autofocus Automatic focusing can be used during the experiment. You can select the auto-focus method that best
meets your needs. The Define button shows a window where you can define parameters of the selected focusing
method.

Closing Shutter The active shutter can be closed between single image acquisitions. Just select the Close active
Shutter when idle / Close active shutter during filter change option in the experiment window.

Running Macro Commands You can define a command (or a macro) to be run in various stages of the experiment.
Select the timing in the Advanced section of the experiment window and enter the command to be run.

Load Loads a configuration XML file. The file with the current configuration can be created using the Save button.

Save Saves the current configuration of this dialog to an XML file. A standard Save As window appears.

73



5.4.2.1 Custom Metadata

To create or edit existing metadata, check the Custom Metadata checkbox in your ND experiment and click |Edit|.
The following dialog window appears.

. Edit Custom Metadata I& .
[Metadata B] [D New ]M Save ”B Import = ”lr;i Export = ”)( Remove ]
+He X ¥

Name | Type | Description | Properties | Default | Mandatory

[ emifc Selection |Z| Positive/Megative/C...  Edit Values... Contral |Z|

[ solvent Selection |Z| . Edit Values... | Glucose |Z| O

[[] concentration Mumeric Value |Z| {0;00)  Format... 5,000 O

|:| Genes Long Text |Z| Genes GA3A45 |:|

O

To create a new custom metadata set - click on D New| and give it a name. Click| 4 |Add New and Name your
first metadata item, choose its Type, enter a text Description, edit its Properties, choose the Default value and select
whether it is Mandatory or not. Add as many metadata as you like and confirm their definition by clicking |OK|.

To edit an existing metadata set, simply change parameters of the items in the table, add more items ( 4 ), change
their order ( 4 v ), or remove one ( X ) or all ( ﬁl ).

You can save the whole metadata set as a .xml file by clicking E? Export|. To import your saved metadata set, use
@ Import.| To delete the current metadata set, click X Remove|.

Note

The created metadata can be changed after acquisition in the image properties dialog (File > Image Properties).

5.4.3 ND Sequence Options

The following options can be applied to time, multipoint and multichannel sequences in ND experiments:

'I-[E Adds a new incubation phase into the sequence (Time-lapse acquisition only, (requires: Stage Incubator)). For
more information please see 5.5.1 Special Options.

=4 Add Adds a new step into the sequence.

@ Select All Selects all steps in the sequence.

Clear Selection Clears the step selection.

4 Move Up,+ Move Down These buttons move the current step up/down in the sequence.
3 Remove Current This button removes the selected step from the sequence.

ﬁl Remove All This button removes all steps from the sequence.
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5.5 Time-lapse Acquisition

Detailed studying of long-lasting processes is enabled by the time lapse acquisition mode of NIS-Elements. The
achievable experiment duration is limited by the hardware abilities of your PC only. Invoke the Acquire > Capture

Timelapse &> Capture Automatically command to set the experiment up:

~ Time schedule
Interval | Duration | Loops r
2sec Iz‘ 24 sec Iz‘ 13

The Time schedule table enables you to define one time phase where duration, interval between single images,
and number of images of the phase can be adjusted. The Interval, Duration, and Loops settings are bound together,
S0 you just need to set two of these parameters. The remaining parameter is calculated automatically.

The flag mark indicates the Duration/Loops priority. For example: if the camera exposure time exceeds the defined
Interval between frames, than the experiment settings are not achievable - only the marked column will be pushed
to be correct. You can set the priority column by clicking on its caption.

5.5.1 Special Options

The following options can be used with this type of ND acquisition. Options common to all types are described here.

Switch Transmitted llluminator off When Idle If this option is selected, the lamp is turned off whenever there is
a long-enough gap between two acquisitions.

Warning

It takes a little time for some lamps to reach the set intensity. In such case, we recommend to use the wait () ;
macro function before the capture is performed.

Events Press the |Events...| button to display the following window:

Move To Next Phase

User Defined Events

Hot key Description Macro
User 1: [Shif’twage Up ] lStart Heating ] [Stg_HeatStageStarH—leaﬁngCuo\ing0,' lm
User 2: [Shiﬁ:-wage Down ] lstnp Heating ] [Stg,HealstagesmpHeanngCoahngO; k Run Macro....
Run Shared Macro  *

User 3: [ 5pace | [(cet Activity |
1T

User 4 [ piope 1 Command List...

Define user hot keys which run user events during time-lapse acquisition. Simply click inside the Hot key field of
the User events window and press any key combination you want to assign to the event. Then you can enter the
event description. A macro command can be specified which will be executed when the event occurs (is triggered
by the user). When the event occurs, the specified command is run and a marker is placed to the time line of the
ND2 file.
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5.5.1.1 Advanced options

These options are shown after clicking |Advanced >>|. Following features are available.

Auto Focus Automatic focusing can be used during the experiment. You can select the auto-focus method that
best meets your needs. The Define button shows a window where you can define parameters of the selected focusing
method.

Note

It can be determined whether the focusing shall be performed at the beginning of the whole experiment or at
the beginning of each phase. If the auto-focus is set to be performed Before each Phase and the ND Experiment
contains just a single time phase, the automatic focus will not be performed. To run auto focus, use the At
the Beginning option.

Execute before/after each Time This field enables to run a command which is executed before or after each loop.
Click on the right drop-down button to enter a macro from a file (Run macro...), a macro command from the list
(Command List...) or a macro command from the list performed on every N-th loop (Command List Every N...).

Note

Image processing macro commands are not executed during the acquisition.

Execute before/after Time phase This field enables to run a command which is executed before or after each
time phase. Click on the right drop-down button to enter a macro from a file (Run macro...) or a macro command
from the list (Command List...). Advanced for combo box specifies to which phases the macro commands are as-
signed. To assign them to all phases present in the current settings, click |Apply to All|.

Note

Image processing macro commands are not executed during the acquisition.

5.6 Multi-point Acquisition

(requires: Stage)

This window serves for defining XY(Z) points to be scanned during the multipoint capture experiment. This feature
is available when a motorized stage XY(Z) is present in the system. Check the Include Z box to display the Z column.
The list of defined points can be saved (and loaded later) to an XML file by the Save (Load) button. Run the Acquire

> Capture Multipoint 888 > Capture Automatically command.

5.6.1 Point by Point (Manual) Multi-Point

1. Move the stage to the first position.

2. Press the == Add New button. A new line containing current coordinates of the stage appears in the list.

3. Move to the next position and repeat the steps until you have all the intended points defined.
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5.6.2 Well Plate (Rectangular) Multi-Point

You can insert a pattern designed to cover a wellplate. Of course it can be used to create any rectangular pattern.

1)

2)

3)

Click the |Custom| button. The following window appears
Select Manual if you know the distances between wells. Otherwise select the Interactive and continue.

Manual This method will create a pattern which will scan Rows x Columns fields. The Distance X and Y para-
meters specify distances between two fields. The scanning will begin at the current position.

Interactive The interactive method lets you specify the number of fields to be scanned and starts a wizard
where you will specify the top-left and the bottom-right corner of the well plate. The distances between wells
are calculated automatically.

Click |Finish|.

5.6.3 Large Image (Covering) Multi-Point

A Multi-point which will cover certain area can be created:

1)

2)

3)

Click the |Custom| button and select the Large Image tab
Set the large image settings:

Scan Area Select whether to define the Scan Area by number of fields or the actual field size.
Camera Select the camera to be used. This field is enabled only if you have a dual-camera setup.

Objective Select the objective for which the multi-point will be calculated. The resulting number of fields / area
size changes depending on the selected objective magnification.

Overlap Overlap of neighboring images in %.

Click |Finish|.

5.6.4 Random Multi-Point

Specify the area where a random set of points will be generated.

1)

2)

Click the |Custom| button and select the Random tab.
Select shape of the area to be filled with random points

Rectangle The area will be defined by a rectangle. Define X and Y coordinates of left top corner of the area,
width and height of the area.
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Radius The area will be defined by a circle. Define X and Y coordinates of center of the circle.

3) Specify Number of points in the multi-point set.

4) Click |Finish|.

5.6.5 To Change a Single Z Coordinate

1. Make sure the Move stage to selected point is pressed. This button ensures that the motorized stage moves to
the coordinates of the currently selected point.

2. Click inside the line you would like to change.

3. Move the Z drive to the new position.

4. Click the <- button.

Note

The XY coordinates of one point cannot be adjusted (unless you delete it and add a new point).

5.6.6 Special Options

Autofocus None, Steps in Range, Steps in Continuous.
Custom Displays a tool for creating predefined multi-point patterns.
See 5.6.2 Well Plate (Rectangular) Multi-Point, 5.6.3 Large Image (Covering) Multi-Point, 5.6.4 Random Multi-Point.

Define Stimulation Laser Powers If checked, Laser Power Settings dialog window appears when defining stimulation
ROIs. This window enables to define power of each laser line on each stimulation group.

Execute Command after Capture You can either Run Macro, or select a command from the Command list. The
command is executed after capturing.

Execute Command before Capture You can either Run Macro, or select a command from the Command list. The
command is executed before capturing.

Include Z If selected, also the Z coordinate will be taken into account during XY(Z) acquisition.

Note

This option is disabled if the Relative XY option is used.
Leave PFS offset ON between points Check this item to keep PFS on while moving between the points.

Move Stage to Selected Point This button ensures that the motorized stage moves to the coordinates of the currently
selected point.

Offset All

The |offset all| button can shift the XY coordinates of all points in the same way:

1. Make sure the Move stage to selected point is pressed. This button ensures that the motorized stage moves to
the coordinates of the currently selected point.
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2. Select one point of the list.
3. Move the XY(Z) stage to a new position (define the offset).
4. Press the Offset All button.

5. The coordinates of all points change - the same shift which you made with the stage is applied to them.

Optimize If the Optimize button is pressed, the system will re-order the defined points in order to minimize the XY
stage trajectory.

Point name Displays the name of the point. You can change the name (default names are #1, #2 #3, etc.).

Redefine reference Z after Auto Focus Check this option to redefine reference Z position after performing autofocus
or PFS (if AF or PFS is turned on).

Relative XY Check the Relative XY item to consider all coordinates as relative with respect to the current stage
position. Any of the points may be used as the reference point, just right-click it and select Set this point as a reference
position.

Stim. Device Defines which connected device will be used for stimulation.
Use Focus Surface Uses Focus Surface for capturing.

X, Y, Z Displays X, Y and Z coordinates of the point. The arrow buttons |->||<-| assign the current XYZ position to the
point. The Offset All X, Y, Z| button shifts the XYZ coordinates of all points by the same offset which is defined as a
difference between the current stage coordinates and coordinates of the selected point.

5.7 Z-series Acquisition

(requires: Z Drive)
Automatic capturing of images from different focal planes using a motorized Z drive can be performed. Run the

Acquire > Capture Z-Series =% > Capture Automatically command to display the setup window. There are three

different approaches of how to set the experiment:

Defined by top bottom

Required values: top position, bottom position, step size or number of steps.

1) Clickonthe T Defined by top bottom button, the cube turns blue.

2) Runthe (& Live camera signal.

Note

If using two Z devices, choose one Z device from the pull-down menu.

3) Define the Z-range of interest:

* Move the Z drive to the top position and press Top.

° Move the Z drive to the bottom position and press ' Bottom.
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4)

Note

Both values can be adjusted in the Bottom and Top edit boxes below.

Enter the Step size in um (distance between adjacent steps) or specify the number of Steps to be captured.

Note

This mode assigns the Home position automatically to the middle step (e.g. the third step out of the whole 5

steps). | XX Reset| discards the Top, Home, and Bottom position settings.

Depending on the direction of Z-acquisition, the last Z position (top or bottom) may slightly differ from the user
settings. However, you can select which position will be preserved exactly. Right-click on one of the buttons
(ITop| or |Bottom)) and select Keep exact Top Position / Keep exact Bottom Position. This setting is indicated
by underlining/overlining the button text.

Symmetric mode defined by range

Required value: range.

1)

2)

3)

4)

Click onthe & Symmetric mode defined by range button.

Run the {4 Live camera signal.

Note

If using two Z devices, choose one Z device from the pull-down menu.

Move the Z drive to the absolute home position (center of your Z series) and click > Home. If you do not

know the exact center position yet, you can then switch to == Relative and the home position will be taken
from the current Z position prior to the actual acquisition.

Enter the Range to be captured and then adjust the Step size in ym (distance between adjacent steps, for the

recommended value click 4= Use suggested step size) or enter the number of Steps to be captured within
this range.

Asymmetric mode defined by range

Required values: above position, below position.

1)

2)

3)
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Click onthe X Asymmetric mode defined by range button.

Run the {4 Live camera signal.

Note

If using two Z devices, choose one Z device from the pull-down menu.

Move the Z drive to the absolute home position (center of your Z series) and click } Home. If you do not

know the exact center position yet, you can then switch to =~ Relative and the home position will be taken
from the current Z position prior to the actual acquisition.
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4) Specify the range from the home position by entering the Below and Above values and adjust the Step size in

um (distance between adjacent steps, for the recommended value click = Use suggested step size) or enter
the number of Steps to be captured within this range.

Special Options

Piezo Z If a Piezo Z drive device is connected, the Piezo button appears in the panel. Use the pull-down menu to
select the action which will be performed upon pressing the button:

VA Keeps Z position and centers Piezo Z This option moves the Piezo Z drive to the home position, but
compensates the movement by the second Z drive in order to keep the original absolute Z position (sum of
Z1 and Z2).

V Move Piezo Z to Home position Moves the Piezo Z drive to the home position regardless of the absolute
Z drive position.

Direction You can define the Z-stack scanning direction - either from Top to Bottom, or vice versa (Bottom to Top).

Two Z devices Two Z devices (Main Z + Piezo Z) can be used for Z-Series acquisition. Z device combination is used
automatically if AF/Z-Stack range exceeds the range of Piezo Z. Combining two Z devices speeds up the Z stack
acquisition, however the user can still decide whether or not to use the Z device combination. Only the Main Z
device is used if it is selected in the Z device combo box. Only the Piezo Z device is used if it is selected in the Z
device combo box and the defined Range is within the device range. Combination of both Main Z and Piezo Z is
used if Piezo Z is selected in the Z device combo box and the defined Range is bigger than the device range.
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6. Displaying Images

6.1 Open, Save, Close Images

6.1.1 Opening Image Files

6.1.1.1 Different Ways to Open an Image File

NIS-Elements offers several ways to open an image file, using either:

File > Open @ command To invoke the Open dialog box where you can select the file to be opened, run the File
> Open B command. This command is also called when you click the Open button on the main toolbar.
Organizer An image can be opened by double clicking its filename within Organizer. Run the View > Organizer
Layout 'l/ﬁ command F10 |to switch to the Organizer. See 6.6 Organizer.

Recent Files List You can quickly access the last opened images using the File > Recent Files menu.

Open next/previous/first/last Commands These commands enable you to continuously open the subsequent
images from a particular directory or a database table. The File > Open/Save Next > Open Previous, File > Open/Save
Next > Open Next, File > Open/Save Next > Open First, File > Open/Save Next > Open Last commands may be
used.

Auto Capture Folder The Auto Capture Folder is a control panel that can be displayed by calling the View > Acquis-
ition Controls > Auto Capture Folder @ command. It displays images within a selected folder. To change the folder

click the ‘E button in the top left corner of the control panel and browse for another folder. Any image of this
folder can be opened by a double-click.

Any File Manager During installation, NIS-Elements creates file associations to files that are considered its native
format for storing images (JP2, ND2). The JP2 and ND2 files can be then opened to NIS-Elements by double clicking
their names within any file manager.

6.1.1.2 Switching Between Loaded Images

Commands for managing the opened images are grouped in the Window menu. The recently opened files are listed
in its bottom part. The currently displayed image is indicated by the selected radio button. To change the current
image, select it from the list or use the Next or the Previous commands (represented by Ctrl + Tab|and Ctrl|
+ Shift|+ Tab|shortcuts).
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Window

Next Ctrl+Tab
Previous Ctrl+5hift+Tab

& Close Al Cirl+5hift+4
Close All but Current Shift+r4
Close

) 1. Captured

= 1. C:¥PROGRAM FILES¥MIS-ELEME.. . ¥malus. tif

6.1.1.3 Automatic Image Sequence Recognition

When you select to open an image that is a part of image sequence such as 001.JP2, 002.JP2..., it is recognized
automatically and you are offered to convert it to an ND2 file.

6.1.2 Saving Image Files

6.1.2.1 Basic Workflows

NIS-Elements offers several ways to save an image file, using either:

The File > Save E command Saves changes in the current image. If the current image is new (was never saved
before), the File > Save As command is called instead.

The File > Save As command Saves the current image and lets the user specify the destination folder, format and
file name.

The File > Open/Save Next > Save Next [e§ command This command saves the current image (live or static)
automatically according to the settings defined within the general options window.

During image-capturing experiments Images and image sequences can be saved automatically during experiments
such as ND Acquisition (5.4 About ND Acquisition).

6.1.2.2 Saving Images with UAC

Because of the security enhancement with the UAC (user account control) of Windows Vista and Windows 7, it is
not possible to save images in those folders that require Windows administrator user rights. Those folders are:

¢ C:\Windows and subsequent folders
* C:\Users and subsequent folders excluding C:\Users\[login-user-name]

* C:\Program Files and subsequent folders excluding C:\Program Files\NIS-Elements\Images

84



Displaying Images

6.1.3 Closing Images

The currently displayed image can be quickly closed by pressing the cross button in the top-right corner of the
image window.

* The image can be also closed by invoking the File > Close command.

If you want to close all images, use the Window > Close All ﬂ command.

If you try to close an image that has been changed, NIS-Elements will display a confirmation dialog box, offering
to save the changes.

Use the Window > Close All but Current command to close all opened documents but keep the current one
opened.

6.1.4 Supported Image Formats

NIS-Elements supports a number of file formats for opening. In addition, NIS-Elements uses its own image file
format (ND2) to fulfil specific application requirements. The following list contains file formats which can be displayed
in the software, however, if you do some changes to the files which you want to save, we recommend to use the
native NIS-Elements format ND2 for that purpose - use the File > Save As command.

AVI, MP4 NIS-Elements imports this movie format as a time-lapse sequence of images. Sound is not supported.

JP2 - JPEG2000 Format An advanced format with optional compression rates. Image calibration, text descriptions,
and other meta-data can be saved together with the image in this format.

ND2 - N-Dimensional Image This is the special format for storing sequences of images acquired during ND exper-
iments. It contains various information about the hardware settings and the experiment conditions and settings. It
also maintains all image layers of course.

NEF, NRW These RAW images produced by Nikon photo cameras can be displayed in NIS-Elements keeping the
original bit depth (10 or 12 bits per channel).

JPG, JFF, JTF - Joint Photo Expert Group Format Standard JPEG files (JPEG File Interchange Format, Progressive
JPEG, JPEG Tagged Interchange Format) used in many image processing applications.

TIFF, TIF - Tagged Image File Format This format can save the same amount of meta-data as JPEG2000. TIFF
files are larger than JPEG2000 files but are loaded faster. TIFF files have several ways to store image data, therefore
there are many versions of TIFF. NIS-Elements supports the most common TIFF modalities. TIFF image format in
NIS-Elements supports also floating point images.

OME.TIF, OME.TIFF OME metadata (OME-XML) are included for increased compatibility between applications. This
format can handle multi-dimensional images (Z-stack, Timelapse...). Multipoint (XY) images are split and saved as
separate files automatically.

GIF - CompuServe Graphic Interchange Format This is a file format commonly used on the Internet. It uses a
lossless compression and stores images in 8-bit color scheme. GIF supports single-color transparency and animation.
GIF does not support layers or alpha channels.

PNG - Portable Network Graphics Format This is a replacement for the GIF format. It is a full-featured (non-LZW)
compressed format intended for a widespread use without any legal restraints. NIS-Elements does not support the
interlaced version of this format.

PSD - Adobe Photoshop NIS-Elements can display Photoshop images. Specialized features of the format such as
vector or textual layers will be rasterized.
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BMP - Windows Bitmap This is the standard Windows file format. This format does not include additional image
description information such as author, sample, subject or calibration.

LIM - LIM Format Developed for the needs of laboratory image analysis software. Nowadays, all its features (and
more) are provided by the JPEG 2000 format.

LSM - Zeiss LSM Image NIS-Elements can display LSM images. Specialized features of the format may be omitted.

ICS/IDS image sequence ICS/IDS image sequences are generated by some microscopes and consist of two files:
the ICS file with information about the sequence; the IDS file containing the image data. The ICS file must be stored
in the same directory together with the IDS file.

Caution

ND Images containing multi-point XY dimension cannot be saved to a file in the ICS/IDS format. See also 5.4
About ND Acquisition.

NDPI, VMS - NanoZoomer files We can open these files produced by Hamamatsu devices and save the image in-
formation to an ND2 file.

ShuttlePix files Nikon ShuttlePix Digital Microscopes produce standard TIFF and JPEG files and save the calibration
info to a separate file. NIS-Elements recognizes the calibration file and loads it along with the image data.

6.1.5 Floating Point Images

In NIS-Elements, a “floating point image” (FPI) is any image which has its pixel intensities represented by “floating
point numbers” instead of integers. The format used is called “single-precision floating-point format” and it extends
the available intensity range to 32 bits per channel (intensity can range from -3.402823 x 10%8 t0 3.402823 x

1038). In short, floating point images allow to store high-precision quantitative information and can be saved in
TIFF or ND2 file formats.

6.2 Image Layers

6.2.1 Introduction to Image Layers

The following image layers can be saved within a NIS-Elements image.
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Annotation layer In this layer, vector objects are stored. The results of manual and automatic measurements, text
labels and other annotations can be included.

Binary layer(s) The binary layer is usually the result of segmentation. By segmentation, you distinguish objects of
interest from background. A picture of night sky can make a nice example - shining stars may be “thresholded” and
compose a binary layer. Then, by means of automatic measurement, you can count them. More than one binary
layer can be placed over one image. See 7.3 Binary Layers. (requires: MEAS (Automatic Measurement))

ROI layer ROIs (regions of interest) is a strong tool for distinguishing objects from background similar to the binary
layer. The advantage over the binary layer is that ROIs are vector objects and therefore provide different way of
manipulation. See 7.4.1 Introduction to ROIs.

Color layer The color layer contains the image data captured by a camera. It can handle images with the depth of
up to 16 bits per color component. The dimensions of this layer determines the dimensions of the other layers.

Note

When saving an image, only some file formats are capable of saving all the layers. The other image formats
will save the content of the color layer only. See 6.1.4 Supported Image Formats.

6.2.2 Image Types

RGB Images

Images acquired by a color camera typically consist of three components that represent red, green and blue
channel intensities. You can display a single color channel using the tabs located in the bottom-left corner of the
image window. Or, an arbitrary combination of them can be selected while holding the Ctrl | key down.

' Rek ) M Red /@ Green ) M EL: [
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Multi-channel Images

These documents usually arise from fluorescence microscopy. Instead of 3 color components (RGB), multichannel
images can be composed of arbitrary number of user-definable color channels.

Note

If an image contains more than 8 components, the tabs in the bottom left corner of the image are replaced
by the wavelength dimension, similarly to how other dimension loops of ND2 files are displayed.

Click the Il Treat As Spectral button in the top image toolbar to use the current image as a spectral image revealing
more channel switching features in the bottom control bar.

1 |-| IE-‘?U |TI-I| L

Islqglllllllﬁlﬁglllllllmgl Ialal CUST.

aro 1o e300,

ALL Selects the full spectrum of the image including spectral (FLUO) and transmitted detector (TD) channels.
FLUO Selects only spectral channels. This button is useful for quick switching between FLUO and TD.
TD Displays only the transmitted detector (TD) image.

CUST. This button displays custom channels. To set a channel (multiple channels) as custom, make a channel se-
lection in the control bar, right-click over the selection and choose Set selected channels as Custom.

Please see 6.3.1 Navigation in ND2 Files, 5.4 About ND Acquisition.

6.2.3 Channel Coloring

Single channels and monochromatic images can be visualized using a predefined color scale. Right-click the

“channel tab” in the bottom left corner of the image window and select a color scale from the ™ Channel Coloring...
sub-menu.

M channel Coloring In color Ctrl-+Alt+Shift+C

Maono
Copy selected channel
£ Rainbow
Remave TexasRed'
Iron
Reorder Channels... ]
Green Fire

ufulofulal

Extract selected channels Green Fire Blue

Brightfield and Fluorescence channel image

If your ND2 image contains only one brightfield channel with its Modality set to Brightfield in Channel Properties,
the behaviour of viewing colors of these channels slightly changes. The brightfield channel is set to Mono color by
default but can be switched to any other pseudocolor. The fluorescence channels are displayed in their native
fluorescence color by default and can by switched to any other pseudocolor. Once the brightfield and fluorescence
channels are displayed together in an overlay, the pseudocolor of the fluorescence channel is ignored and is shown
in its true color.

88



Displaying Images

6.2.4 Assigning Colors to Channels

Despite the color in which a channel is displayed, other per-channel colors can be assigned to it. This regards colors
for:

¢ indication of oversaturated pixels
¢ indication of undersaturated pixels
* indication of binary pixels

In the context menu over a channel, select Colors for and choose a color for oversaturated pixels, undersaturated
pixels (these colors are used globally for all images in NIS-Elements until next change) and for binary pixels. Selected
color for binary pixels is linked to the channel name and is shown in all images having the same channel name.

Oversaturated pixels
Reset LUTs For 'FITC
W Complementary Colar
Calors For 'FITC Il Red
] B Green
Properties...

Color of oversaturated and undersaturated pixels may also be selected from the pull down menu next to the Pixel
Saturation Indication (Ctrl+Shift+S) M button shown in the image toolbar.

Figure 6.7. Pixel Saturation Indication sub-menu

Pas

Oversaturated pixels

Mone
Take calor From channel tab
W Complementary color

B FRed

I rCreen

None The pixel saturation will not be indicated.

Take color from channel tab Color which has been previously assigned to oversaturated and undersaturated pixels
in the menu over the channel tab will be used. See 6.2.4 Assigning Colors to Channels.

Complementary color Colors complementary to the display color of each channel will be used in order to ensure
good visibility of the highlighted pixels.

6.2.5 Copying Channels by Drag and Drop

Drag one of the channel tabs and drop it to the left portion of the image window in order to create a new image.
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Note

e Even the All and RGB tab can be copied.

* When extracting a channel from Live image, it does not freeze the camera signal.
6.3 ND Dimensions

6.3.1 Navigation in ND2 Files

6.3.1.1 Control Bar

Figure 6.8. A Time-lapse image.
EJ 0.5 1@5 EEE 3 35 @ 4.5 5 ]
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When an ND2 file is opened, its structure is pictured at the bottom of the image window.

1. There is a time line with all captured images indicated by gray markers. The blue-highlighted marker indicates
the currently observed image frame. You can browse the ND2 file by clicking inside the time line.

2. Below the time line, loops of each dimension are indicated by blue rectangles. Loops can be selected by mouse
while holding Ctrl|or Shift|keys and are highlighted green.

Note

ND2 files may contain a very large number of frames. It may be useful to omit some of the frames from the
selection. See Selection Context Menu.

3. Each dimension can be browsed frame-by-frame or you can use the playback controls on the right side.

In specific cases the ND2 file control bar looks differently.

If the number of channels exceeds 10, the image is considered to be a spectral image and a lambda dimension is
displayed instead of the standard channel tabs.

Figure 6.9. T/Z/multi-channel image containing 11 channels and the time line hidden

N LRSS AL — T + (R M)

90



Displaying Images

Figure 6.10. HDR multi-exposure image

N e

Figure 6.11. Multi-channel image containing 11 channels

» e e e e |

Playback Controls

liii select All Frames Selects all frames of the dimension and highlights them green.

»» Play Sequence Plays all images of the dimension at a defined speed. If a selection is applied, only the selected
images are included in the playback.

Il Stop Playing Stops playing the sequence at the last displayed frame.

<4 Previous Position, P> Next Position Displays the previous/next frame of the dimension.

= Decrease Playing Speed, Increase Playing Speed Changes the playback speed by one step down/up.
B Real Time Playing Speed On Sets the playing speed to real-time (as the image was captured).

m Maximum Playing Speed for Every Frame On Sets the playing speed to maximum while the display of every
frame is guaranteed (when the speed is set to maximum by the + button, some frames are usually omitted when
playing the sequence depending on your graphics card).

M4 Home Position Displays the frame of the Z dimension that was set as “home” during the acquisition.

Selection Context Menu

Right-click a loop (blue rectangle) to display the selection context menu. There are the following commands:

Note

The placeholder X is the name of the current (clicked) dimension, i.e.: T, Z, M, ...

Select All Frames in X Selects all frames within the current dimension. The Select Every option is reset to Every
automatically.

Select Frames in X Opens a dialog where the user can define a range of frames to be selected.
Invert Selection Inverts the current selection while preserving the Select Every option.
Select Every Every Nth frame of the selection is used. First make a selection of frames either by mouse (while

holding down Shift|or Ctrl|) orselect all frames using the Select All Frames command or the il buytton.
Then choose the Select Every option. Selection is changed to every Nth frame of your previous frame selection.

Note

Once this option is turned on, it is applied all over again even after making a different frame selection. To turn
this function off, switch it to Every or select all frames.

Keep Selected Frames in X, Delete Selected Frames in X When one of these commands is called, a new image
file is created containing only the selected/deselected frames.
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Select Frame (N) Selects the clicked frame and de-selects all other frames of the current dimension.

Delete Frame (N) Deletes the clicked frame of the current dimension and also the custom selection of frames/loops
of the other dimensions.

Note

If you want to keep all frames/loops of other dimensions, make sure you applied the Select All Frames command
to them.

Tips

* Detailed info about dimensions will be displayed after you click the leftmost button of the control bar (T>, Z>,

).

* Place the cursor over one of the dimensions. A tool-tip which displays statistics of the dimension appears.

Playing options

Right-click the speed bar to display the following context menu and select the playing mode.

UJ Back and Forth, ((J Forward, 1) Backward Define the direction how the image sequence will be played.
(J Repeat Sets the repetitive infinite playback.

|1| Stop on Events When you select this option and then press the [ Play Sequence button, a dialog window
appears once the first user event is reached. The dialog window displays information about the reached user event.
Use the Continue button to continue playing to the next event, or press the Stop button to stop the playback at the
current frame. Within the window, you can also select the Do not ask again in this session (Always stop) option.
Playing will then stop automatically on every user event but the window will not be shown.

Maximum Speed This command corresponds to the m Maximum Playing Speed for Every Frame On| button de-
scribed above.

Real Time This command corresponds to the B Real-Time Playing Speed On| button described above.

6.3.2 ND Views

There are several views which can display the ND2 files in various ways. Some views are available for some dimen-
sions only. If a view is available for two or three dimensions of the ND2 file, a pull-down menu appears in the top
image toolbar. There you can select the dimension to be displayed.

Note

When you switch the view, a new image window opens by default. This behavior can be changed within the
Edit > Options ¥¥ command window so that only one view of an image will be opened at a time.

|:| Main View When you open an ND2 file, it opens in this view.
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Figure 6.12. Main View

QH Slices View (requires: EDF Module (Extended Depth of Focus)) This view displays orthogonal XY, XZ, and YZ
projections of the image sequence. (Requires Z or T dimension)

Figure 6.13. Slices View

6.3.2.1 ND2 Information

Information about current frame of an ND2 document or live image can be displayed using the Show ND Information
command from the image contextual menu. It displays information about current frame of the ND2 document or
live image. All possible information (metadata) are displayed by default.

You can edit which information is displayed in the Label Properties dialog window. Right click the ND2 information
field and select ND Info Properties.... Select displayed features from the Available ND information area and use
the | ~ | button to insert them into the ND information text scheme area which defines the visible information. Use
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Format options tools to specify the data format (e.g. numeric precision, date format, etc.) and adjust the text ap-
pearance in the Text Box tab. Always show Acq. Time forbids removing the Acquisition Time information from the
ND information text box.

To view the physical zoom of your image (how many times the image is magnified on your monitor compared to the
real dimensions of the calibrated sample), click on Show Physical Zoom in the context menu over your image. The
maghnification is placed as an overlay information in the corner of your image.

6.4 Large Images

6.4.1 Opening Files in Progressive Mode

If a single image (or one ND2 frame) is too big and it can not be loaded to RAM in one piece - you will be asked
whether to open it in a Progressive Mode. This means that only a thumbnail of the image will be loaded to the RAM.
When zooming-in to view image details, the image data of the particular portion of the image will be loaded to RAM
progressively (piece by piece).

Many image processing functions and commands are disabled in this mode. This problem usually occurs with Large
Images created by stitching several frames together. In case you need to process such an image, a smooth solution
is to split it into tiles and create a multi-point ND2 file out of it. Please see 6.4.2 Splitting Large Images.

6.4.2 Splitting Large Images

You can split an existing large image to tiles easily.

1) Open the large image to be split.

2) Run the Image > Split Image command. A dialog window appears.

3) Set split options:
Split to separate files - output format Select the output format (ND2 or TIFF). A separate file will be saved for
each tile. Define Output folder and Prefix where the files will be saved.

Create multipoint ND Document Only one multi-point ND2 file will be created and opened after the split.

Set measurement frame after splitting The measurement frame will be turned ON after the split in order to
exclude overlapping areas. This is to prevent distortion of data in case of measurement.

Tile Size, Number of tiles Define width and height of a single tile in pixels or set the number of columns and
rows to which to split.

Overlap Set overlap value of neighboring tiles either in % or the current calibration units (presumably um).
Overlap up to 50% of the tile size is allowed, higher values are reduced to the maximum.

Fill background|Select a color to fill empty spaces which will appear the total area of tiles exceeds the image.
Use |Optimize| to prevent the empty spaces.
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4) If you do not require the tiles to have exact size, click |Optimize|. The system will arrange/resize the tiles
automatically so that the whole image is covered precisely.

5) Click |OK|.

6.4.3 Locating XY Positions Between Images

If two images have matching XY coordinates you can locate the exact position in one image inside the other. This
would be the case especially after using the Image > Split Image command. Right click the location within the first
(multi-point) image and select Find this Point in Paired Document from the context menu.

If you do this right after splitting the large image (the two images are “paired”), the system displays it and highlights
the XY position by a flashing cross. If it is not clear to the system which images shall be paired (e.g. three or more
images with matching coordinates are open), the user will be prompted to select the second image to the pair.

6.4.4 Methods Used for Stitching Large Images

Some NIS-Elements functions for creating large images by stitching multiple image frames enables the user to select
a stitching method. Select the one you serves better your purpose:

Blending Overlapping image parts will be blended.

Figure 6.14. Stitching via "Blending" (pixel intensity is changed in the overlapped region)

Image 1 Image 2

0 Intensity X

Optimal Path A contour where two overlapping images are least different will be computed. The images will be
stitched copying this contour.
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Figure 6.15. Stitching via "Optimal path" (pixel intensity is preserved)

Image 1 Image 2

o [ntensity I

6.5 LUTs - Non-destructive Image Enhancement

6.5.1 Introduction to Look-Up Tables (LUTS)

LUTs is a useful tool for image color and brightness modifications. You can use LUTs to enhance images for obser-
vation purposes so the color modifications will be non-destructive to the image data. LUTs settings are saved along
with the image file. If required, the LUTs settings can be applied to the image data by pressing the H*H button. Use
the [Z Show LUTs window button in the image toolbar to display the LUTs window.

The following actions are available within the LUTs window:

* Adjusting the Gamma parameter. The gamma curve is drawn in gray over each graph. You can drag the middle
point and move it up or down, or enter an exact value to the G: field at the top of the graph area.

* Adjusting the input intensity range. The input intensity range can be restricted by moving the black and white
triangular sliders to the center. All pixels with values outside of the modified input range will be set to maxim-
um/minimum values and the remaining pixels will be approximated in order to fill the output (full) range.

Note

This is the way how images can be equalized. For example, if the image is very dark and most of the histogram
is located to the left while the right part of it is flat, you may move the white slider(s) to the position where
the histogram line starts to rise. This will incredibly brighten the image and reveal details which were previ-
ously hidden in a dark.

* You can adjust the histograms height non-proportionally by moving the slider on the left side of the window up
and down.

Tips

* Right-click the graph area and (de)select Draw trend style. When ON, the LUTs curves will be smoothed to display
the data trends rather then represent the actual image data values.

* The position of the black, white and Gamma sliders can be reset by a double click.
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Different controls will be available when applying LUTs to monochromatic, RGB, multi-channel or spectral image.
When LUTs are active, the LUTs button in the top-left corner of the image window is highlighted red.

6.5.2 LUTs on RGB Images

LUTs x
BN K - [Oaws G X [L2 -1 BB | H-
o G: 0,46 1

There are 3 separate windows for each of the RGB channels. All channels are controlled at the same time by default.
To control each channel separately, press and hold the Shift |key while you drag the sliders or adjust Gamma.

LUTs Tools

!gNg Enable/Disable LUTs This button applies LUTs to the current image.

17 Keep Auto Scale Press this button to run the auto scale procedure permanently (on the live image). When you
turn this button OFF, the settings remain as if the Auto Scale button was pressed only once.

I Auto Scale This button adjusts the white slider position of all channels automatically with the purpose to enhance

the image reasonably. If you have selected the Use Black Level option from the Settings pull-down menu, the black
slider will be affected too.

X Reset All Components Discard all LUTs settings and turn LUTs OFF by pressing this button.

Settings pull-down menu Display the pull down menu and select one of the following commands:

* Brightfield Opacity - You can change opacity of a brightfield channel. Define the opacity in the Brightfield Opacity
dialog window that appears after you run this command.

* Use Black Level - Check this item to ensure that the black slider will be affected by the auto scale functions.

» Settings - opens the Auto Scale Settings window. See 6.5.2.1 Auto Scale Settings.
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Keep Auto White Balance Check Box Check this option to switch the Auto White Balance functionality permanently
(on the live image).

AWB Press this button to perform the Auto White Balance operation once.

Auto White Balance Color (...) This button Opens the AWB Color window and enables you to select a color shade
which the system shall eliminate (make white). See 6.5.2.2 AWB.

X Reset AWB If Keep Auto White Balance or Auto White Balance function is applied, this button turns it off.

M Color Oversaturation Switch this button ON and the system highlights all pixels with values reaching maximal
values. Select colors to highlight the pixels with in the pull-down menu. See also 6.2.3 Channel Coloring.

B0 B] These buttons arrange histograms of single channels next to each other horizontally or vertically.

- This button arranges histograms of single channels overlapped. Use sliders at the bottom of the graph window
to amplify or reduce the green/red/blue component display in the view.

H- Save/Load LUTs This pull-down menu enables user to handle LUTs settings in various ways. They can be saved
to a *.lut file and loaded later. Or, LUTs settings saved along with an image can be loaded directly from this image
by the Reuse LUTs from File command. Or you can copy/paste the settings within the documents opened in NIS-
Elements.

Modify Image Through LUTs Press this H*H button to apply the LUTs settings to the image data - the original image
will be overwritten. Until you press this button, no changes are made to the image data.

Reset Zoom Zooms the histogram to fit the preview window.

l—| Auto Range Zooms the histogram so that the “high” and “low” limits are distinguishable. For example, if a small
intensity range is defined on a 16bit image the low and high lines are displayed as one-pixel line. Pressing this
button will stretch the histogram in order to display the lines separately.

6.5.2.1 Auto Scale Settings

Press the arrow next to the Reset LUTs button and a pull-down menu appears. Invoke the Settings command.

Auto Scale Settings ﬁ

Low’ EH%
High[ 2]%]%

OK

l |
l Cancel l

Shared with Histogram under fover
exposed settings.

The Low and High fields determine how many of all pixels of the picture are left outside the sliders when Auto Scale
is applied (0-10%).
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6.5.2.2 AWB

White color in some images may suffer from having a color tint. The AWB (Auto White Balance) mode adjusts the
image to get pure white instead of this tint. Similarly to LUTs auto scale, the AWB function can be used once, or
permanently on the live image. If you know the tint your “white” color has, you can select this color by the color
picker that appears after pressing the ... button:

[]
&

l l Cancel l

Choose the color by mouse. You can also enter the RGB values to the fields below. A preview of the chosen color
appears in the rightmost rectangle.

6.5.3 LUTs on Monochromatic Images

All features mentioned above are also valid for monochromatic images, except that the AWB function is not available.
There are some other features added when in “mono” mode.

Gradient Mapping monochromatic images to pseudo-color gradients is often used to enhance details in the image
which would otherwise not be obvious. This button indicates the currently selected gradient. When pressed, a pull-
down menu appears where you can select the color scheme you would like to use. Try a few of the schemes to see
which one suits best.

99



- L -

Mano

Rainbow

Iran

Green Fire
Green Fire Blue
Red Fire

Red Hot
Magenta Hot
Brown

Lemon Hot
Yellow Pale

Rainbow Contrast

NENOARANANADN

Rainbow Dark

Manage Custom LUTs...

Manage Custom LUTs The Manage Custom LUTs command in the pull down menu enables to define a custom
LUTs gradient. Use the tools available in the dialog window to define your custom gradients. They then appear in
the pull down menu ready to be applied. Please see View > Image > LUTs > Create Custom LUTs for details about
the custom LUTs definition.
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6.5.4 LUTs on Multichannel Images

Figure 6.20. LUTs window on two-channel image

LUTs =
LZ N X ~|[a Fle@| -1 H M
i} G: 1,00 244

Hold Shift key to control all channels

Most of features mentioned above are also valid for multi-channel images. There are some other features added
when in “multi-channel” mode. Each channel is controlled separately by default. To control all channels at the same
time, press and hold the Shift|key while you drag the sliders or adjust Gamma.

When the image contains up to three channels, all channels can be visible at the same time and you can handle
them similarly to the RGB mode. When there are more than three channels, only one channel is displayed at a time.
A pull-down menu in the toolbar enables you to select the channel to be displayed.

O Next to the channel selection pull-down menu, there is this Auto Scale button. By pressing it, the system will
automatically adjust only the current channel settings.

6.6 Organizer

6.6.1 About Organizer

Apart from the main application layout used for capturing and image analysis, NIS-Elements provides an extra layout
called Organizer. Organizer makes the work with image files and databases as easy as possible. To activate it, run

the View > Organizer Layout szj command or click the D button located in the top right corner of the applic-
ation window. The screen opens divided into two identical panes. To switch from one pane to the other, use the
F6 | key. To copy files between the panes, simply drag the images from one side to the other side.
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Figure 6.21. Organizer layout
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* To navigate to a folder containing your image files, use the tree view on the left or enter a path into the first blue
edit box. The drop-down menu next to it (E) reveals a list of recently used folders.

|Generate All Thumbnails| calculates image thumbnails for all images present in the current folder.

* The next pull-down menu sets the file type. Only images with the selected type will be displayed or All Images
can be shown.

* If the Subfolders check box is selected, all images from the included sub-folders are displayed.

6.6.2 Image Filter

You can define a filter which enables you to display only images which fit the defined conditions. One or two conditions
may be applied.

° Y’ Pressing this button invokes the filter setup window.

* S This button activates the filter.

Basic Mode

This mode enables you to filter files according to one condition.

Advanced Mode

This mode enables you to define two conditions with a relationship between them. Either select OR to display files
matching at least one condition, or select AND to display files which match both conditions.
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["Fiter ‘ ‘ =)

Search in field: Description E] Search in field: [Size E]] [ Ok ]
Condition type: () Values  (®) Range
Values: [Comparison ] | << Basic | From: [SDD ]
Occurrence: (@) Anywhere AND OR e [ 1200 ] l
) Exact
) start

) allletter strings

) Any letter string
Hint
‘You can type more than one numeric value separated by comma. Specdified field containing at least one of these values will satisfy the
criteria. You can define also an interval with lower and upper bound.

1. Search in field - select the field where NIS-Elements should search for a given expression.

2. If the selected field is of a numerical type (e.g. Size, Calibration, File date, etc.) you can specify, whether you
want to find the exact value or a value in a given range. This is selected by the Condition type radio button.

3. If the field type is Text, the Occurrence setting determines the way of evaluating the expression:

* Anywhere - If the given sequence of characters is found anywhere in the field, the system will evaluate it as
a match. For example: you have entered “set” to the Values field. The filter will select records with the following
field values: “set”, “reset”, “settings”, “preset”, etc.

Exact - If the given sequence of characters exactly equals to the content of the field, it is evaluated as a match.
Fields containing the “set” value only will match.

Start - If the entered string is found at the beginning of a field, it passes the condition. For example: fields
containing “set”, “settings”, “setup” will match.

All letter strings - It is possible to search for more expressions. These should be entered separated by commas.
If you want to enter an expression with a space, insert it quoted. If this option is selected, only records where
all of those expressions appear (anywhere) will match.

Any letter string - This option is for entering multiple expressions as above, but this time every field with an
occurrence of at least one from the given expressions is matched.

6.6.3 Operations with Images within Organizer

* To open an image double click its thumbnail. NIS-Elements will close Organizer and display it in the main window.

* To select multiple images, either click on the first and the last image holding the Shift|key (continuous group
selection) or click individual images with the Ctrl | key down.

¢ You can copy one or more images from one folder to another by “drag and drop”.

* To delete selected images press the Delete | key.

All these operations and some other can be invoked also from the context menu, which appears after you right-
click on the image thumbnail:
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Open
[ copy
Cut
Select Al
Invert Selection

Delete. ..

Send to Recyde Bin...

Thumbnail Displaying Options

You can adjust the way images are shown in the organizer.

oo Show thumbnails Click this button to display image thumbnails and use the Tile Size slider to adjust their size.

o= Show image details This mode displays images below each other with all available information aside.

Show film strip Images are shown as a film strip below the currently selected image which is displayed big.

Metadata Displays a metadata summary list related to the selected image. This mode is disabled for the image
details view.

Sorting of Images

To order displayed images, right click anywhere in the pane - a context menu will appear. Move to the Sort by sub-
menu which offers several ordering criteria. If the ordering is turned ON already, the icon is displayed on the left
side of the applied criterion.

Enable Filter ||
Sort by b «  Ascending
Remove Filter and Sorting Descending
% Refresh Unsorted
ﬂl Filename
Properties...
Path
Size

Grouping of Images

To arrange the view of images efficiently, you can use the capability of grouping of images. Drag the column caption
to the grouping bar right above the table. All files with matching field values of the selected column will be grouped
together. This can be undone by dragging the column caption back to the others. See Figure 6.21, “Organizer layout”
(the Calibration column is grouped).

Note

If you have the Database module installed, the Organizer becomes switchable between two modes: the B
Files view and the [ Database view.
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6.6.4 Resizing the Organizer Panes
The pane size is adjustable. To resize it, you can either:

* 1. Place the mouse cursor over the dividing line in the middle.
2. The cursor becomes an arrow with two tips.

3. Drag it left or right to the new position.
* [0 Resizes the panes to achieve the same size for both of them.

« > Resizes the pane to its maximal/minimal size (one pane is then displayed on the whole screen).

To change the size of the whole organizer window and restore it down, click & Restore Organizer ( F10 |).

6.6.5 Reporting

Images together with their metadata can be exported into a report. Selecting image(s) and clicking on Report
opens the Create Report from File Listing dialog.

Exporting 15 records. ..

Columns: ~Template
[~]Filename - {®) Standard
Path
i Size Records per page:
|_|Filedate - Columns: [ 1 H Rows: [3 H
| Ciimensions 3 R R
| Calibration Font: Size:
| |Optics ;
[ IType T l.ﬁ.nal E]] [ 0 E]]
| |SampleID
| Author © Custom
[+|Description [ - l
|_|ImageID
L_|Group i ’ Browse... ] [Create NeEw... l
Canhurinn

Here you can select which columns will be transferred to the report and which template is used. Click |[Next >|to
generate the template and then adjust it according to your needs. For more information about reports, please see
9. Creating Reports.
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7. Image Analysis

7.1 Preparation

7.1.1 Histogram

A histogram is a graphical representation of pixel intensity distribution in the image. It is a basic tool which is used
during all phases of an experiment to assess the image information. It is especially useful to make sure there are

not too many over- or under-saturated (overrun) pixels. Run the View > Visualization Controls > Histogram m
command to display the histogram control panel:

Histogram x |
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7.1.1.1 Source Data

Source data of the histogram can be viewed if you swap to the Data tab in the bottom-left corner of the window.
The area from where the histogram is calculated can be restricted according to the selected histogram mode:

[] The data are obtained from the whole image.
D The data are obtained from within the probe.
© The data are obtained from within the current ROI.

m The data are obtained from the image parts under the binary layer.
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7.1.1.2 Export

E The source data or the histogram image can be exported to an external file. Display the Export pull-down menu

and select a suitable destination. Click the button to perform the export. The Export ND histogram button enables
to export histogram data of all frames of the current ND2 file. The same destination which is selected in the Export
pull-down menu is applied.

Note

Please, see the 8.1.7 Exporting Results chapter for further details.

7.1.1.3 Histogram Scaling

The histogram can be zoomed in and out using the zoom buttons on sides of the window. There are also other options
to adjust the graph appearance:

Left slider There is a slider along the Frequency axis. Drag it in order to stretch the view of either lower or upper
values of the axis.

I Auto Scale Vertical Zooms the graph of each channel separately to fit the available area. When this function
is ON, the histogram is not proportional.

|4—>| Auto Scale Horizontal Zooms the graph so that the marginal zero frequencies, if there are some, are excluded
from display.

iLin Graph Linear Displays the linear scale on the Y axis.
fLOg Graph Logarithmic Displays logarithmic scale on the Y axis.

ﬁ Show Grid Turns on/off the grid in the background.

7.1.1.4 Overrun Indication

If certain amount of pixels with maximum/minimum intensity values (black/white pixels) are spotted in the image,
color dots appears above the graph. The color indicates which channel is affected. When you place the mouse
cursor over the dots, a tool tip message appears with details about the percentage of under/overexposed pixels.
The percentage limit setting is loaded from the LUTs settings (the color dots do not appear unless the set percentage
of black/white pixels is exceeded).

Note

If the overrun concerns more than three channels (considering multi-channel images), only one white dot is
displayed instead of many color dots.

7.1.1.5 Graph Memorizing

You can save the current graph to memory and display it later for comparison with another graph.

MR Displays memorized graph.
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MS Memorizes the current graph. Only one graph can be memorized at a time. If any graph has already been
memorized before, it will be overwritten by the current graph.

MC Clears the memory.

7.1.1.6 Histogram Options
Drawing Style
There are two ways the histogram can be drawn:

* Raw Data - tries to draw the source data precisely to the graph

* Trend Style - interpolates the data so that the histogram lines appear smoother.

Histogram Options Window

The graph appearance can be modified. Press the |Options £+ button - a window appears where the following
settings can be adjusted:

Colors Graph background and axes colors can be selected.

Pen Width Set the width of the histogram(s) line to 1, 2, or 3 pixels.

Fill Graph Area The area below the histogram line can be filled with the channel color.

Graph Area Opacity Select the opacity of the Graph Area color in %.

Vertical/Horizontal AutoScale, Show Grid These options equals the corresponding buttons of the histogram toolbar.

Interpolation method Select the way of drawing the graph line. The Linear (smooth) and Quick (precise) options
are available.

Show grid Shows the grid of the graph.
AntiAlias Smooths the edges of the graph line.
Horizontal axis always visible If checked, the axis does not leave the graph area while zooming in the graph.

7.1.2 Image processing

7.1.2.1 Processing On: Intensity/RGB/Channels

If you work with RGB images, you can decide whether to perform the processing on single RGB channels of the
image, or on the intensity component. The RGB/Intensity setting is global so it is applied to all the other processing
commands automatically. When processing a multichannel image, this option is disabled - the operation is applied
to channels automatically.

Note

In case the command does not open a window where it would be possible to make the choice, the setting
from the last performed processing command (the global setting) is applied.
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7.2 Image Segmentation

7.2.1 Thresholding

(requires: MEAS (Automatic Measurement))

7.2.1.1 A Basic Way to Threshold an Image

Specifying correct threshold limits is a crucial procedure of the automated image analysis. The point is to determine
which pixels will and which will not be included in the binary layer and thereby distinguish objects to be analyzed

from background. Thresholding can be performed in the following modes:

1)

2)

3)
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Open or capture the image to be thresholded.

Run the View > Analysis Controls > Thresholding ﬂ command to display the Thresholding panel:

Figure 7.2. Thresholding panel
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In the top toolbar, select the color mode which will be used for thresholding. According to the type of image
opened, the following modes could be available: RGB, HSI, Intensity and MCH. See 7.2.1.2 Color Modes.
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4) Select one of the pixel-picking tools (e.g. -%— ) and start clicking on objects in the image you want to detect.

Color values of each of the clicked pixel(s) are used to adjust the low and the high threshold values so that
the clicked pixel would stay inside the thresholded interval.

Apart from this “clicking” method, the thresholds can be adjusted directly within the histogram by dragging
the vertical lines which highlight the thresholded interval.

5) All pixels having their numeric values inside the thresholded interval become a part of the resulting binary
layer.

6) Very often, also other binary objects appear in the image which you did not intend to detect, for example dust
particles with intensity similar to the specimen, etc. To eliminate these mis-detected object, use one or more
tools available at the bottom of the panel. You can either apply some morphology functions to the binary layer
or apply size or circularity restrictions to detected objects. See 7.2.1.3 Tips and Tricks.

7.2.1.2 Color Modes

RGB The RGB thresholding mode is available only if an RGB image is opened. There are two ways how to define
the threshold limits, by choosing reference points within the image, or by defining the limit values for each color
channel.

HSI The HSI thresholding mode is available only if an RGB image is opened. The thresholding procedure works the
same way as in the RGB mode except that the pixel values are displayed in the HSI (Hue, Saturation, Intensity)
color space and that the Saturation and Intensity channels can be switched OFF. Therefore you can threshold over
the H, HS, or HI channels only. Switch the channel off by deselecting the check box in the top-left corner of the
channel histogram.

Per channel In this mode, the channels are handled separately, a binary layer is created for each channel and also,
the binary processing functions (Smooth, ...) can be adjusted differently for each channel. Switch between the
channels by selecting their names in the bottom pull-down menu.

This mode is dedicated to perform threshold on multichannel images, but can be applied to RGB images as well.
It is not available when working with a monochromatic (single channel) image.

Intensity The thresholding procedure works the same way as in the RGB mode except that it is performed on the
intensity pixel values.

7.2.1.3 Tips and Tricks

Threshold Adjustments

Thresholding parameters can be adjusted very precisely in the following way:

* Threshold limits of each channel can be adjusted by rewriting the values in the top-left/top-right corner of each
channel histogram.

* Threshold range of each channel (the colored stripe) can be shifted by mouse. Place the cursor in the middle of
the range (a circle appears) and drag it left or right.

* Threshold limits of each channel can be adjusted by mouse. Place the cursor on the edge of the thresholding
range and drag it left or right.
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The two last behaviors can be further modified by pressing additional keys:

* Move the threshold using the right mouse button - the binary layer in the image is not updated continuously, but
is updated only once after the mouse button is released. Such operation saves some computing and therefore
is quicker.

* Hold Shift | while moving the threshold limits - the threshold adjustment is performed on all channels together
(RGB images only).

¢ Hold Ctrl|while moving the threshold limits - both the low and the high threshold limits move in opposite dir-
ections.

Binary Operations

Four basic operations can be performed on the binary layer before it is displayed on screen. To turn the operation
on, click on the up arrow button in order to define the number of its iterations:

Clean Removes small objects from binary image.
Smooth Smooths the binary image contours.
Fill Holes Fills holes within binary objects.

Separate Separates objects.
Restrictions

Size Define size range using min/max value in the edit boxes or using the slider.

Circularity Define circularity range using min/max value in the edit boxes or using the slider.

Thresholding Large Images

If thresholding images larger than 5000 x 5000 pixels, a new check box called Preview on selected area only is
displayed. This feature enables to display the threshold preview just on a limited area to speed up the thresholding
adjustment.

Changing Appearance of the Binary Layer

To change the color or transparency of the layer, right-click the E Overlay button in the right image toolbar. A
contextual menu appears, where you can select one of the predefined transparency levels, or run the Colorize
Binary Objects command. This command displays the binary objects in several different colors. The algorithm ensures
that two neighboring objects are never colored by similar colors.

See 7.3.4 Mathematical Morphology Basics.
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7.3 Binary Layers

7.3.1 Introduction to Binary Layers

7.3.1.1 How Do | Get a Binary Layer?

Commands for creating and editing binary layers are placed in the Binary menu. Basic methods of binary layer
creation are:

Thresholding This is the most common way of creating a binary layer for image analysis purposes. Use the View >

Analysis Controls > Thresholding ﬂ command to specify threshold limits, a binary layer will be created automat-
ically. See 7.2.1 Thresholding.

Drawing Manually in Binary Editor A binary layer can be edited or even created manually using the built-in binary
layer editor. To enter it, click Binary > Binary Editor. See 7.3.3 Binary Editor.

7.3.1.2 How Do | Display the Binary Layer?

There are the following buttons at the bottom of the right image toolbar.

m View Binary This button displays the binary layer only of the image.

E View Overlay Binary layers can be displayed together with the color layer using an overlay mode.

ﬂ View Color This button switches to view the color image (only).

To manage display of multiple binary layers, use the View > Analysis Controls > Binary Layers E control panel.

See 7.3.2 Managing Binary Layers.

7.3.2 Managing Binary Layers

7.3.2.1 Binary Layers Control Panel

Run the View > Analysis Controls > Binary Layers m command to display the following panel.
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Each time you create a new binary layer, it is automatically placed into the Working Layers area of the Layer List.
Working Layers may be overwritten by the application each time a new binary process is performed. Therefore once
you are satisfied with the layer content it is highly recommended to move it into the Stored Layers section using

the & Store Current Working Layers.

7.3.2.2 Operations with Binary Layers

Change color Color of a binary layer can be changed using the color pull down menu. It offers a list of predefined
colors. Besides the list of predefined colors it is possible to create a custom color (More...) or to colorize objects in
a single layer using multiple colors (By Object/By 3D Object).

Change order Use the arrow buttons ( ‘f + ) to change the order of the layers in the list.

Combine Layers using Binary Operations If you drag-drop a binary layer name over another binary layer name,
the Binary operations window appears. The same window can be displayed by the (&) Binary Operations Dialog
button.

Note

If multiple layers are selected in the layer list and drag-dropped over another layer, the Binary Operation dialog
calculates with multiple (more than two) layers. Available functions are dependent on the number of selected
layers.

See Binary > Binary Operations.
Create 3D Binary Objects To create 3D objects in the selected binary layer, click 9 Connect objects to 3D. If the
binary layers are not defined for all frames of the ND document having more than one frame (e.g. only the current

frame contains binary information), you can use Fill missing binary frames to copy the binary from the current
frame to all frames where the binary layer is missing.

Duplicate To duplicate one or more binary layers, select them by mouse and drag-drop them to the empty area
below the layer list, or click the F.i'. button.
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Note

If you drag and drop a binary layer to some already existing reference layer, content of the dragged layer is
copied to it.

Make Selection Binary layers can be selected by mouse (pick more layers holding Ctrl |or select a range holding
Shift|) or you can select all layers by clicking % Select All Layers.

Remove Select the binary layers to be removed and click the X button.

Rename Double click a layer name to rename it. Only name of the Reference Layers can not be edited.

7.3.2.3 Attaching Binary Layers to Channels

1) Ifabinary layeris created by thresholding in the |Per channel| mode, such binary layer is automatically attached
to the channel on which it has been created. Other binary layers can be attached to a channel manually:

1. Right-click a binary layer in the Binary Layers panel.

2. Select the Attach to Component sub-menu and select to which channel/component, the layer should be
attached.

2) Visibility of binary layers attached to channels can be synchronized with channels. Turn ON the Eﬂ* Synchronize
binaries with channels button. Now if a single channel is selected for display, only binary layers attached to it
are displayed and vice versa.

3) Tomake an attached binary layer global again, right click the binary layer name or thumbnail and select Detach
from Component.

7.3.3 Binary Editor

(requires: MEAS (Automatic Measurement))

The binary layer, as a result of thresholding, can be modified by hand using the binary layer editor. It is a built-in
application providing various drawing tools and morphology commands. Go for the Binary > Binary Editor command
or press Tab. New buttons appear on the toolbars:

7.3.3.1 Drawing tools

The binary image can be modified using various drawing tools. Although the way of use of some tools differs, there
are some general principles:

* Make sure you are in the right drawing mode (drawing background E /foreground E )
» Drawing of any object which has not been completed yet can be canceled by pressing Esc.

* The polygon-like shapes are drawn by clicks of the primary mouse button. The right button finishes the shape.
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* The automatic drawing tools (threshold, auto detect) have a changeable parameter. It can be modified by i|
and ;| keys or by mouse wheel.

* The scene can be magnified by the UP/DOWN arrows when mouse wheel serves another purposes.
* You can drag a magnified image by right mouse button.
¢ Aline width can be set in the top toolbar.

* Hints are displayed in the second top toolbar.

Binary Layer Color and Transparency
When in overlay mode:
* The Insert|key switches between predefined overlay colors.

* Ctrl + Up/Down|increases/decreases the binary layer transparency.

Erasing Single objects

Single binary objects can be erased in the following way:
* Run View > Analysis Controls > Binary Toolbar & .

* Select the Delete Object & tool from the toolbar.

* Click inside the objects to be erased.

Multiple Binary Layers

An arbitrary number of binary layers can be created within one image. Click this Create New Binary Layer button
in the image toolbar to add a new binary layer. The binary layer that you are currently editing can be selected in the

nearby pull-down menu. Binary layers can be managed from the View > Analysis Controls > Binary Layers E
control panel.

7.3.4 Mathematical Morphology Basics

(requires: MEAS (Automatic Measurement))

The binary image as a result of thresholding often needs to be modified before a measurement is performed. Edges
of the objects can be smoothed, holes in the objects filled, etc. by using the mathematical morphology commands.

Note

“Image Analysis and Mathematical Morphology” by J. Serra (Academic Press, London, 1982) was used as a
reference publication for the following overview.

The basic processes of mathematical morphology are: erosion, dilation, open, close and homotopic transformations.
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@ Erosion After performing erosion, the objects shrink. Marginal pixels of the objects are subtracted. If an object
or a narrow shape is thinner than the border to be subtracted, they disappear from the image.

@ Dilation After performing dilation, the objects enlarge. Pixels are added around the objects. If the distance
between two objects is shorter than twice the thickness of the border to be added, these objects will be merged.
If a hole is smaller than twice the thickness of the border, it disappears from the image.

Open Open is erosion followed by dilation so the size of the objects is not significantly affected. Contours are
smoothed, small objects are suppressed and gently connected, particles are disconnected.

Close Closing is a dilation followed by erosion so the size of objects is not significantly affected. Contours are
smoothed, small holes and small depressions are suppressed. Very close objects may be connected together.

Clean This transformation is also called geodesic opening. The image is eroded first so small objects disappear.
Then, the remaining eroded objects are reconstructed to their original size and shape. The advantage of this algorithm
is that small objects disappear but the rest of the image is not affected.

Fill Holes Fills the holes inside objects. This transformation is handy when objects have a rich inner structure
with intensities typical for background. After applying the Fill Holes transformation, objects become homogeneous.

[ contour This transformation converts objects into their contours.

~]

=] Smooth Smooth affects rough edges of the objects makes them smooth.

€| Morpho Separate Objects This transformation detects standalone objects that are connected together and
isolates them.

7.3.4.1 Homotopic Transformations

Homotopic transformations preserve topological relations between objects and holes inside them. Using a homo-
topic transformation, an object with 5 holes will be transformed to another object with 5 holes. Two objects without
any holes, even if they are very near each other, will become again two objects without holes, but likely with a dif-
ferent shape and size. Opening, Closing, Erosion and Dilation are not homotopic transformations. Typical homotopic
transformations in NIS-Elements are: Skeletonize, Homotopic Marking and Thickening.

7.3.4.2 Connectivity

Applying the above mentioned transformations has some limitations due to digital images rasterization.

When speaking about binary image processing, a binary image is a set of pixels where values 1 represent objects
and values O represent background. In the square grid of the image, two possible connectivities can be used for
processing - the 8-connectivity or the 4-connectivity. Look at the picture below. If the 8-connectivity is used, the two
pixels represent one object. If the 4-connectivity is applied, there are two objects in the picture. NIS-Elements works
with the 8-connectivity model, so all pixels neighboring by the corner belong to one object.
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7.3.4.3 Structuring Element = Kernel = Matrix

When applying Erosion, Dilation, Opening or Closing, one of the parameters which determines the transformation
result is the selection of kernel (structuring element, matrix) type. There are the following kernels used in NIS-Ele-
ments:

The bright pixel in the center or near the center of the kernel represents its “midpoint”.

Example 7.1. Erosion

Let's assume 1 and O represent object(1) and background(0) pixels of the binary layer. You can imagine the erosion
as the following algorithm:

Move the midpoint of the kernel to every point of the image. Each time, look at the neighboring pixels of the kernel
and make the following decision:

* If there are object(1) pixels in all the positions of the kernel, set the midpoint to object(1).
* If there is at least one background(0) pixel in the kernel, set the midpoint to background(O).
Example 7.2. Dilation

You can imagine the dilation as the following algorithm:

Move the midpoint of the kernel to every point of the image. Each time, look at the neighboring pixels of the kernel
and make the following decision:

* If there is at least one object(1) pixel in any position of the kernel, set the midpoint to object(1).

* If there are background(0) pixels in all the positions of the kernel, set the midpoint to background(0).

Example 7.3. Open and Close

Open is performed by eroding the image and then applying a dilation to the eroded image. On the contrary, Closing
is performed as a dilation followed by erosion.

Repetition issues

If the midpoint is not in the center, applying erosions or dilations by odd number of iterations causes image to shift
by 1 pixel. Normally, the total image shift would be determined by the number of Iterations (in pixels). NIS-Elements
eliminates this shift: it changes the position of the midpoint 1 pixel down-rightwards within the kernel for even op-
erations. For opening and closing it is possible to eliminate this shift totally. However, if you run the erode or dilate
processes again and again using the kernel with even dimensions and odd number of iterations, then the shift
becomes significant.

7.3.4.4 Mathematical Morphology Examples

Please see the following examples of some of the binary functions applied to an image. In the following sequence
of images, the functions were applied subsequently:
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Example 7.4. Functions applied subsequently
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Example 7.5. Single function applied to the original

The following images were created by calling each of the functions separately:

Original s Contou@ e Quench(5); UltimateErosion(15,2);
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7.4 Regions of Interest - ROIs

7.4.1 Introduction to ROIs

In laboratory imaging experiments, users are often interested in just a part of the image. To define such an interesting
part of the image we use one or more Regions of Interest (ROIs). These regions are used later in analysis and
measurements.

Note

Do not confuse image ROIs with Camera ROl which is used to reduce the active area to just a part of the
camera sensor (CCD or CMOS). Such reduction usually results in higher frame rate. See 5.2 Camera ROI.

7.4.1.1 Types of ROI

Individual ROIs (ROI objects) are 2D objects. They can have different shape: rectangular, elliptical polygonal or
Bezier. One shape can be created with one or more tools. For instance polygon ROI can be defined using both “Draw
Polygonal ROI” and “Autodetect ROI”.

In case of an ND file which has time axis (e.g. time-lapse) individual ROl objects can be defined as “Global ” or as
“Changing over time”. Global objects do not change any of their characteristics over time. Objects that are defined
as changing over time can change their position and shape in time (however objects cannot change their shape -
e.g. from ellipse to polygon). This feature is useful for track moving or warping objects.

In case of Multi Point ND2 file there is one more option: ROl can be defined per Multi Point (which is the default).
It means that ROIs from one point are completely independent of ROIs defined on the other point (even if they have
the same number). This applies also to ROIs defined as “Changing over Time” (in case the image has time axis too).
On the other hand if the ROl is changed to a “Global” it will be shared among all points of the Multi Point set.

Depending on the application purposes ROI objects can have different usage. NIS can handle “Background ROIs”,
“Reference ROIs”, “Stimulation ROIs” and “Standard ROIs”.

7.4.1.2 Interaction with ROIs

ROIs can be manipulated anytime directly in the image window. Many of the following techniques work in ROl editors
too. Objects cannot be moved or resized when they are Locked (some analysis tools or users may lock them to
prevent accidental modification). They must be unlocked (from the ROIs' context menu) before any manipulation.
Note that the mouse cursor changes over the ROI to indicate which action will be started after mouse button is
pressed (it changes when modification keys like Alt and Ctrl are pressed).

Selection ROI objects can be selected by clicking on an unselected object (other previously selected are unselected).
Clicking on a ROI object with Ctrl key pressed results in altering the selection state. More than one object can be
selected in this way. Double-clicking on any object results in only that object being selected. All objects can be se-
lected by pressing Ctrl+A or by choosing “Select All ROIs” from the menu over any ROI. Alternatively, it is also possible
to select a set of objects by dragging a rectangle around them with Ctrl key being pressed.

Moving Objects are moved by simply dragging them (cursor indicates that). When more objects are selected, only
the one below the cursor position is moved by default. This can be changed by pressing the Alt|key and move
all selected objects. When object is changing over time, any moving results in a new key-frame. Individual dots
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representing the key-frames can be moved too. It is possible to duplicate existing objects by Shift dragging. It works
on selected objects. In case of a key-framed object, object is duplicated with all its' key-frames unless Alt is pressed.

Resizing Resizing a ROl is done by dragging its' contour (the cursor changes accordingly). Note that the hot-zone
(the area where mouse cursor changes into different tool) for resizing is outside of the object contour while the hot-
zone for moving is inside. Resizing always affects only one object (selection is not taken into account). The behavior
slightly varies depending on the object shape. By default resize does not hold aspect of the object - width and height
can be changed independently. By holding Shift key aspect is maintained (useful for circles) and the center is not
moved. Rectangle can be also rotated by using Alt key while dragging.

Exact values can be entered in “ROI Properties” dialog which is accessible from the ROI context menu.

7.4.1.3 Simple ROI Editor

When creating more than one ROI, the Simple ROI editor is the tool of choice. With this tool it is possible to make
all possible shapes with different methods. All interaction techniques work here as well.

Figure 7.8. Simple ROI Editor toolbar

’6 B % ||ty pointing [Rectangle v () Grde ~ ) Polygon €3 Bezier @ AutoDetect + % AutoDetect Al v | DrawHoles | 3 Clear 7 tep | £ Finsh ‘

Note that many actions have a hot-key (P for Pointing tool, R for Rectangle, E for ellipse, L for Polygon, B for Bezier,
A for Auto detection, H for drawing holes and others) to speed up the process of interaction.

7.4.1.4 Auto-Detect Tool

Auto-detect tool is available from ROl menu, Simple ROI editor and some other places. It produces a Polygon ROI.
Using the tool is two step process: The first click on an image structure results in preliminary object contour, that
is drawn on the screen. After that, user can further tweak the object contour and then finish whole auto-detect by
confirming with right mouse button. User can always cancel auto-detect by pressing the Esc | key.

The veryfirst click is important, because these pixels under the cursor determine intensities from which the algorithm
guesses the whole object. As a general rule it is better to choose brightest pixels in the bright objects (fluorescence)
and dimmest in the dark object. It is also good to click near the center of the object.

After the click the algorithm presents its guess of the object contour and goes into the interactive phase. In this
phase it is possible to:

Redefine the first point by clicking again in the image
Cancel auto-detect by pressing Esc | key

Grow or shrink the object area (changes the intensity range of pixels making the object) by scrolling mouse wheel
or pressing PageUp/PageDown (for finer steps use Ctrl + mouse wheel)

Erode or Dilate morphologically the object by 'E'/'D' or Down/Up keys
Open or Close morphologically the object by '0'/'C' keys

Morpho-separate portions of the object by 'S' or 'P' key (if it is not possible to separate the key does nothing)
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7.4.1.5 Using ROlIs for analysis

ROIls are used mainly in Automated Measurement to measure ROIs features or number of binary objects inside
each ROI, Object Count to restrict binary objects to areas of interest only, ROI statistics to measure intensities inter-
actively. In all these cases ROl selection is taken into account as well as intersection options in Measurement Options.
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8. Measurement

8.1 Basic Workflows

8.1.1 Calibration

8.1.1.1 Introduction

Calibration of the image is of crucial importance to measurement. On calibrated images, realistic measurements
can be performed and objects of different images could be compared to each other. A correct calibration has to
be made before you begin to measure.

There are two ways how to obtain a calibrated image:

* To capture images with a calibrated system (objective). Please see the 4.1.5.3 Objective Calibration chapter
which explains how to calibrate the NIS-Elements system.

» To calibrate an uncalibrated image manually:

8.1.1.2 Calibrating an (Uncalibrated) Image

There are two ways to calibrate an image

Manually After you run the Calibration > Recalibrate Document command, you can specify a distance in the image
or set the current pixel size. Please see 4.1.5.4 Manual Calibration

Using Objective When you have an uncalibrated image, you can use an already calibrated objective to calibrate it.
Right-click the Uncalibrated field on the image status bar and choose one of the objectives from the Calibrate using
Objective sub-menu. Of course, the same objective which was used to capture the image shall be selected.

8.1.1.3 Units

NIS-Elements supports the following units: pixels, nanometers, micrometers, millimeters, centimeters, decimeters,
meters, kilometers, inches, mils

If the image is uncalibrated, pixels are the only units available. In case of a calibrated image, it is possible to select
other units which are then used to display all values (e.g. measured length/area). There are two ways of how to
select the desired units:

* Right click the image status bar where the calibration is displayed. Select the units and precision from the context
menu.

¢ Or, click the Current unit button located in the Calibration > Objectives command window and select the units.
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8.1.

2 Rough Measurement

Quick and approximate measurements can be performed using the graticule layer. They behave like adjustable
floating rulers. User can simply align a graticule with the measured object and read the distance value (e.g. the
diameter). To activate the graticule, press the Graticules button.

1)

2)

3)
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Select Graticule Type

The type of the graticule ruler is indicated by a picture on the Graticules button placed on the right image
toolbar. To change the graticule type, click on the graticules button with the right mouse button and select the
appropriate item from the context menu:

Rectangular Grid

Circle

Simple Circle

Cross

Industrial Cross

Simple Cross

Vertical Ruler

fret+ @S H

Horizontal Ruler

Define Graticule Properties

Right click the Graticules button and select the Graticules properties command from the pull-down menu. A
window appears where display parameters (shape, color, line width, density of lines) of all graticules can be
adjusted. Please see View > Layers Properties > Graticules Properties.

Graticules Density

The density value - the closest distance between two line intersections of the graticule - can be set, or you can
let NIS-Elements adjust it automatically according to the current zoom factor. The units selection depends on
the image calibration (calibrated/uncalibrated).

Note

Concerning the Cross ¥+ graticule. The distance defined by Density is divided into smaller sections
automatically. However, for odd density values greater than 10, the markings remain hidden because it
is not possible to display them accurately.

Measure the Image

The graticule measurement provides the following options in the graticule menu:

* A graticule can be moved around by clicking on it and dragging.

* A binary layer can be created from the current graticule using the Copy Graticules to Binary command.

* A Graticule Mask can be created from the current binary layer using the Copy / Add Binary to Graticule Mask
command.

* A Graticule Mask can be stored/loaded to/from an external file via the Save Graticule Mask As and Open
Graticule Mask commands.
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* Position of the graticule can be reset by the Move Graticules to Center command.

* If Graticule Mask is set as a graticule type, its transparency can be adjusted using the Mask Transparency.
In the Graticules properties, the opacity can be precisely set, mask can be rotated (Angle) and Calibration
changed.

* A new image containing graticules can be created by the Edit > Create Full View Snapshot (8bit RGB) com-
mand.

8.1.3 Object Count

(requires: MEAS (Automatic Measurement))

The Object Count tool is designed for automated object detection and counting. It enables users to threshold the
image, automatically measure the binary objects, and export the measured data to a file in a straightforward way.

Object count can be performed even on Live image. Run the View > Analysis Controls > Object Count 2: command
to display the control panel.

The recommended workflow through the dialog is to move from left to right, starting with thresholding, then using
restrictions and finally reviewing the result and export out of NIS-Elements to a text file or an MS Excel spreadsheet.

8.1.3.1 Thresholding the Image

~ Threshold RGB
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The threshold limits shall be defined by picking object-typical colors from the image. Select one of the following
tools:

-i- 1 point threshold tool
-0- 3 points circle threshold tool

-O- 6 points circle threshold tool
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Click inside the image to define typical object areas. The system will detect similar parts of the image and highlight
it by color. The threshold limits are indicated in the histogram and can be further modified by dragging the limit
lines by mouse.

Please, refer to the 7.2.1 Thresholding chapter for further details on thresholding.

8.1.3.2 Applying Restrictions

The number of objects that are included in the results table can be restricted by defining limits. Objects which do
not fit these limits will be left out of the result table.

~ Restrictions; EqDiameter (pm)

EqDiameter In 3,96 7,00
[ circularity 1In ] 1,00
| | |
E
S
E
T
i I.Il..lllll |||| .
Al ] [ Al
b,49 | omns| 2[5 9,08]

Right click to the restrictions field to select one or more of the available measurement features.

Select the restriction feature you would like to define.

Move sliders below the histogram to set the limits. The limit values are indicated next to the feature name, and
can be modified by double clicking the indicated value.

Decide whether the defined interval will be excluded or included - this is done by setting the Inside / Outside
option next to the feature name.

The nearby check box indicates whether the restriction is currently being applied or not. If applied, the histogram
below is color, otherwise it is gray.

Restrickions:  Circularity

Area In 5,00

Circularity D,B

Note

Infinitude can be defined by entering “00” or “inf”.

Reset The Reset button on the right side discards restriction settings of all features.
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Bins This setting determines the number of columns in the histogram.

Restrictions from the Image

A reference object can be picked from the image and used to set the limit values.

* Select the restriction feature you would like to set by mouse. Let's assume you have selected Circularity.
* Right click the thresholded object which is going to be used as source. A context menu appears.

* Select whether to INCLUDE or EXCLUDE the selected object and all others with higher/lower circularity.

* The restriction will be applied and indicated by colors within the image.

Restrict Circularity

IMCLUDE selecked objects and all with LOWER, Circularity

IMCLUDE selecked objects and all with HIGHER. Circularity

EXCLIUDE selected objects and all with LOWER Circularity
EXCLIUDE selected objects and all with HIGHER. Circularity

8.1.3.3 Results

The following results appear in the results table:

Total Area The area of the ROL. It is shown in square pixels or square calibration units.
Measured Area The area of the binaries inside the ROI.
Number of objects Number of objects after applying restrictions.

Table of results Measurement results for each object are displayed in this table. Select the columns to display/hide
from the context menu which appears when you right-click one of the column captions.

# Number of selected objects is displayed in the left part of the toolbar. One or more objects can be selected by
mouse while holding the Ctrl|orthe Shift|key.
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— Result
Total Area: 0,007 mm? 42
Measured Area: 23,57 %

0 X|®| E?.|| EE)qurtlv| M M [] use Standard EqDia mm ﬂ

ROIID | Binary 1D | % | Area | Perimeter | Circularity | Meanintensity | ~
Whole Image  Cell Count 3 (In... 1 0,00002 0,02 0,38 84,91
Whole Image  Threshold 1 0,00002 0,02 0,52 178,82
Whole Image  Cell Count 3 (In... 2 a 0,01 0,34 75,04
Whole Image  Cell Count 3 (In... 3 1} 0,010 0,89 90,45
Whole Image ~ Cell Count 3 (In... 4 0,00001 0,01 0,87 37,74
Whole Image  Threshold 5 1} 0,01 0,44 178,47
Whole Image  Threshold [ [i] 0,01 0,49 186,11
Whole Image  Threshold 7 i} 0,009 0,78 183,43
Whole Image | Threshold 3 a 0.02 0.38 118.03 ¥

Toolbar

There is a toolbar above the results table which contains the following buttons:

X Delete selected objects Removes the selected objects. The objects can be selected by mouse while holding

CtrlL

@ Invert selection Deselect objects selected by mouse and vice versa.
B Generate binary Erases binary objects which do not meet the restrictions settings.

Show Object Calatog Opens the Object Catalog control panel with data source automatically set to “Object
Count”.

Export The measured data can be exported to clipboard or a file using the Export button. Please refer to the 8.1.7
Exporting Results chapter for further details.

H- Save/Load Object Count configuration Invokes a pull-down menu which enables you to load/save the current
object count settings from/to an external file (*.counting).

Use Standard EqDia Check this option to enable counting of objects using standard EgDiameter. Value of the
standard EqDiameter parameter can be edited in the field nearby.

Note

Please be aware that the number of objects calculated by this function is only an approximation and not an
accurate count of objects.

Q’U Keep updating count Refreshes the measured results each time the binary layer changes (e.g. when the
threshold is modified).

8.1.3.4 Object Count Procedure Example
1. Open the Object Count control panel by the View > Analysis Controls > Object Count §§ command.

2. Threshold the image. Use the thresholding picking tools and click on the image to sample areas of interest.
These pixels selected will determine what intensity/ part of histogram is considered accepted. The threshold
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will detect several specs or smaller objects such as noise or background. If desired, the Clean and Smooth filters
will exclude smaller objects.

3. You can also measure using the defined region of interest (the © button) or measurement frame ( the L,
button). Check the options are properly set in the Measure > Options dialog window.

4. Apply restrictions. Select Area from the list of available restriction features. Use the sliders in the histogram to
specify the lower limit and the upper limit. The lower and upper limit will update in the display.

b o)
L) ﬁ-. ..

. ~ Restrictions: EqDiameter {mm) ———«

EqDiameter  In 0,004 0,007
[ Ccircularity In 0 1,00

i~
§
L
]
.

s
@
’ |||||I|||‘||‘|||| |

T el

—mMwma

The green area of the histogram represents the accepted range areas. Any object with an area in the green range
will be considered an object. Alternatively, any object with an area in the red ranges will not be considered an
object.

The outlines of objects on the image differ according to whether the object is restricted or accepted. In this case,
accepted objects have a green outline and restricted objects have a blue outline.

To ensure that that count is updating with any change, click the "{; icon:

- Remove any unwanted object from the object count by selecting the |De|ete Selected Objects\ X icon from the
Result section. The object will lose its thresholded overlay and will be excluded from the measurement.

Warning

You cannot Undo this action. To restore an object repeat the original threshold procedure or load a saved
Object Count configuration.

6. View the result data and export them to a file or spreadsheet application. See 8.1.7 Exporting Results for further
information.
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8.1.4 Measurement Options

Run the Edit > Options % command and select the Measurement tab.

Rules for Excluding Objects This section regards automatic measurement. Select the options how to treat the
objects touching the area borders when you are performing the automatic measurement:

When using measurement frame Pick up the option how to treat the object touching the measurement frame.
Run the automatic measurement by the Measure > Use Measurement Frame command.

When using ROI Pick up the option how to treat the object touching the ROI frame. Run the automatic meas-
urement by the View > Layers > Measurement ROl command.

Without Measurement Frame and ROI Pick up the option how to treat the object touching the image border.
Turn off the measurement frame and ROl and run the automatic measurement.

Note

Rules for excluding objects are valid for all features of objects measurements. For field, frame and ROI
measurement, these rules are taken into account only for the number of objects and do not affect the field
measurement results. Field measurement is always applied inside the defined area without exceptions.

Object Colors After the automatic measurement is performed, all measured objects are highlighted by color borders.
Here you can select colors for the objects excluded from measurement according to the ROl/measurement frame
settings. The Out of limits color will be used to highlight objects which do not fit the applied restrictions (View >

Analysis Controls > Automated Measurement §3 ).
Manual Measurement

Automatically zoom in Length manual measurements This option zooms in while placing the measurement
points into the image (click and hold the primary mouse button). Only the indicated measurement tools are
affected.

Copy manual measurement objects from live image to captured NIS-Elements enables to measure manually

on live camera signal ( View > Analysis Controls > Annotations and Measurements V ). After the Acquire >
Capture command is used, the measurement objects in the image are copied (or not) to the captured image
according to this setting.

Label The manual measurement objects can be labeled. Select what information will be attached to every
manual measurement object in an image.
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8.1.5 Measurement on Graph

Intensity Profile x
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The following interactive measurements can be performed within graphs.

l—| Vertical, I Horizontal Pick this tool to measure distances within the graph.

2\ Angle This tool enables selecting an angle and its both line lengths. The resulting number represents a ratio
between the projection of the y arrow on y axis and projection of the x arrow on x axis. The resulting number is a
dimensionless value. This tool does not allow adjusting the x line length.

<J Free Angle This tool measures the same features as the previous angle tool but allows to adjust all of the
angle's anchor points.

M Area of Graph This tool enables you to draw a rectangle in the graph. Area will be measured of intersection of
the rectangle with the area below the graph curve.

m’, FWHM This tool measures the Full Width at Half Maximum value on the given graph range.
1. Click to the graph to define the maximum, then the minimum.

2. Half of this interval defines the value in which the graph width will be measured.
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FWHM Definition
MNow you can redefine your intensity points.

Calculated FWHM:0,00

2951 Max 1026 Min
\\ ‘_f
Max Inll-;—'.'rs'it',-' v
A\ A rA A
L [\ [ [\
| I|I | h¥aY I| I|I || h¥aY
| \ | Y Red: Lgngth ' 0,0008 mm
| \ . | \
II \ | I'I I | I'I
|I '|I ) II|I |I '|I ) II|I
{ \ \ \
f V| \ f \ \
! ‘\__ ! A
/ /
/ /
__-‘-—--’F\} _.‘-—--’F\}
-~ Min Intensity  [—"
T T T T T T T T T T T T
00080 00100 fO060 00070 00080 00080 00100

Note
If the minimum is defined in a different part of graph (e.g.: different peak), the width is measured on the peak

where the maximum value was defined.
3 Clear Measurement Objects Deletes all the measured objects in the graph.

F)z(i Reset Data Clears the table with the measurement results.

8.1.6 Pixel Classifier

A typical task for Pixel Classifier may be counting the area of a cross-section of a blood vessel. Since there are at
least three different types of tissue whose area should be calculated while background should not be counted at

all.

1. Eliminate the background. You can:
* Define a region of interest. See 7.4.1 Introduction to ROIs for more information.

* Use the method of accepted region. Run the Edit > Region > Region Settings command first. Choose color of

the background in the Region Settings dialog that appears. You can fill in the value O, which is easy to threshold.
Next run the Edit > Region > Accepted Region command. Draw the boundary around the area to keep. Finish
drawing with a right click. The image is cropped according to the boundary. The area left outside the border

is deleted and filled with the set background color.
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Figure 8.9. Accepted Region Example

2. Run View > Analysis Controls > Pixel Classifier ﬂ to display the classifier panel. Press the Define button and

edit all phases you want to detect separately. Use the < and 3 buttons and commands in the contextual
menu to Add, Rename, Reset or Delete any class.

If you choose the Manual method of classifying, you can manually choose the intensity ranges of all phases.

Blocine | - - O X 0 | = | 0o
© s

O Bayes Channels (1) hd

Classes [, Test [“Ishow al + X
Phase Name Color B | AreaFraction[%] | Area[px
Background .- 0 0
Normal | 2 - -
Hyperplastic =] 100 30486
Lumen — 15 1] ]

[Uncalibrated

[Mono 8bit: 600 x 450 pixels

[0

Alternatively, you can sample areas and train the other algorithms to find phase boundaries.

3. Once all phases have been defined properly, the settings can be reused to classify another images.
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8.1.7 Exporting Results

Some image analysis data and measurement results can be transferred out of NIS-Elements so they could be used
further. There is a standard Export pull-down menu in some of the control panels (intensity profile, histogram,
measurement, etc...) which enables the export.

E Export F
@ Data to Excel
'ﬂ- Settings. ..

Data to Clipboard

Data to Web Browser
Data to HTML Clipboard
Data to Printer

B i i®

Data to Report

B[]

Create Report from Template 4

The set of commands of the menu differs according to the type of data (tables or graphs) which can be exported.
Click the arrow button to display the pull-down menu. When you select the destination, the pull down menu hides
and the icon of the selected export type appears on the Export button. The export action is performed after the
button is pressed once more.

8.1.7.1 Export Destinations

It is possible to export tabular data or a graph:

To Excel (requires: MS Excel) Tabular data can be exported to MS Excel. A new XLS sheet opens and the table is
copied to it automatically. There may be also the Export All To Excel option, which copies the data table, measurement
table, and the graph image into Excel at once.

To File Tabular data can be exported to an MS Excel sheet (xIs) or a text file (tab delimited txt).

To Raster File Graphs can be saved as a *.bmp image file. A save as dialog appears each time so you can name
the file properly.

To Clipboard Data tables and graphs can be exported (copied) to MS Windows clipboard. Then the data or the image
can be inserted into any appropriate application (text editor, spreadsheet processor, graphics editor) typically by
the Paste command.

To Web Browser, To HTML Clipboard Some tabular data can be exported as a HTML table. It can be displayed in
a default Internet browser (the Web Browser option), or the HTML code can be copied to Windows clipboard - ready
to be inserted to any HTML/text editor.

To Printer Tabular data can be printed directly. This option opens a standard Print dialog window where it is possible
to select a printer and print the data.

To Report Tabular data and graphs can be exported to NIS-Elements report. If a report is already opened for editing,
the data/graph will be appended to it. Otherwise, a new report will be created and the exported data inserted to it.

To Report Template The Create Report from Template option Inserts the result data into an existing report template.
Choose an existing report template from the list in the pull-down menu or click on |Browse for Template...| to open
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a report template file (.rtt) from your hard drive. The report opens and dynamic data are inserted automatically.
Then you can adjust the report, save it, print it, or export it to PDF using the menu commands.

8.1.7.2 Data Export Options

Run the Options command and switch to the Data export tab or press the Settings 'I:I- button within the export
pull-down menu. There are two tabs available:

Global Settings

Export into Microsoft Excel application Select this option if you want to export the data to MS Excel application.
You can choose if the data will be exported into currently opened file or a new file will be created. Or you can set
to export the data to a specific file. If this file does not exist, it will be created. Choose the path and name of the
file to be created/opened.

Set the Start at column values (column and row indexes). These values mark the first cell in the MS Excel application
which will hold the exported data.

Export text files into folder Select this item if you prefer to export the data to a text file. Press the ... button and
specify the target folder and the file name.

Data delimiter Pick up the type (tabulator, space, semicolon) of data delimiter which will be used when exporting
data to MS Excel or clipboard.

Append current data to previous exported data If you check this item the existing data will not be overwritten by
the new data.

Export also column headers if not appending Include the titles of columns in the files which are being created or
overwritten.

Activate target application after export If you check this item the exported file is opened in the default application
(MS Excel or the default text editor) automatically.

Insert empty lines Check this item to allow insertion of empty lines in the exported data.

Data export

You can modify the amount of data included in each export type.The control panels which contain the Export to file
functionality are listed in the top pull-down menu. Select the control panel of which the export shall be modified.

Export Name A control panel such as View > Analysis Controls > Annotations and Measurements {V stores in-
formation about the measurement in multiple tables according to the measurement type (area, length, etc.). In this
column, you can select the table you would like to modify.

Sheet name In this column you can define an arbitrary name which will be used to name a sheet or a txt file to
which the data will be exported.

Options for: This section of the window enables you to select the items to be included/excluded from the selected
table during export.
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8.2 Manual Measurement

8.2.1 Basic Workflow

Length, area, angles, taxonomy, counts, circle radius, and ellipse semiaxes can be measured manually over an
image. There are several tools for measuring each feature. The results are being recorded to a simple result table,
which can be exported to a file or clipboard. The data can be presented as a graph, too.

Example - Measurement of a Grain Thickness

1) Run the View > Analysis Controls > Annotations and Measurements 9/* command. The manual measurement
control panel appears.
Annotations and Measurements x |
Annotations
RIAL 2/ O0 > 2| =S
Length
SZHTADPHEHIINNS S < &
Area Angle
JEHOLOLOR| I =2 oAl
Radius Semiaxes Count & Taxonomy
Qoal g& e o]
Length - | @ ) | W | E Export - Dpﬁonsv|
A Source | Length | Comment |
1|DividingCell.nd2 79,35
2 |DividingCell.nd2 12,68
3 |DividingCell.nd2 10,19
Mean 34,07
St.dev 32,03
Min 10,19
Max 79,35
Sum 102,22
2)  select the Vertical parallel lines T tool.

3) Place the first line on the top edge of the crystal by clicking into the image. The position of the line can be ad-
justed while you hold the primary mouse button down. After you release it, the line is positioned.
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4) Repeat this to place the second line on the bottom edge of the crystal.

[

Length = 4,01 mm

l\_

5) When finished, an arrow is drawn between the lines, and the result of the measurement is attached. A record
with the measurement type and the measured value is added to the results table.

6) After finishing the measurement (e.g. of multiple grains or other images), select where to export results in the
Export pull-down menu.

7) Export the results using the Export button.

8.2.2 Working with the Measurement and Annotation Objects

There are two types of vector objects which can be placed over the image to a separate layer:

Annotations Vector objects used to emphasize or label interesting areas in the image, such as an arrow, a text
box, etc.

Measurement objects After a measurement object is placed to the image the measured value is appended to the
table of results. See 8.2.1 Basic Workflow.

Displaying the vector layer Use the A Show Annotations (A) icon on the right image tool bar to display all vector
objects in the layer.

Select or Clear Objects Objects of the annotation layer can be selected by mouse. Multiple selection is enabled

whenthe Ctrl|or Shift|keys are pressed at the same time. The selected objects can be deleted by the Del

key. Or, right-click the A Show Annotations (A)| button to display a context menu containing these commands:
Clear All Objects, Clear Annotation Objects, Clear Measurement Objects Deletes objects of the selected
type from the layer.

Select All Objects, Select Annotation Objects, Select Measurement Objects Selects objects of the selected
type in the layer.

Visibility of objects If an ND document contains a time dimension, you can set visibility of any annotation or
measurement object throughout the time. Use the secondary mouse click over the object and select Object Visibility....
The following dialog appears.
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Figure 8.14. Visibility Settings
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Use shift|and Ctrl|keysand primary mouse click to select frames over which the object will be visible. Once

you define the selection, click| E3 Finish|.

8.2.3 Measurement Tools

Run the View > Analysis Controls > Annotations and Measurements V command to display the following meas-
urement tools:

8.2.3.1 Angle

<I Measure Free Angle Angle between the two connected lines is measured. Click the primary mouse button and
drag to draw the first line and release the button. Then use the secondary mouse button click to confirm the first
line and repeat the procedure for the second line.

ﬂ Measure 2 Lines Angle between the two separated lines is measured. Click the primary mouse button and
drag to draw the first line and release the button. Then use the secondary mouse button click to confirm the first
line. Click the primary mouse button and drag to draw the second line. Confirm the object by the secondary mouse

click (only if Ej Confirm with R-Click is turned on).

=% Measure Via Reference Angle Angle between two lines (one is a reference line) is measured. First use the A

Define Reference Angle tool to define the reference line. Then select =% Measure Via Reference Angle, draw the
second line using the primary mouse button and confirm the object by the secondary mouse click.

A Define Reference Angle Draw a line in the image (using|Drawl|) and confirm it using the secondary mouse
button or enter a precise value in degrees into the edit box and click |OK|.

8.2.3.2 Area

& Polygon Polygon area is measured. Draw a polygon by clicking the primary mouse button inside the image. The
secondary mouse button or a double-click will place the last node of the polygon and close the object. Confirm the

object by the secondary mouse click (only if Ej Confirm with R-Click is turned on).

[] Rectangle Rectangle area is measured. Draw a rectangle holding down the primary mouse button. Confirm

the object by the secondary mouse click (only if 8 Confirm with R-Click is turned on).
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0 Ellipse Ellipse area is measured. Draw a circle holding down the primary mouse button. Click on the edge of
the circle and drag to form an ellipse. Confirm the object by the secondary mouse click (only if B Confirm with
R-Click is turned on).

0 5 Point Ellipse 5 point ellipse area is measured. Define five different points into the image using the primary
mouse button. The system automatically interpolates these points and finishes the ellipse. Confirm the object by

the secondary mouse click (only if Ej Confirm with R-Click is turned on).

0 4 Point Ellipse 4 point ellipse area is measured. Define four different points into the image using the primary
mouse button. The system automatically interpolates these points and finishes the ellipse. Confirm the object by
the secondary mouse click (only if B Confirm with R-Click is turned on).

& Auto Detect Area of the detected object is measured. The system automatically detects a homogeneous area

around the clicked point. Tolerance (size of the area) can be adjusted by rolling the mouse wheel or by using the
Page Up/Page Down |keys. Confirm the object by the secondary mouse click.

Select Binary Area of objects detected on the binary layer is measured. The system automatically detects a
homogeneous area on the binary layer around the clicked point.

8.2.3.3 Length

/ 2 Points Distance between two points is measured. Use the primary mouse button to define the starting and

ending point. Confirm the object by the secondary mouse click (only if B Confirm with R-Click is turned on).

/ Simple Line Line length is measured. Click and hold the primary mouse button over the starting position and
drag to the ending position and release the button. Confirm the object by the secondary mouse click (only if Ej
Confirm with R-Click is turned on).

|- Horizontal, I Vertical Horizontal/vertical distance between two lines is measured. Click the primary mouse
button over the starting point and move to the ending point and click again. Confirm the object by the secondary

mouse click (only if (8§ Confirm with R-Click is turned on).

Note

You can modify default length of the measurement lines. Click the measurement line and resize it by mouse.
The new length will be remembered and used for the next measurement.

Figure 8.15. Resizing of the measurement line

D 3
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Alternatively, you can hold the mouse button when placing the first measurement line and draw the line long
as you like. The default length will not be affected by this action.

"y Parallel Lines Distance between two parallel lines is measured. Click the primary mouse button over the first
point of the line, move to the second point of the line, adjust the position of both points and confirm it using the
secondary mouse click. Then move to the position of the second line and click the primary mouse button, adjust
its position and confirm the whole measurement by clicking the secondary mouse button.

> Polyline Polyline length is measured. A polyline consists of several line segments. Use the primary mouse button
to draw the line segments. Each mouse-click creates a new node. Complete the total length definition by the clicking
the secondary mouse button. Confirm the object again by the secondary mouse click if Eﬂ Confirm with R-Click
is turned on.

.'ISI.' Crosses Distance between two crosses is measured. Click the primary mouse button to define two points
between which the distance is measured. Confirm the object by the secondary mouse click (only if Ej Confirm
with R-Click is turned on).

'H' Auto Default Distance between two points estimated by the computer is measured. Click and hold the primary
mouse button, drag and release the button to draw the line. The system automatically detects the sharpest changes
of the pixel intensities and adjusts the point position. Confirm the object by the secondary mouse click (only if Eﬂ
Confirm with R-Click is turned on).

;I_F Auto Outer Distance between two points estimated by the computer is measured. Click and hold the primary
mouse button, drag and release the button to draw the line. The system detects several sharp changes of the pixel
intensities and selects the first and the last one as the measurement points. Confirm the object by the secondary

mouse click (only if Ej Confirm with R-Click is turned on).

'H' Auto Inner Distance between two points estimated by the computer is measured. Click and hold the primary
mouse button, drag and release the button to draw the line. The system detects several sharp changes of pixel in-
tensities and selects the second and the next to the last one as the measurement points. Confirm the object by

the secondary mouse click (only if B Confirm with R-Click is turned on).

@ 2 points on XY stage Measures the distance between two points on a live image which do not fit the camera
FOV. Click the primary mouse button to mark the first point, move the stage to the second point on the sample and
click in the image to mark the second point.

8.2.3.4 3D

E; Length 3D (requires: EDF Module (Extended Depth of Focus))

This tool enables to perform interactive 3D measurement on ND2 files which include the Z dimension.

Measurement on Slices View

1. Open an ND2 file containing a Z dimension.
2. Run the View > Image > ND View > Slices View Bl command to display the image in Slices View.

3 Select the A Length 3D tool. The cursor changes.
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4. Select a Z plane (use the mouse wheel) on which the first point lies. Click the primary mouse button to mark
that point (crosshair is shown). Confirm its position by the secondary mouse click. The color of the crosshair
changes.

5. Select a Z plane on which the second point of your measured line lies. Place the second crosshair as in the
previous step and confirm it using the secondary mouse click.

6. Measured value is written into the results table of the View > Analysis Controls > Annotations and Measurements
A7 window.

Measurement on a Focused Image, Surface View or Volume View

1 Open an ND2 file containing a Z dimension and run the Applications > EDF > Create Focused Image W command.

2- You may switch to Show EDF 3D Surface View, IQ Volume View or stay inthe W Show EDF Focused Image

view which appears automatically. The 3D Measurement behaves the same way in all of the views.

" Invoke the E} Length 3D measurement.

4. Define both points of the measured line by the primary mouse click. Measurement is performed automatically
and the length is displayed over the line and in the results table of the View > Analysis Controls > Annotations
and Measurements &* window.

8.2.3.5 Radius

C’) Circle Radius of the circle is measured. Click and hold the primary mouse button and drag to create a circle
and release the button. Adjust the circle size and position and confirm the object by the secondary mouse click

(only if B Confirm with R-Click is turned on).

() 3 Pts. Circle Radius of the circle is measured. Define three different points into the image using the primary
mouse button. Adjust the circle size and position and confirm the object by the secondary mouse click (only if Ej
Confirm with R-Click is turned on).

@ N Pts. Circle Radius of the circle is measured. Define as many points as you like into the image using the
primary mouse button and confirm the object by the secondary mouse click. The circle is created by interpolating
the defined points. Adjust the circle size and position if needed.

8.2.3.6 Semiaxes

0 Ellipse Ellipse semiaxes are measured. Click and hold the primary mouse button and drag to create a circle
and release the button. Click on the edge of the circle and drag to form an ellipse. Adjust the ellipse size and position

if needed and confirm the object by the secondary mouse click (only if Ej Confirm with R-Click is turned on).
@ 5 Pts. Ellipse 5 point ellipse semiaxes are measured. Define five different points into the image using the
primary mouse button. The system automatically interpolates these points and finishes the ellipse. Adjust the ellipse

size and position if needed and confirm the object by the secondary mouse click (only if Ej Confirm with R-Click
is turned on).
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& Free Rectangle Rectangle semiaxes are measured. Click and hold the primary mouse button and drag to create
a rectangle. Adjust its size, position or rotation (using the green anchor point) and confirm the object by the secondary

mouse click (only if B Confirm with R-Click is turned on).

8.2.3.7 Count and Taxonomy

Count Click inside the image to insert counted points. The current count is shown next to each point and its
position and number is recorded. Finish counting by the secondary mouse click.

Taxonomy This tool enables to manually count objects of up to 70 classes.

1 Click the 3 icon.
2. Use the secondary mouse click over the results table and select Taxonomy Options.

3. In the Taxonomy Options window, define the number of classes (from 2 to 70) and the way of inserting markers:

On left button down Inserts a marker to the current cursor position after a mouse click. If this option is
selected, the function keys enable to switch between the classes. In this mode, the Fn | keys works for
switching between classes.

On Fn key at cursor position After the Fn|key is pressed, the count is performed and the corresponding
marker is placed to the current cursor position.

On Fn key at screen center After the Fn | key is pressed, the count is performed and the corresponding
marker is placed to the center of the image view.

On Fn key at cursor position, no marker inserted After the Fn | key is pressed, the count is performed
and no marker is placed.

4. Start the count according to the Taxonomy Options setting.

Note

The keyboard Fn (function) keys F1 - F10 can be used as a shortcut for classification/class selection. Since
there are 70 classes available, certain key combinations must be pressed in order to select/classify the

right class:

Key Combination Class Number
Fn n

Ctrl + Fn 10 +n

Alt + Fn 20+n

Shift + Fn 30+n

Ctrl + Alt + Fn 40 +n

Ctrl + Shift + Fn 50 +n

Shift + Alt + Fn 60 +n

5. Perform the measurement until all classes are counted.

8.3 Automated Measurement

(requires: MEAS (Automatic Measurement))
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Automated measurement is the most powerful of image analysis features. In combination with user macros, NIS-
Elements can become a semi- or fully-automatic image analysis tool. There are several key procedures which a
proper automated measurement should involve:

1. Optical system calibration (see the 4.1.4 Optical Configurations chapter)

2. Image acquisition (see the 5. Image Acquisition chapter)

3. Defining threshold, creating the binary layer (see the 7.2.1 Thresholding chapter)
4. Performing the automated measurement

5. Results presentation

Image Layers Involved in Measurement

The binary layer and also the color image can get involved in the automated measurement:

¢ Binary layer - is typically used for shape and size measurements (area, perimeter, etc).

¢ Color layer - intensity or hue measurements are carried out on this layer. The area covered with the binary layer
is used as the source data.

Object/Field Measurement

NIS-Elements distinguishes two types of automated measurements: object and field.

Object Measurement Groups of neighboring pixels of the binary layer are called objects. Results of the object
measurement are usually the object data such as Length, Area, CentreX/Y (the X,Y position of the central pixel of
an object), etc.

Field Measurement Field measurements produce information regarding the whole measurement area (measurement
frame, ROI). Such information can be Area Fraction, Mean Brightness, Density Variation, etc.

Please see the complete list of measurement features in the 8.4 Measurement Features chapter.

Restricting the Area of Measurement

The area of measurement can be restricted by the measurement frame or by a user defined region of interest (ROI).

Region of Interest - ROI ROl is a user defined area of the image. Whenever the ROl is displayed (by the View >
Layers > Measurement ROl command), it is also applied to restrict the area of measurement.

Measurement Frame The measurement frame is a re-sizable rectangular frame which serves for bounding the
area accepted for measurement. Turn the measurement frame ON via the Measure > Use Measurement Frame
command.

Binary objects touching edges of ROl or the measurement frame can be treated differently (excluded from the
measurement or included). This behavior can be specified within the Measure > Options window.

Statistics and Data Presentation

NIS-Elements calculates basic statistics - mean value, standard deviation and distribution of all measured features.
The features to be measured can be selected in the Measure > Object Features and the Measure > Field and RO
Features windows. Results of all automated measurements are presented and can be exported from the View >

Analysis Controls > Automated Measurement Results o% control panel.
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8.4 Measurement Features

(requires: MEAS (Automatic Measurement))

The following list contains all features which can be measured within NIS-Elements Measurements. There are the
following. Different measurement tools measure different features. If not stated otherwise, all distances and areas
are measured in the current (image) calibration units. If the image is not calibrated, pixels are used instead.
EXX] Features available in manual measurement.

EXE] Object features - measured under binary objects (layers).

EX Field features - measured over the whole image area.

T30 ROl features - measured within ROIs.

Eﬂi EDF features - can be measured only after EDF focused Image was created.

AcqTime ELE], [T, ET]

Acquisition time of the current image in seconds. If the image is a part of an image sequence, the time is measured
from the beginning of the sequence. Otherwise it is the time elapsed since the software was started.

Angle [IIX]]

Angle between two user-defined lines. See 8.2.3 Measurement Tools.

Area [LH], [IX]

Area is a basic quantity for measuring object size.

Figure 8.16. Area

Axis A, Axis B, Axis A/B [[IX]]

Lengths of the major (A) and minor (B) axes of an ellipse and their ratio. See 8.2.3 Measurement Tools.

BinaryArea [T

Sum of areas (Area) of all binary objects.

BinaryAreaFraction [T

BinaryArea

BinaryAreaFraction =
MeasuredArea
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See BinaryArea and MeasuredArea.

Blue [IIXI

Arithmetic mean of pixel intensities of the blue component within the measured area. See 8.2.3 Measurement
Tools. It equals O on other than RGB images.

BoundsAbsLeft, BoundsAbsRight, BoundsAbsTop, BoundsAbsBottom [ELE]

These are absolute distances (X/Y coordinates) of the left, right, top, and bottom edges of the object bounding
rectangle within a motorized stage range. This feature can be measured only if a motorized stage is connected.

Figure 8.18. BoundsAbs

Stage range

a3

BoundsLeft, BoundsRight, BoundsTop, BoundsBottom [EL:E]

These are distances (X/Y coordinates) of the left, right, top, and bottom edges of the object bounding rectangle.

Figure 8.19. Bounds

@ Mage

- Bottom

BoundsPxLeft, BoundsPxRight, BoundsPxTop, BoundsPxBottom Em

These are distances (X/Y coordinates) of the left, right, top, and bottom edges of the object bounding rectangle
measured in pixels.

BrightVariation Em m EI'.I

It is the standard deviation of brightness values within the object.

CentreX, CentreY ELE], U0, ET), LN

Coordinates of the center of gravity of the object (ROI, field).

CentreXabs, CentreYabs [IF], [T31, I

Absolute coordinates of the center of gravity in the scope of the stage XY range. These features can be measured
only when a motorized stage is connected. See also BoundsAbsLeft.

CentreXpx, CentreYpx X, [EH, T

145



Coordinates of the center of gravity measured in pixels.

ELLL OB) P ROLIY FLD FRIMAN]

Comma-separated list of channel names on which the measurement was performed.

cCircularity [EEE]

Circularity of a circle equals 1. All other shapes are characterized by circularity smaller than 1. It is a derived shape
measure, calculated from Area and Perimeter. It is useful for examining shape characteristics.

., , 4 x 1 x Area
Circularity = ——————-
Perimeter

comment ELEl, [N, G, [ZXI

This feature adds an editable column to the results table.

Convexity Em

Indicates convexity of the object edges.

Area

Convexity =
’ Convexr Hull Area

Convex Hull Area is the area of objects after running the Binary > Convex Hull command.

DensityVariation Em Em EII

It is the usual standard deviation of the density values.

Diameter [0

Diameter of a circle measured manually. See 8.2.3 Measurement Tools.

EdfRoughness GLE], [T01, M4 G [CXX]

Based on the 3D EDF surface model, it indicates how much the surface is rough. Its value for a flat surface is 1.

Edf Sur face

Area

Edf Roughness =

See also EdfSurface and Area.

EdfRoughnessRA LR, [T01, EE . 0. (X

Based on the 3D EDF surface model, it indicates how much the surface is rough. It is a sum of absolute values of
differences between Z value of each pixel and mean of all Z values divided by Area. Its value for a flat surface is O.
It is the most widely used one-dimensional roughness parameter
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1
2df RoughnessRA = =Y |Z; — EZ
Edf RoughnessR/ - |Z; — EZ|

=9’

1
Area = Q| =n EZ =~ >z

e

EZ The mean height of the Z-map (mean of all Z coordinates of the EDFSurface).

n, Area, Q Number of pixels in the measured area (image/object/ROI).

Z; EDFSurface Z coordinate of a particular pixel.

Edfsurface LR, (01, 04 X [IX0

Based on the 3D surface model, it is an approximation of the surface area. For a flat surface, EdfSurface = Area.

Figure 8.24. EdfSurface highlighted red, Area of four Edf surfaces highlighted yellow
zh

Az, y, z1)
B(x+1,y,22)
Clz+1,y+1,23)
D(z,y+1, z4)

a = |AB]|
b= |BC|
c=|CD|
d = |DA
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Edf Sur face = 5 5

Edf Sur face > Area

Elongation [EIX]
Characterizes the object shape. Ratio of MaxFeret and MinFeret features.
, MaxFeret
Elongation = ———
MinFeret

EqDiameter [IE], [IEX

A size feature derived from the area. It determines the diameter of a circle with the same area as the measured
object:

4 % Area
FEqDiametersp = | ————

m

Figure 8.31. EqDiameter

Zi

LI 0B [ FLD IIROT)

Automatically generated field ID. Each measurement per field generates a new ID.

FillArea CLE]

If an object contains holes, FillArea remains the same while Area is reduced by the area of the holes. If an object
does not contain holes, then FillArea = Area.
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Measurement

Figure 8.32. FillArea

FillRatio ELE]

FillRatio is the ratio of Area and FillArea:

Area
FillRatio = —
T = FillArea

If an object does not contain holes, FillRatio = 1. If an object contains holes, FillRatio is less than 1. This feature
helps distinguish objects with and without holes.

Green m

Arithmetic mean of pixel intensities of the Green component within the measured area. See 8.2.3 Measurement
Tools. It equals O on non-RGB images.

Height LY

Projection of 3D length measurement to the Z axis. See 8.2.3 Measurement Tools.

HueTypical GEE], [T00, ET

HueTypical (H) is the hue value with maximum frequency in the hue-values histogram. This feature describes the
most frequent hue (color) in an object or field.

a=-(2R-G - B)

b | =

(G - B)

i
1S

H = atan2(3, a)

HueVariation Em Em m

HueVariation is the usual standard deviation of hue values. This feature describes hue (color) distribution of inner
structure of an object or a field.
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1
— —(2R-G —

o 2(.7? G - B)

;‘i:\f—g({?—.’})

b

H = atan2(3, a)

Intensityvariation LR, [T, I

IntensityVariation is derived from the intensity histogram. It is an usual standard deviation of intensity values. This
feature describes the inner structure of an object or a field.

Length CLE, [ZXI

Length is a derived feature appropriate for elongated or thin structures. Since it is based on the rod model, it is
useful for calculating length of medial axis of thin rods.

Perimeter + /(Perimeter? — 16 x Area)
4

Length =

Figure 8.37. Length

Width

Length

Length xyz, Length xy LN
3D length measured manually. Length xyz is the actual length measured on Slices View or Volume View. Length xy
is length of a projection of the measured line to the XY plane. See 8.2.3 Measurement Tools.

LineLength [ELE]

It is the length of an object with elongated shape.

MaxFeret, MaxFeret90 [IE], LN

It is the maximal value of the set of Feret's diameters. Generally (for convex objects), Feret's diameter at angle o
equals the projected length of the object at angle o, a (0,180); NIS-Elements calculates Feret's diameters for o
=0, 10, 20, 30, ..., 180.

The MaxFeret9O0 is a length projected across the MaxFeret diameter.
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Figure 8.38. MaxFeret

MaxFeret90

MaxFeret

MaxIntensity Em Em m E!EI

It is derived from the intensity histogram as the maximal of all pixel intensity values (I).

Figure 8.39. Intensity

I=%(R+G+BJ

Mean*ChannelName*, MeanRed, MeanGreen, MeanBlue L], LI, ]

Arithmetic mean of pixel intensities of one image component. See also Meanintensity.

MeanBrightness Eﬂ m m E!E'I

Arithmetic mean of brightness values of pixels.

Meanchord ELE, (T3, T

The mean value of secants in the 0, 45, 90 and 135 degrees directions. It is a derived feature and is calculated
from the Area and mean projection according to the following formula.

4 x Area

MeanChord =
(Pro + Prys + Proo + Prigs)

MeanDensity [ELE], [T, [ZN], EE3

Arithmetic mean of density (0.D.) values of pixels.

PixellntensityValue

0.D. = —1
o MaxIntensityV alue

Meanintensity CIEE], CTH, [0, GG

It is derived p from the intensity histogram as the arithmetic mean of pixel intensities (1).
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Figure 8.42. Intensity

I:%(R+G+B)

I=\frac{1H{3}(R+G+B)

MeanRatio, MeanCa2+, MeanCorrFRET, MeanFRETEff, MeanTitration B[R], [T, T

Arithmetic mean of intensities of the Ratio, Ca2+, FRET / Corr FRET / FRET Eff / Ph channels. This feature is activated
upon creation of the channel view.

MeanSaturation Eﬂ m m

Arithmetic mean of saturation values of pixels (S).

Figure 8.43. Saturation

v 0, if C' =0
SHsI = { |_m

Z, otherwise

M = mazx(R,G.B)
m =min(R,G, B)
C=M-—m

MeasuredArea [I3], [T01, T

The area of the measurement frame or a ROl within the measurement frame (if the ROl is on).

MinDistanceTo [ELE]

MinFeret B2, EIX

The minimal value of the set of Feret's diameters. Generally (for convex objects), Feret's diameter at angle o equals
the projected length of object at angle o, a (0,180); NIS-Elements calculates Feret's diameter for o« =0,10,20, 30,

..., 180.

Figure 8.45. MinFeret

-
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Minintensity BI3], [T, [N, G

Its value is derived from the intensity histogram. It is the minimum of intensity values of pixels.

Figure 8.46. Calculation of Intensity (1)

I=%(R+G’+BJ

CDRUN FLD I ROTIMAN|

Frame index within the Multipoint dimension.

LLAS FLD P ROT PR MAN]

Frame index within the time dimension.

NearestObjDist [ELE]

The smallest distance to another object (measured between centers of gravity).

Note

If ROIs are used during the measurement, NearestObjDist is calculated only between the objects within the
specific ROI (objects having the same ROI ID).

NumberObjects m , IIE]

The number of objects inside the measured area. Exclusion rules for counting objects are taken into account (see
8.1.4 Measurement Options).

NumberObjectsRestricted [T

Number of objects left after applying restrictions.

See also View > Analysis Controls > Restrictions ) .

Numbers [

Number of points clicked within one Count measurement. See 8.2.3.7 Count and Taxonomy.

obj ip [ELE

Binary object ID. Each binary object has a unique ID

ObjectAreaFraction L1

Ratio of BinaryArea and ROIArea.
BinaryArea

Object AreaFraction =
Djec real Taction ROIArea

Objects Area m
Area of all binary objects placed within ROIArea.

Orientation EEH
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The angle at which Feret's diameters have their maximum. The diameters are calculated with 5 degrees angle in-
crement.

Figure 8.47. Orientation

l’ \ﬁ__'_,_...-..}
\
\ -
I ,/
4 -
(‘ - Ferat (max)

Orientation

OuterPerimeter Em

Length of the outer perimeter (unlike in Perimeter, holes inside the object do not count).

ST 08) P ROTIIMANY FLD

Perimeter is the total boundary length. It includes both the outer and inner boundaries (if there are holes inside an
object). The perimeter is calculated from four projections in the directions 0, 45, 90 and 135 degrees using Crofton's
formula

m x (Prg 4+ Prys + Prop + Priss)
4

Perimeter =

Figure 8.48. Perimeter

-

|
('~ __7 !

PerimeterContour [ELE]

Total boundary length computed from object contours. Compared to Perimeter, it is more accurate (especially on
elongated objects) but slower to get the result.

Radius [ZIX]

Radius of a circle measured manually. See 8.2.3 Measurement Tools.

Red [N

Arithmetic mean of pixel intensities of the Red component within the measured area. See 8.2.3 Measurement
Tools. It equals O on non-RGB images.

Roi ID 3], T3]

ROI ID. Each ROI has a unique ID.

ROIArea [T
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Area of each ROI.

Roughness ELE, [IX]

This feature indicates how much the object is rough. “1” means the object roughness is minimal (it is circular).
Roughness values range is <0;1>.

Convex hull perimeter

Roughness =
: Perimeter

Roughnessinf [EE]

This feature indicates how much the object is rough. “1” means the object roughness is minimal (the object is cir-
cular). Roughnessinf values range is <1;inf>.

1

Roughnessinf = ——
Roughness

ShapeFactor [IF] , [[IX]

This feature is to define whether the object is rough or not.

4 xmx Area

ShapeFactor = — - 5
Convex hull perimeter

Figure 8.52. ShapeFactor

SLULLY 08) Y FLD B ROTRRMAN

Name of the measured image file.

StartX, StartY [LIE]

When you scan the image from the origin in left-to-right direction, the first pixel of the object you hit is the one with
StartX and StartY coordinates.
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Figure 8.53. StartX, StartY

v

StartXpx, StartYpx [IE]

StartX and StartY coordinates measured in pixels (see StartX).

StgPosX, StgPosY [, [T

Coordinates of the absolute position of the measured field. It is available only for systems equipped with a motorized
XY stage.

Figure 8.54. StgPos

— 1 Field of view N
|
Me;t.area
Stage range
.
Sum*ChannelName* [IE], [T0, T
The sum of intensity of all pixels of the object, ROI or field.

SumBrightness [, [T, EE

A sum of brightness in every pixel of the object.

sumbensity CLE], [T, CIX], GE3

A sum of individual optical densities (0.D.) of each pixel in the measured area. This feature describes, for instance,
the amount of a substance in biological sections. Optical density is evaluated according to the following formula:

t
b

PixellntensityV alue

0.D. = —1
9 MaxIntensityValue

Sumlintensity EEEI IZEEI E!II IE!IJ

Sum of intensity in every pixel/voxel of the object.

SurfVolumeRatio [11 , I
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SurfVolumeRatio is a feature with a strong stereological interpretation: if you measure on fields that are sampled
systematically and independently of the content of the sections, then the feature is an unbiased estimator of the
surface area of objects (inner structure) per volume of the whole sample.

1 5 Perimeter

Sur fVolumeRatio = =&
MeasuredArea
See also Perimeter and MeasuredArea.
Time [N
Time interval measured on a 1DT document. See also Velocity.
Velocity [[IX]]

Speed measured between two points defined manually. This feature can be measured on a 1DT image using length
measurement tools. 1DT image can be created from a timalapse ND file.

1. Open a timelapse ND2 file and run View > Image > ND View > Slices View i .
2. Right-click one of the side views and select Create New Document from this View. A new image will be created.
3. Perform length measurement on the new image.

VolumeEqCylinder Em

This parameter is based on the rod model. Length is interpreted as height and Width is interpreted as the base
diameter of a cylinder.

VolumeEqCylinder = (m x d°)( ) n X d
4 6
| = max(MaxFeret, Length)

d = min(MinFeret, Width)

Figure 8.58. VolumeEqCylinder

VolumeEqgSphere [ELE]

Volume of a sphere whose diameter is equal to EqDiameter of the measured 2D object.
7 x EqDiameter?

6

VolumeFEqSphere =
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Figure 8.59. VolumeEqSphere

width 3]

Width is a derived feature appropriate for elongated or thin structures. It is based on the rod model and is calculated
according to the following formula:

Area

Width = ————
v Length

Figure 8.61. Width

Width

Length
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Creating Reports

9. Creating Reports

9.1 Report Generator

Report Generator allows the user to create a print-ready document which can contain measured data, images,
graphs, etc. Once you start it by the File > Report > New Blank Report command, a graphical editor appears.

Ele Edt Page Vew bebp

DbHeE e ngm|
3

Protocol # 69

1IN O\

Project title:
Colocalization of Glycine receptor alpha 1 subunit (Gat)
and Gephyrin (GE)

E 2

Date: 4. 9. 2012

Labeling: Ga1 (Alexa Fluor 488), GE (CY3)
Dilution of primary antibody: Ga - 1:1000 (rabbit), GE - 1:200 (mouse)
Dilution of secondary antibody: 1:500

Location: Principal cells, the Medial Nucleus of the Trapezoid Body, Brainstem
Animal: Wistar rat

Gender: male

Age: P65

| Project description

Results:

Pearson's correlation = 0.868768

Mander's overlap = 0.895769

Mander's overlap coefficients k1= 0.977427, k2 = 0.820933
Colocalization coefficients c1 = 1.000000, c2 = 1.000000

B LABORATORY IMAGING

Za Drahou 17117
102 00 Praha 10
+420 272 081 400

www Iaboratory-imaging.com

Creating of a report in Report Generator is very similar to creating any document in a common text editor. You can
insert text fields, simple shapes, images, tables or graphs. As well as in text editors, you can create templates
containing objects which do not change such as headers and footers, but also dynamic objects to be filled with
data (e.g.: image name, author, etc) filled upon creation of the report. This comes especially handy in connection
with the Database module where database fields are loaded to the report(s) automatically.

9.2 Report Objects
A report is composed from report objects. In the left toolbar, there are tools for inserting different objects.

1. Select one of the tools
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2. Click and move the mouse inside the report to determine the area reserved for the object. Release the mouse
button.

3. Double-click the report object to open a window where its properties can be adjusted.

4. Confirm the changes by OK.

Tip

Vector objects (report objects, annotations, interactive measurement objects, ROIs) can be copied by “drag
and drop” while holding the Shift| key down.

1. Select the object(s).
2. Press Shif t| and drag the object somewhere.

3. A copy of the object is placed to where you release the mouse button.

9.2.1 Aligning Objects

AlignObjects = % = 7T # nl

You can align two objects to the same horizontal or vertical level.

1. Select more objects (e.g. by holding down CTRL |and clicking with the primary mouse button).
2. Right-click one of the selected objects and select the Align or Distribute > Align command from the context menu.

3. The objects will be aligned as indicated on the command icon.

4. If the Relative to Page ( * ) option is turned on, the objects will be aligned to the edges or the center of the
page.

Distribute Objects il =
Objects of similar size can be distributed uniformly in the horizontal/vertical direction.

1. Select three or more objects.

2. Right click one of the objects and select the Align or Distribute > Distribute Horizontally command from the
context menu.

3. Distances between the objects will be adjusted to equal.

1) is turned ON, the outer objects will be moved to the edges of the page.

-r

4. If the Relative to Page option (

Match Object Sizes

Sizes of objects can be unified too.

1. Select two or more objects.
2. Right-click the “master” object to the size of which you want to resize the other objects.

3. Select one of the Resize Objects sub-menu commands.

160



Creating Reports

9.2.2 Dynamic Data

Results of automatic-interactive measurement, graphs, or the current image can be inserted to reports.

1. Insert an object which can contain dynamic data (text, picture, table, or graph).

2. Right-click the object and select Insert Dynamic Data or Insert Dynamic Picture from the context menu.
3. A window appears.

4. Select one of the available sources, and click Next.

5. Finish the source definition and click |OK|. The data appear on the report page.

List of Available Dynamic Data Sources:

* Data inserted by user (available for: image, text, table) - the system will ask you to type a text or browse for an
image to insert during the report creation. When creating a dynamic object of this type, a query text which will
be used to prompt you for the data can be defined.

System data (available for: text, table) - enables you to insert some general data such as date, the name of the
user account currently logged in, the page number, or the page count.

* Macro (available for: text, table) - enables you to insert expressions, values, or results of a macro.

* Measurement (available for: text, table, graph) - enables you to insert results of automatic/interactive measure-
ment.

Database (available for: image, text, table) - this data source is displayed only when creating a database report
template (see below). It enables you to insert a link to any of the database records.

The real purpose of the dynamic data turns up when creating reports using report templates.

9.3 Report Templates

A report template is a layout defining the appearance of future reports, which is ready to be filled with data. The
data can be inserted by the user “on demand” or automatically (dynamic data).

To Create a Report Template

1 Run the File > Report > New Blank Report command. An empty report appears.

2. In the Report Generator, select File > Change to Template.
3. Edit the report template in the same way as a common report.

4. Insert the dynamic data where it is appropriate - measurement results to text boxes or tables, the current image
to the image field, etc.).

* Save the report template (*.rtt) via the File > Save E command.
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To Create a Report FROM Template

1. If the template is opened inside the Report Generator, run the File > Create Report command. Otherwise, use

the File > Report > New Report from Template > Browse command inside the main application window to
open a template from hard disk.

2. Areport opens and the dynamic data is inserted automatically.

3. Save the report, print it, or export the page(s) to PDF using the commands from the File menu.
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10. Macros

10.1 Creating Macros

A macro - an executable sequence of commands - can make the work very effective. NIS-Elements provides a C-
like programming language utilizing its internal set of functions. The sequence of functions can be created either
by recording the performed actions, by writing the functions within the macro editor, or by modifying the command
history (the history is recorded automatically during the work). The macro can be saved to an external (*.mac) file
for later use.

Recording a Macro

The fastest way to create a macro is to record it.
» Start the NIS-Elements macro recorder by selecting the Macro > Record command.
¢ Perform the series of actions you would like to record.

* Finish the recording by the same command again (its name changes to “Stop Recording”)

* It is recommended to check the macro in the macro editor before saving. Run the Macro > Edit /= command
to display it.

¢ Save the macro to a file via the Macro > Save As command.

Creating a Macro from History

You can create a macro using the list of recently performed commands.

1) Runthe Macro > Command History command to display the Command History control panel:

Command History x |

fq Execute H Create a Remove Reset
" selection macra -+ redundant history

DefineThresholdIntensity (0,188, 0); ]
DefineThresholdProcessing(2,3,0);
DefineThresholdBestrictionSi=ze (0, 0.0000.
DefineThresholdRestrictionCircularity (0.
Threshold();

EnablelUTs(1);

LUTs_KeepRutoScale(l);

=1 @y N s D R

8 Scantbjectsa{);

3 ImageSavels("C:\Program Files\NIS-Eleme. .
_DefineThreshold(); ] J foen § OB
[Number of commands: 39 [Free Memory: 8.1GE

2) Push the Create Macro button.
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3) Select what portion of the command history will be used in the macro:

|

Create macro from selected commands or whole command history?

Whole History l [ Cancel

Selection This option will use only commands which you have previously selected by mouse within the Command
History window. Group selection (holding Shift|or Ctrl|)is available.

Whole History All commands listed in the Command History window will be used for the new macro.

4) After you selected one of the options, the macro editor appears containing the new macro source code. Use

the editor to fine-tune it.

Note

The Remove Redundant command is automatically performed before the macro is opened in the editor.

Writing/Editing a Macro

If you posses programmers skills, a macro can be written by hand in the built-in macro editor. Run the Macro > Edit
#= command to display it.

.

SOHRB|9 G| 230 » =
foou £ € S| e | DERDT®R| S

WaitText (2., "Detection of poppy seeda™)

f*%% Pre — definition of threshold *#%/

DefineThreshold
® DefineThreshold(int RLow, int GLow, int BLow, int RHigh,
D SmoothBinary():

BinaryToReference():

The macro editor provides:
¢ Undo/Redo functionality.

¢ Command insertion from the list of available commands.

* Interactive command names list. Press Ctrl+Space |to display a simplified list of all commands while typing
the macro.

¢ Syntax hints (parameter types and names) appear as you type a command name.
* Bookmarks [[] can be placed to the code so you can easily roll to the important parts of the macro.
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° Breakpoints @ can be placed to the code. A breakpoint forces the macro to stop the execution at a certain
point so you can check the state of variables and therefore inspect the macro functionality thoroughly.

Syntax highlighting.
* Help on commands with detailed description.

* Use the Save Macro E and the Save Macro As... E} commands in the macro editor to save the created macro.

NIS-Elements automatically remembers the folder from where the macros were run the last time and will open
this folder when user clicks on Open/Save command in Macro menu.

10.2 Running a Macro

NIS-Elements provides several ways to run a macro.

° You can run the current macro loaded to NIS-Elements by choosing the Macro > Run fﬁ command or by
pressing F4|.

* A hotkey combination (Ctrl+Alt+1,2,3 ... 9) can be assigned to it in the Macro > Options £ window.

¢ You can run a macro at the beginning of the NIS-Elements session, by assigning the StartUp flag to the macro

in the Macro > Options 'l:I- window.
* You can run a macro saved to a disk by using the Macro > Run From command.

* Atoolbar button can be assigned to run a macro. See 3.3 Modifying Toolbars.

Breaking the Macro

The macro execution can whenever be stopped by pressing the Ctrl+Break |key shortcut.

10.3 Interactive Advanced Macro (API)

(requires: INTADV (Interactive Advanced Macro - API))

If the API module is installed, it dramatically extends the macro programing capabilities. It adds the following
functionality to the main application:

Loops and conditions Loops and conditions are enabled (if, for, while...)

User interaction functions Contains functions, which enable interaction with user like: type value, text, combo
boxes, list boxes and many other Windows standard controls with easy and intuitive code handling.

Support of importing functions from external DLLs Functions from external DLLs can be imported at the start of
the macro and used during the macro execution.

See 10.4 Macro Language Syntax.
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10.4 Macro Language Syntax

Specifies the NIS-Elements Macro Language features.

10.4.1 Variable types

The following data types are implemented:

char text

char8 <-128, +127>

byte <0, +255>

int <-32.768, +32.767>

int64 <-9.223.372.036.854.775.808, +9.223.372.036.854.775.807>
word <0, +65.535>

long <-2.147.483.648, +2.147.483.647>

dword <0, +4.294.967.295>

double <1.7E +/- 308 (15 digits)>

10.4.2 Structures and Unions

Structures and unions are not supported.

10.4.3 Arrays

One and two dimensional arrays are supported.

10.4.4 Local and Global Variables

You should declare local variables at the beginning of macro or function only. You should declare global variables
only at the beginning of macro. You can run two nested macros declaring the same global variables, but they must
be of the same type. You can declare global variables by prefixing the declaration global. Eg.:

global int Number Rows;
global char buffer[200];

The “global” keyword in front of the variable definition assigns the variable to the global scope. Such variable is
then accessible from all function scopes within the macro interpreter.
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10.4.5 Statements

Supported Statements

for (requires: INTADV (Interactive Advanced Macro - API))

The for statement lets you repeat a statement a specified number of times.

Syntax

for([init-expr]; [cond-expr]; [loop-expr])
statement

First, the initialization (init-expr) is evaluated. Then, while the conditional expression (cond-expr) evaluates to a non
zero value, Statement is executed and the loop expression (loop-expr) is evaluated. When cond-expr becomes O,
control passes to the statement the following the for loop.

while (requires: INTADV (Interactive Advanced Macro - API))

The while statement lets you repeat a statement until a specified expression becomes false.

Syntax

while (expression) statement

First, the expression is evaluated. If expression is initially false, the body of the while statement is never executed,
and control passes from the while statement to the next statement in the program. If expression is true (nonzero),
the body of the statement is executed and the process is repeated.

if, else (requires: INTADV (Interactive Advanced Macro - API))
Conditionally executes a statement or group of statements, depending on the value of an expression.
Syntax

if (expression) statementl
[else statement2]

The if keyword executes statementl if expression is true (nonzero); if else is present and expression is false (zero),
it executes statement2. After executing statementl or statement2, control passes to the next statement.

goto Transfers control of the program execution.

Syntax
goto name;

name: statement
You cannot use goto to jump inside the block from outside. E.g. following is not allowed:

goto label;
if (k>5)
{
label:
DilateBinary (3, 5);
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FillHoles () ;
}

You cannot use goto to jump out from the block more then 2 block levels down. E.g. the following is not allowed:

for (i=0; 1i<64; i=i+1)
{
for (3j=0; j<64; j=j+1)

if(ali]l > b[il)
{
value = i;
goto end; // crossing 3 right brackets
}

end

break Terminates the execution of the nearest enclosing statement.

Syntax

break;
The break keyword terminates the execution of the smallest enclosing for or while statement in which it appears.
Control passes to the statement that follows the terminated statement.

continue Passes control to the next iteration of the statement in which it appears.

Syntax
continue;

The continue keyword passes control to the next iteration of the for or while statement in which it appears. Within
a while statement, the next iteration starts by reevaluating the expression of the while statement. Within a for
statement, the first expression of the for statement is evaluated. Then the compiler reevaluates the conditional
expression and, depending on the result, either terminates or iterates the statement body.

Statements which are not supported

do, switch, case, default, typedef These statements are not supported.

10.4.6 Directives

The following directives are supported by the system:

define The #define directive assigns a meaningful name to a constant in a program.
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//Syntax

#define identifier token-string

The directive substitutes token-string for all subsequent occurrences of the identifier in the source file. Token-string
can be a value or a string (only for 32-bit version of NIS-Elements).

//Example

#define ERROR_SPRINTF 0
#define MAINDIR "c:\Images"

int main ()

{

char buf[256];
int retval;

retval = sprintf (buf, "%s", "MAINDIR");
if (retval == ERROR SPRINTF)

Beep () ;

else WaitText (0., buf);

return TRUE;

FoA

include Specifies the name of the file to be included.

//Syntax

#include filename

The #include directive includes the contents a file with a specified filename in the source program at the point
where the directive appears.

Example
// if you do not specify the full path, NIS-Elements assumes, that it is a \
relative path to a main directory

#include "macros\my macro.h"
#include "c:\NIS-Elements\macros\my macrol.h"

import (requires: INTADV (Interactive Advanced Macro - API))

The #import directive is used to incorporate information from an external library.

//Syntax
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#import ("DLLname") ;
#import function declaration

NIS-Elements can call functions from external DLL's. You should import the DLL, where the functions resides and
then make a declaration of the functions. You should not import the following system DLL's: kernel32.dll, user32.dll,
gdi32.dll, com32.dll, comdIg32.dll. This feature is available only for 32 bit version of NIS-Elements.

//Example

#import ("luc_13.d11");

#import int RTF ReplaceVariables (LPSTR destfile, LPSTR sourfile);

#import int RTF FindQuestion (LPSTR sourfile, LPSTR question, long *length, \
LPSTR defvar);

#import int RTF ReplaceQuestion (LPSTR destfile, LPSTR sourfile, LPSTR \
replacement) ;

__underC (requires: INTADV (Interactive Advanced Macro - API))
The __underC directive assigns a function to be interpreted by the UnderC engine instead of the standard interpreter.

//Syntax
//works only on 32bit operating systems

~_underC int inter sharpen(int cols, int rows) { }

#importUC (requires: INTADV (Interactive Advanced Macro - API))

The #importUC directive imports an API function to the UnderC engine so that it can be used from within there.

//Syntax
//works only on 32bit operating systems

#importUC DisplayCurrentPicture;

10.4.7 Operators

The following operators are supported by the system.

Caution

Precedence of operators in NIS-Elements is different than might be expected. See 10.4.8 Priority of Operators

.

arithmetic operators

+ Addition
- Subtraction
* Multiplication

/ Division
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% Modulo

assignment operators

The assignment operator assigns the value of the right operand to the left operand.
= Addition

bitwise operators

The bitwise operators compare each bit of the first operand to the corresponding bit of the second operand. The
following bitwise operators are supported.

& Bitwise AND
| Bitwise OR

~ One's complement
pointer operators

& Address of ?

* Indirection

relational operators

< Less than

<= Less than or equal to
> Greater than

>= Greater than or equal
== Equal

I= Not equal

logical operators

The logical operators perform logical operations on expressions. The following logical operators are supported:

&& Logical AND
|| Logical OR
! Logical NOT

Caution

Precedence of operators in NIS-Elements is different than might be expected. See 10.4.8 Priority of Operators
().

10.4.8 Priority of Operators (!)
If an expression contains more than one operator:

* Logical operators are evaluated from right to left!!!
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¢ |t is recommended to always use brackets to define different evaluation order:
Example 10.1. Priority of logical operators in NIS-Elements
if( 'a && 'b )
is evaluated by NIS-Elements as
(a && ! (b)) \
To make it work as expected it should be written as:

if( (la) && (!b) )

* Priority of arithmetic operators is standard, division (/), multiplication (*) and modulo (%) have higher priority
then other operators.

10.4.9 C-like functions

The system can interpret your own C-like functions. An entry point to program is the main() function in your macro.
If main() is not presented, for backward compatibility, the body of the macro is also considered as "main function".
The new macros should use main() as an entry point.

The general C-like functions (also called interpreted functions, as opposed to basic system functions from NIS-
Elements) have the following syntax.

Syntax

int MyFunction (int a, LPSTR str, double d)
{

int retval;

return retval;

}

Return Value The return value can be any basic data types (char, int, word, dword, int, double or pointer).

Parameters Parameters can be any basic data types (char int, word, dword, int, double or pointer).

Note

Int and double parameters are automatically converted to string type, when they are assigned to text variable,
or are one of the parameters of a function.

Example
int main ()
{
char buf[256];
my functionl (buf);
WaitText (0., buf);
return TRUE;
}
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int my functionl (char *buf)

{

strcpy (buf, "This function has a pointer to char array as a parameter");
return TRUE;

10.5 Controlling Cameras by Macro

Every camera can be controlled from within a macro by changing its properties. There is a CameraGet_* and
CameraSet_* macro function available for each camera property (e.g. CameraGet_ExposureTime();). The number
of functions (beginning with CameraSet_and CameraGet_) and their actual names depend on the type of camera(s)
you have currently connected to NIS-Elements.

CameraGet_ The CameraGet._... functions retrieve current values of the properties determined by the function
name postfix. So the CameraGet Exposure (int Mode, double *Exposure); function retrieves the
current value of Exposure of the specified Mode.

CameraSet The CameraSet_... functions allows you to adjust camera properties. So the CameraSet Expos-
ure (int Mode, double *Exposure); function sets a new Exposure value for the specified Mode.

How To Set Camera Properties

Instead of describing each property function, it is better to show you a universal way to handle a camera by macro:

1) Display the View > Acquisition Controls > [Camera name] Settings "8 control panel and find the property you
would like to control.

2) Make a change of the property from within the control panel. For example, change the exposure time.

3) Display the View > Macro Controls > Command History €¥) window and see the last function which has been
called and its parameters (e.g. CameraSet_ExposureTime(1, 500);). This is the function you will control the
exposure time with.

4) Experiment with the camera control panel in order to determine the right parameter values of the functions
to be called within your macro.

10.6 Macro Preferences

This window enables you to configure key shortcuts to macros and set a macro to run automatically on startup.
Run the Edit > Options 'I:l' command and switch to the Macro tab.

Macros Lists of macros that can be executed using hot keys or automatically at the beginning of the NIS-Elements
session.
Start Up To launch a macro automatically after starting the NIS-Elements program, select it and press the
StartUp| button. StartUp field of the selected macro in the list box is filled.
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Hot Key To assign a hot key to a macro, select the macro in the macro list box and press the |Hotkey| button.
Select one of the predefined key combination and press |OK| button.

Full Path Shows the full pathname of the selected macro.

Add Adds a macro to the macro list box. Select Macro dialog box appears and you can search the disk for the
macro.

Remove Removes a selected macro from the macro list box.

Edit Enables to edits a selected macro from the macro list box.

Filename substitution These lines display the current values of substitution strings available in macro commands.

# Letter representing a drive e.g. “C”
## A customizable path e.g. “C:\Images”

### Path to a directory according to the macro function used. It leads to the folder where NIS-Elements EXE
file is placed and to a subdirectory - “Images” for functions concerning image files or “macros” for functions
concerning macros. E.g.:

ImageOpen ("###\agnor.tif"); //leads to the IMAGES subdir
RunMacro ("###\macro 001.mac"); //leads to the MACROS subdir

###t#, ##i### The current filename including/excluding the path. These substitutions can be used with the
Sequences or SequencesEx macro commands.

Information Shown in Caption Optionally, the name of the current macro and an arbitrary user text can be displayed

inth

e NIS-Elements caption.

Defaults for this Page Restores the default setting for Macro Options.
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11. Movies

11.1 Capturing AVI Movie

1. Display the AVI Acquisition control panel by the Acquire > AVI/MP4 Acquisition command.

2. Adjust the advanced settings, especially define the file name and the destination folder.

3. Click the Record button. The live image appears and recording starts according to the settings.
4. Stop recording by the Stop button, or wait until the time defined in the Duration field passes.

5. When stopped, the AVI file remains opened in a new image window.

11.2 Save ND2 as AVI

You can easily create an AVI movie from an ND2 file. Run the File > Save As command and select the AVI format
in the Save As Type: pull-down menu. The Save As window is extended by the following options:

Use Default Video Compression Either leave this box checked or select which video compression will be applied
to the movie file. See 11.4 About Video Compression.

XY Loop When the ND document contains XY points, you can decide how these are saved.
Current XY Only the currently selected XY loop will be saved as a movie.

All XY in separate files A movie will be saved for each XY loop present in the ND2 file. An automatic number
will be appended to the file name.

Output Timing Parameters Timing of frames of the resulting AVI movie may equal the Original Acquisition Time. If
this does not suit your needs, define a custom interval in ms.

Experiment Loop Select the dimension, frames of which will be used to create the AVI movie.
Use Time Loop The T dimension frames of the current Z stack position will be used.

Use Z-stack Loop The Z dimension frames of the current Time position will be used.

Use Z-stack and Time Loop All frames of the ND2 file will be used in the AVI movie.

Note
If you have the QuickTime Player installed on your PC, a QuickTime movie (*.mov) can be created as well.

11.3 Creating a Movie from EDF Surface View
(requires: EDF Module (Extended Depth of Focus))

11.3.1 Creating a Movie Step by Step

1. Open a Z-Stack image and use the Applications > EDF > Create Focused Image W .
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' Display the surface view by the Applications > EDF > Show Surface View command.

3. Run the Movie Maker by the %4 button.

4. Adjust the movie settings by the Settings button a window appears where the movie duration and frame rate
can be defined.

5. You can use one of the predefined presets or import some previously defined key frames by the Export / Import
button.

6. Either enable or disable the Director's mode by the clapper button. See 11.3.3 Directors Mode.

7. Go to the beginning of the time line and define the initial zoom, position, rotation or component appearance of
the object. This step is not necessary, but very much recommended. Press the Add/Update key frame button to
fix the initial appearance.

8. Browse the time line, modify the object position each time, and set key frames by clicking the Add/Update key
frame button. Press the Play Movie button for a preview.

9. When all the key frames are properly set, press the Create Movie button. The movie is created and the AVl file
will open in a new image window.

10 Save the new file by the standard File > Save As command.

11.3.2 Movie Maker Controls

When you start the movie maker, the following bar appears at the bottom of the image view. The user is supposed
to create a set of key-frames. The rest of the movie will be created by interpolation between these key frames. This
gives the user absolute freedom in how the movie will look like.
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1. The Clapper button. By this button, the director's mode can be turned on/off. See 11.3.3 Directors Mode.

N

. Time line. By clicking to the time line you can browse the movie frames. When a key frame is added, a bold line
appears in the time line to indicate its position.

. First Frame, Play, Last Frame buttons.
. Settings - by this button, you can define the movie length and the frame rate.

. Create Movie

o o b~ W

. The key frame buttons. The existing key frames may be browsed by pressing the Previous frame / Next Frame
buttons. The Add / Update Key Frame button inserts a key frame to the current position on the time line.

7. Presets - a predefined rotation can be loaded. When you press the button and select the rotation type, the existing
key frames settings will be overwritten.
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8. Import/Export Key Frames - this enables you to save and load the key frame settings. A file with the *.KEY ex-
tension will be created during the export.

11.3.3 Directors Mode

In the directors mode it is not needed to press the Add/Update key frame button every time the position of the
object is changed. The director's mode detects all changes made to the object position and adds a key frame to
the time line whenever such change is detected. A typical work-flow would look like this:

1. Turn ON the directors mode by the Clapper button. The time line gets highlighted with red color.
2. Click to the time line where a certain position of the object shall occur.

3. Move the object by mouse or adjust it in some way (zoom, crop, etc.) - at this moment, the key frame will be
added to the time line automatically.

4. Click to the time line where another position shall occur, and so on...

The director's mode shall be used when you know precisely how the movie shall look.

11.4 About Video Compression

It is common to encode (compress) movies in order to save some disk capacity. This can be done using various
types of codecs. A video codec is a software tool which can code (compress) and decode (decompress) video files.
Remember that the codec you use to save the video will be required for playback as well (when playing the video
on other computers).

Look at the list of codecs coming with NIS-Elements by default. If other codecs are installed on the computer, they
become also available to NIS-Elements.

Caution

32bit operating systems provide better choice of codecs because a 64bit codec must be used on a 64bit op-
erating system, but there are not many of those in the meantime.

NIS-Elements compression options

We performed a test by converting a 1 GB / 4000 frames ND2 file to AVI using different codecs. The results are
displayed in the list:

No compression Original quality, file size: 787 MB.

DV Video Encoder This codec produces only videos with 640 x 480 resolution. Videos with other resolutions are
stretched to fit, therefore we do not recommend to use this codec.

MJPEG Compressor Very good quality, file size: 240 MB.

Cinepack Codec by Radius Average quality, file size: 70 MB.

Intel IYUV codec Very good quality, file size: 390 MB. Provides the best quality / compression rate.
Microsoft RLE Very poor quality, file size: 90 MB.

Microsoft Video 1 Very poor quality, file size: 6 MB.
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Object Count Procedure Example, 128
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